Libva error: vaGetDriverNameByIndex() failed with unknown libva error, driver_name = (null)

Hi everyone,

I’m a noob on Linux as I just started learning to code thanks to The Odin Project. I’m starting to see why so many people are in love with this OS. And from what I’ve read here and there on the net, the Linux community is awesome.

Without further ado, using the terminal I’ve hit a little problem when opening a .html file. I get the error message mentioned in the title line. I believe it’s no biggie since the browser DOES display the file as intended. But since I like running things ‘clean’, I tried finding info inquiring over almighty Google and I haven’t found anything relevant to my case, that is Ubuntu Jammy Jellyfish. If anyone can share their knowledge, I’d be forever grateful.

Here are my specs if it helps:


Kernel: 5.15.0-33-generic x86_64 bits: 64 compiler: gcc v: 11.2.0
Console: pty pts/1 Distro: Ubuntu 22.04 LTS (Jammy Jellyfish)
Type: Desktop Mobo: ASUSTeK model: ROG STRIX X570-F GAMING v: Rev X.0x
serial: UEFI: American Megatrends v: 1405 date: 11/19/2019
RAM: total: 15.54 GiB used: 2.56 GiB (16.5%)
Array-1: capacity: 128 GiB slots: 4 EC: None max-module-size: 32 GiB
note: est.
Device-1: DIMM_A1 size: No Module Installed
Device-2: DIMM_A2 size: 8 GiB speed: 2666 MT/s type: DDR4
Device-3: DIMM_B1 size: No Module Installed
Device-4: DIMM_B2 size: 8 GiB speed: 2666 MT/s type: DDR4
Info: 6-core model: AMD Ryzen 5 3600X bits: 64 type: MT MCP arch: Zen 2
rev: 0 cache: L1: 384 KiB L2: 3 MiB L3: 32 MiB
Speed (MHz): avg: 2733 high: 3800 min/max: 2200/4409 boost: enabled
cores: 1: 3800 2: 2200 3: 3800 4: 2200 5: 3800 6: 2200 7: 2200 8: 2200
9: 2200 10: 2200 11: 3800 12: 2200 bogomips: 91025
Flags: avx avx2 ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 sse4a ssse3 svm
Device-1: AMD Navi 10 [Radeon RX 5600 OEM/5600 XT / 5700/5700 XT]
vendor: Sapphire driver: amdgpu v: kernel bus-ID: 0a:00.0
Device-2: Logitech Webcam C270 type: USB driver: snd-usb-audio,uvcvideo
bus-ID: 5-4:4
Display: server: X.Org v: driver: gpu: amdgpu
note: X driver n/a resolution: 1: 2560x1440~60Hz 2: 2560x1440~60Hz
OpenGL: renderer: AMD Radeon RX 5700 XT (navi10 LLVM 13.0.1 DRM 3.42
v: 4.6 Mesa 22.0.1 direct render: Yes
Device-1: AMD Navi 10 HDMI Audio driver: snd_hda_intel v: kernel
bus-ID: 0a:00.1
Device-2: AMD Starship/Matisse HD Audio vendor: ASUSTeK
driver: snd_hda_intel v: kernel bus-ID: 0c:00.4
Device-3: Razer USA RC30-026902 Gaming Headset [Nari Essential Wireless
type: USB driver: hid-generic,snd-usb-audio,usbhid bus-ID: 1-6:2
Device-4: Logitech Webcam C270 type: USB driver: snd-usb-audio,uvcvideo
bus-ID: 5-4:4
Sound Server-1: ALSA v: k5.15.0-33-generic running: yes
Sound Server-2: PulseAudio v: 15.99.1 running: yes
Sound Server-3: PipeWire v: 0.3.48 running: yes
Device-1: Intel I211 Gigabit Network vendor: ASUSTeK driver: igb v: kernel
port: f000 bus-ID: 04:00.0
IF: enp4s0 state: up speed: 1000 Mbps duplex: full mac:
Local Storage: total: 2.71 TiB used: 33.54 GiB (1.2%)
ID-1: /dev/nvme0n1 vendor: Crucial model: CT1000P5SSD8 size: 931.51 GiB
temp: 42.9 C
ID-2: /dev/sda vendor: Crucial model: CT500MX500SSD1 size: 465.76 GiB
ID-3: /dev/sdb vendor: SanDisk model: SDSSDXPS480G size: 447.13 GiB
ID-4: /dev/sdc vendor: HGST (Hitachi) model: HTS541010A9E680
size: 931.51 GiB
ID-1: / size: 66.63 GiB used: 33.51 GiB (50.3%) fs: ext4 dev: /dev/sda3
ID-2: /boot/efi size: 99.2 MiB used: 33.8 MiB (34.1%) fs: vfat
dev: /dev/nvme0n1p3
ID-1: swap-1 type: file size: 2 GiB used: 0 KiB (0.0%) file: /swapfile
System Temperatures: cpu: N/A mobo: N/A gpu: amdgpu temp: 51.0 C
Fan Speeds (RPM): N/A gpu: amdgpu fan: 775
Processes: 343 Uptime: 2h 34m Init: systemd runlevel: 5 Compilers: gcc: N/A
Packages: 1724 Shell: Bash v: 5.1.16 inxi: 3.3.13

Just did again the same command in the terminal, that is ‘google-chrome index.html’, and now I get this message:

google-chrome index.html
libva error: vaGetDriverNameByIndex() failed with unknown libva error, driver_name = (null)
[15611:15611:0524/] Failed to call method: org.freedesktop.ScreenSaver.GetActive: object_path= /org/freedesktop/ScreenSaver: org.freedesktop.DBus.Error.NotSupported: This method is not implemented
[15611:15611:0524/] Failed to call method: org.gnome.ScreenSaver.GetActive: object_path= /: org.freedesktop.DBus.Error.UnknownMethod: Object does not exist at path “/”
[15654:15654:0524/] GetVSyncParametersIfAvailable() failed for 1 times!
[15654:15654:0524/] GetVSyncParametersIfAvailable() failed for 2 times!
[15654:15654:0524/] GetVSyncParametersIfAvailable() failed for 3 times!

I really don’t understand.

Sometimes you have to abandon that desire, when running Linux. There are tons of warnings and errors when doing a variety of operations on Linux. For example, during bootup there are tons of warnings and erros. However, users are always told to just ignore them, as they are benign.

As with your example, it does seem relatively benign too, as it is specifically referencing screensaver activity. So, it shouldn’t be a big deal.

1 Like

libva is software for video acceleration
You say the error happens when you open an .html file
So I would be looking to see if all the needed video card drivers are loaded.
Use dmesg
you will get heaps of stuff about what is happening as the system boots. Look for messages about error or missing driver

If you find something, look for a package with drivers for that device and install the package… Then reboot and see if it is fixed

Sorry that is complicated for a beginner.


1 Like

Thanks for your help. I used the command dmesg as you suggested and have found no missing drivers or error using the search function. The issue seems to be related to my amd gpu driver. So I looked up the AMD website for drivers and I’m now wondering if I should downgrade Ubuntu to 20.04 since AMD has drivers for that version unlike none for Jammy Jellyfish.

Or again, I’m wondering if I should just plainly ignore it altogether like @Akito said. I mean beside the error message, there’s no hangups, crashes or anything serious.

It’s alright. That’s exactly how I learn. :slight_smile:

1 Like

I have a shellscript that uses w3m to render HTML in a terminal - is that what you’re looking for?

/usr/bin/w3m -dump HTML-file.html | less

Because it’s using “less” as the pager, you can even search using vi commands…

Had a dump of a massive stack of Wiki pages in html files… needed some way to digest them - this was my solution…

Hi daniel,

Actually, I didn’t even know you could render HTML in the terminal.
My issue is just a minor hiccup that I’ve ran into while opening a html file in the terminal using google-chrome index.html command line. Beside the error msg about libva, there’s no real issue.
Also correct me if I’m wrong, since 22.04LTS is fresh out of the oven, I guess many hiccups are still present in its current state. I’m guessing it’ll get ironed out as the OS gets updates OR I just gotta wait for AMD to release GPU drivers for Jammy Jellyfish.

Nevertheless, thank you for your input.

I tried Jammy Jellyfish for a few hours - until it also had USB 3 ports stop working on me (the reason I jumped from Fedora 35 to Ubuntu 22.04). So far so good with 20.04 been up since Sunday at least, USB 3 ports have stayed up since…

I was using (I’m still using) an AMD GPU - Radeon RX 6600/6600 XT/6600M with 8 GB of DDR5…

The drivers were MUCH better under Jammy Jellyfish than they are under Focal Fossa! My system got a a vastly better Geekbench5 score under Fedora 35 and Ubuntu 22.04, than in Ubuntu 20.04 - but - I can’t live with flaky USB 3 support - I might wait till Ubuntu 22.04.1 and see if that’s fixed my issue with USB 3 (no searches so far have found anyone else having same/similar in Fedora 35 or Ubu 22.04).

They’re here, they’re now - nobody has to wait for AMD - Radeon has been open sourced, and the OSS drivers are BETTER than Catalyst from AMD, and I’m pretty sure AMD recommend using the OSS drivers…

Sorry for asking a noob question, how do you install amd drivers on 22.04? I mean, this is my current driver (the default one) for my rx 5700XT:

description: VGA compatible controller
product: Navi 10 [Radeon RX 5600 OEM/5600 XT / 5700/5700 XT]
vendor: Advanced Micro Devices, Inc. [AMD/ATI]
physical id: 0
bus info: pci@0000:0a:00.0
logical name: /dev/fb0
version: c1
width: 64 bits
clock: 33MHz
capabilities: pm pciexpress msi vga_controller bus_master cap_list rom fb
configuration: depth=32 driver=amdgpu latency=0 resolution=2560,1440
resources: irq:142 memory:e0000000-efffffff memory:f0000000-f01fffff ioport:e000(size=256) memory:fcc00000-fcc7ffff memory:fcc80000-fcc9ffff

Beside the libva issue, I haven’t encountered anything serious. Well, there’s VLC refusing to re-launch without reboot if I closed the program once. Again, nothing serious. Just annoying :confused:

Are you seeing some message, but unsure if it’s stopping you doing, what you want to do?

i.e. other than the message, is this preventing you doing something?

Note : you don’t have to do ANYTHING at all - Ubuntu installs and runs the open source AMD drivers for you automatically! i.e. it’s done for you…

Even on Ubuntu 20.04 - the OSS AMD drivers are automatically installed…

You only have to do “manual” stuff for GPU if there’s some thing SPECIFIC you need offered by the Catalyst drivers - or - you’re running an NVidia GPU, because the OSS drivers for NVidia (Nouveau) were pretty shit - but apparently - NVidia have now open sourced a great chunk of it now…

To me it seems you’re finding errors, that aren’t symptoms of some failure, and you’re assuming 'cause on Windows you have to install drivers, that’s the case with Linux - in most cases Linux is more plug and play than anything from Microsoft…

Good on you. Yes, graphics cards have a lot of trouble with drivers. At least you have AMD… that has better support in linux

I think I would ignore it. You might update your OS and find other troubles more serious.


To answer your question, indeed no. There’s nothing stopping me doing what I want. Everything is smooth. I guess it’s my desire to run things clean, but as another user mentioned before, it’s something I should ignore and move on.

You’re right, it’s probably my Windows experience that is driving me to find an unnecessary solution. I just started using Linux a week ago. I guess I’m just looking for solutions when there are none.

I sincerely apologize if I have been wasting your time. My curiosity got the best of me.

Thank god AMD is open-source. As you said, and like everyone did, too, I’ll just ignore it and move on.

Nevertheless, thanks for the feedback. I’ll just close this thread as solved.

Thanks everyone.


Thank god <software-name> is open-source.

That’s always a good sentence! :grin: