Linux and HP Envy-17 laptop

My experience with Linux on this laptop has been very frustrating so I gave up however my old HP e6930p has been very stable with Linux Mint and now that I found out it can run the 64-bit version, I’m set for a few years. I am interested in knowing if any of you have had similar experiences. Here is the story:

  • First attempt was Ubuntu and that worked well except for the Realtek Network driver. I was able to recover once but after a kernel update, that was it. I might be able to restart it and compile the Realtek drivers today but …
  • In my next attempt, I installed Linux Mint Cinnamon. It worked well for a little while but suddenly would not boot anymore. The live USB would not boot either so I could not troubleshoot and try to recover. This has happened twice with Cinnamon 64-bit.
  • I tried Solus 4.3 for a while and it worked well until it stopped booting also.
  • This laptop worked well under Windows 10 and now Windows 11. I’ll stick to it on this laptop.

I’m not trying to get it to work anymore so I’m not asking for help but have any or you had similar experiences? I’ve been learning as much as I can about Linux but I’m not an expert by any means. If anyone has an idea why this has happened, I’d appreciate your feedback.

Hi Elroy,
What is happening with that HP Envy laptop, seems to indicate that the hardware is too new for Linux to have proper working driver modules for all its components. The fact that it works with Windows seems to confirm that… Windows always has drivers for the latest hardware.
There are a couple of things you can do if you wish

  • some Linux distros release special editions with more uptodate drivers, that are still being tested and therefore not in the standard edition. The ones I know of are
    Linux Mint “Edge” edition… edge refers to leading edge… nothing to do with Edge browser
    Linux MX “ahs” edition… ahs stands for advanced hardware support
    You could try one of those
  • Rolling release distros have more uptodate driver software. Rolling release distros can be a bit more difficult. In order of difficulty I would mention Solus, Manjaro, Void, Arch, Gentoo.
    You said that you tried Solus. The booting problem might be a different issue.
  • Wait for your favorite distro to get more uptodate driver modules. This usually means wait for a new kernel… the driver modules are part of the kernel. You may have to wait something like 2 years for Debian to catch up, less for other Distros. Given that you have another machine, waiting may be acceptable option.

We can look closer at the booting issue if you want. I think you might be doing something there that can be fixed. Booting does not usually fail once you have it working, unless the machine has a hardware fault, and that seems unlikely given that windows works. If it will not even boot a usb drive that is very strange indeed? I wonder if you have an issue with secure boot? You generally need to turn secure boot off for Linux

Thanks for writing, and let us know how you get on.



When I built my desktop machine a few years ago I used a MB and CPU that had been released only a few days prior. Installing the then-current Ubuntu LTS release resulted in a blank screen. Someone suggested that I try the daily build of the ISO and that worked perfectly.

Thank you!

I was about to delete the partition but decided to give it another try with the live USB and it booted ok so I tried rebooting on my disk but went through all the grub options first after which it booted up fine. Checking for new drivers identified a new nvidia driver (must be very recent since I had already installed the recommended one two weeks ago) so I installed the new one. So far so good except that Thunderbird won’t connect to gmail on this laptop and it’s the most useful application.

Neville’s comment about missing an adequate driver seems plausible as the screen was going blank at about the time when the logging screen would pop up. So I’ll keep playing with it for a while. Thank you both!

That might be a network card driver problem.

I would be trying a live usb of either MX"ahs" or Mint “Edge” editions

Keep going you will get something that works. It is not an impossible issue.

Yes, Don, that should bring in the lastest drivers Ubuntu has.
It is a bit more drastic than Mint “Edge” edition , but it is worth the risk to get a new machine working.

There is also backports. That did not work for me, I needed very new drivers.

Truth is Gmail used to work fine on this computer with Ubuntu and Solus before they crashed. It is still working fine with Windows 11 in the Edge browser at the moment so I’m ruling out hardware. It’s also working fine on the old laptop that I am using now.

I tried Gnome-mail, Thunderbird, and the Firefox browser. Also tried Chrome a while back to no avail. This seems to be a new security feature implemented by Google resulting on google refusing the connection. It is strange that gmail should work with other versions of linux.

Mint crashed again and would not boot from either the hard disk or the live USB (neither Cinnamon or Xfce) until I went into recovery mode with a previous kernel version. I rebooted the computer with the previous kernel 5.15.69.xx and it booted fine. When I tried Thunderbird, google asked me for a confirmation code and now gmail works fine.

I had added another two-factor authentication to my google account yesterday but it never asked for authentication until I loaded the previous kernel. I think I’ll hold off doing updates for a while.

That is strange. Are you sure you are not having trouble with ethernet or wifi card drivers?
Can you ping google?

Maybe Google thinks your upgraded OS is a new computer and it wants you to re-authorize.

When you say ‘would not boot’ how far into the boot process does it get? ie does grub work? Does the initramfs load? Do you get down to a kernel panic?

My gmail seems to be still working, without any extra authorization? I can use gmail from thunderbird?

think I’ll hold off doing updates for a while.

Yes that makes sense. There may be issues with the kernel version in the update.
I still suspect driver problems… the modules that come with the upgrade kernel may have issues… both with the graphics card and with the network card.
The email seems to be a separate problem. It is confusing when 2 issues happen at once.

The live Cinnamon USB that I was using was warmer than I anticipated after I took it off so it may be faulty - the booting up would hang at random parts. The Xfce usb would stop at the logging screen that went blank. Before going any further, I’ll burn up a new Cinnamon USB.

Good thinking. That makes sense

Xfce usb would stop at the logging screen that went blank

Thats most likely a graphics card driver issue. That is when it first starts to use X11 (or Wayland) and the Linux drivers in the kernel. Before that the screen is being driven by the primitive bios drivers.
By the way, is it using Wayland?

It’s possible but I’m not sure how to find it; would “locate wayland” in a terminal window do or do I have to look deeper? As I mentioned, I’m not that proficient.

Anyway, this has become a moot point as Mint totally failed on my laptop yesterday. It starts by hanging up during bootup forcing me to shutdown using the power switch. It gets progressively worse after that. I’m in the process of installing Ubuntu 22.04LTS. The previous version worked for over a year on this laptop so we’ll see.

Thanks for your help!

If you have wayland, it is usually offered as a choice on the login screen. If there is no choice, you probably have X11.

Mint totally failed on my laptop yesterday. It starts by hanging up during bootup forcing me to shutdown using the power switch. It gets progressively worse after that.

There is something strange about this… we are not getting on top of it?
Intermittant faults are not usually software related.
Are we sure the hardware is OK? Does it run Windows?

1 Like

Never noticed Wayland in the Mint system but I get many references to wayland on the same laptop with Ubuntu when I run xinput at the terminal window.

The last update done on the Mint system was systemd and something went wrong - something about a broken package. It did not affect the system until the next boot when it hung at various steps in the sequence. Booting up the previous kernel worked once. Could I have recovered from the broken package and how? I’m guessing I would need to do this from a terminal window.

Anyway, I’m running Ubuntu now and so far so good. All versions of Linux that I tried so far have had problems with nvidia and realtek drivers. The nvidia driver update resolved the issues in all cases but for Realtek, it’s been hit and miss so I obtained the realtek drivers r8168 from Realtek and can install it if I need to with Ubuntu.

It’s been frustrating but I’m learning. Thanks.

Looks like you solved it.
Bad graphics drivers can lead to all sorts of strange behaviour.

If you get any more intermittant faults, you should check your hard disk