Linux Mint Cinnamon question

Can anyone show me how to get a terminal window icon into the panel of a Cinnamon desktop.?
Is Cinnamon able to save the X session on shut down and restore it at boot?

1 Like

If you go into the menu, locate the Terminal application (probably under Administration or such like) and right click, it offers you the option to ‘add to panel’. The change is permanent (i.e. will be retained at next boot).

I too like to have the terminal available from the panel.

4 Likes

Hi Neville,

I am running Mint Cinnamon and the terminal icon is already in the panel. But if you bring up the menu and search for terminal, then right click on the name, you should get some options. Add to desktop, add to panel, etc.

I assume “X session” is terminal session. I always copy it to a text file if I want to save it before I re-boot if I want to look at it later.

Not much help … sorry.

4 Likes

Thank you, that is easy.

Thanks Howard. I should have known that.

In Xfce there is a setting to save the whole desktop when you shutdown. Then when you boot and login, all your windows are there on the screen, and in the same state as when you logged out.
I dont think Cinnamon has that. Its called saving your Xsession. Mint may not even be X11, it may be Wayland for all I know?

I just press ctrl-alt-T.
It works in most DE, I think it should work on Cinnamon too. If it works, certainly the quickest way to launch a terminal.

4 Likes

Hey, it works like magic.
Perhaps I need to learn a few keyboard shortcuts.

4 Likes

It’s Super-T in Pop-OS!

2 Likes

I remember that caused you an issue a while back. Something about starting all kinds of stuff at restart time and there was some sort of issue. I think you had to get rid of something that was running before it would restore you last window arrangement. I forget the details now.

Can you explain Super?

Yes it slows up the boot. I put up with it. For some reason much worse in Void/Xfce than in MX or Gentoo.

It’s labelled as the “Windows” key on the keyboard. But in Linux it would be weird to call it “Windows”, so it’s the “Super” - I think. :slight_smile:

Edit:

I remember the name “Super” from the time I tried XFCE. :wink:
Now, in MATE on my Debian it is called “Mod4”.
Just tried to set Super-T to launch a terminal, it shows as “Mod4+T” in the shortcut manager.

3 Likes

@kovacslt ,
Thank you for Super explanation.
I am in VoidXfce at moment . Ctrl Alt T works on the main screen, and in a VM.
Super T does not work.

1 Like

I have to remember which distro I’m on. For example Pop_OS! uses Super-T, but Ubuntu uses Ctrl-Alt-T I believe. I don’t bounce around a ton, but enough to confuse me.

1 Like

This shortcut easily customizable. Why don’t you set it to be the same across all your distros? You don’t have to use the defaults everywhere.

3 Likes

Doesn’t work for me on Pop!_OS (Super+T)
Not that I need it - I have it on my dock (the default gnome “panel” in Pop!_OS but configured as an autohide bottom dock, instead of “extended” panel) - and just tried super (sometimes called “meta”) + T on my Ubuntu 23.04 thinkpad, and doesn’t do it there either - but - I also have a dock (Ubuntu Gnome 3 dock) there with terminal on it…

And that’s the exact same way I fire up a terminal on MacOS too - iTerm2 in the dock…

1 Like

Hmmm. I have an Ubuntu 23.04 VM and it uses the standard Ctrl-Alt-T.

My Pop_OS! uses Super-T. I checked in Settings > Keyboard > View and Customize Shortcuts > Launch Terminal. Here it shows Super-T. I don’t know for a fact that is the default. Maybe I customized it at some point in the past few months.

I customised my Pop!_OS so that Super+C and Super+V would do copy and paste, respectively, for consistency across MacOs and Linux…

It was pointless really - as for some reason, Synergy doesn’t send Super to MacOS synergy clients…

I’ve just tried to google solutions (send Super to MacOS clients) and the only hit in the synergy forums is a link to Symless Zendesk, and I don’t have an account there - so much for my Synergy Pro license!

I fixed my Synergy issues…

I thought I had to modify “Modifier keys” on the server settings… Doh!

No : “Modifier keys” for each Mac client. So I’ve changed it on the two Mac clients (in the server config) :smiley:
Shift = Shift
Ctrl = Ctrl
Alt = Super
Meta = Alt
Super = Super

Now I can use “ALT” for the Command button, but I can also use Super…

So “Alt+C” does the clipboard and “Alt+V” pastes, as does Super+V, and Shift + Super (or Alt) + 4 does screenshot with marquee select…

Cooking with GAS!

1 Like

Sounds a little confusing. Hope it works well for you.