Linux on Acer Aspire E5-771560N from MFG 08/08/2014 hangs on shut down


I have already tried many Linuxes with the notebook mentioned above and everything runs quite well.
However, every Linux (Ubuntu, Debian, Devuan, Fedora, …) with different desktops has the problem that when I shut down the notebook, it starts to shut down, but then hangs up and does not switch off completely. It can only be switched off hard using the power switch.

Has anyone ever had this problem?
What can be done about it?

Many thanks in advance

Hi @xylo_manius and welcome,
Sometimes when I shutdown my Debian system, it goes into
a system update with messages from systemd. That can take a long time, but it does eventually shut down.

I take it that you are not experiencing the above, because it would not happen with Devuan.
Therefore, I think we are dealing with something specific to your notebook.
What you might check is your power/sleep/hibernate settings.
If there is nothing unusual there, I think you have to
conclude it is a hardware issue

Have a look at this discussion



Hello Neville,

Thanks for your quick reply.

The updates have all worked without issue, and the settings are all still default when I now run the shutdown tests first.

It’s not the first system I’ve set up with Linux (mostly Ubuntu), but I’ve never had a problem like this before.

Thanks for the link. I will study it.


1 Like