Lm-sensors doesn´t display fan speed

Hi all, :wave:

I´ve just installed lm-sensors on Linux LIte 6.2. (which uses xfce DE) and ran
sudo sensors-detect .

I checked everything with “yes” and at the end I did:

Do you want to add these lines automatically to /etc/modules? (yes/NO)yes
Successful!

After that: sudo service kmod start

So everything should be o.k. But sensors doesn´t show my fan. :slightly_frowning_face:
Here´s the output:

sensors
acpitz-acpi-0
Adapter: ACPI interface
temp1:        +27.8°C  (crit = +92.0°C)
temp2:        +29.8°C  (crit = +92.0°C)

coretemp-isa-0000
Adapter: ISA adapter
Package id 0:  +30.0°C  (high = +87.0°C, crit = +91.0°C)
Core 0:        +30.0°C  (high = +87.0°C, crit = +91.0°C)
Core 1:        +30.0°C  (high = +87.0°C, crit = +91.0°C)

Hmm…, that´s strange. When doing the same in Lubuntu sensors DID recognize my fan. So theoretically it can be done. :thinking:
I´m a bit at a loss here. Can anyone help me :question:

Thanks a lot in advance.
Many greetings from Rosika :slightly_smiling_face:

Version may be older than the one on Lubuntu.
Your bios may show fans.

1 Like

Hi Neville, :wave:

thanks for your answer.

Well, I think I spoke too soon. Shame on me. :blush:

Yesterday evening I shut down my system and today I started it again (cold start of course) and it seems reboot (or cold start?) was needed to take effect as far as sensors in its entirety is concerned.

Here´s my today´s output:

sensors
it8772-isa-0a30
Adapter: ISA adapter
in0:           2.23 V  (min =  +2.81 V, max =  +3.06 V)  ALARM
in1:           2.23 V  (min =  +0.76 V, max =  +2.29 V)
in2:           1.98 V  (min =  +2.87 V, max =  +2.87 V)  ALARM
+3.3V:         3.29 V  (min =  +5.90 V, max =  +2.90 V)  ALARM
in4:           3.06 V  (min =  +1.33 V, max =  +1.70 V)  ALARM
in5:           3.06 V  (min =  +0.00 V, max =  +3.05 V)  ALARM
in6:           2.23 V  (min =  +3.05 V, max =  +2.48 V)  ALARM
3VSB:          3.26 V  (min =  +0.00 V, max =  +5.54 V)
Vbat:          3.17 V  
fan2:        1534 RPM  (min =   46 RPM)
temp1:        -70.0°C  (low  =  -2.0°C, high = +86.0°C)  sensor = disabled
temp2:        +26.0°C  (low  =  -1.0°C, high = +127.0°C)  sensor = thermal diode
temp3:        -66.0°C  (low  = -41.0°C, high = +119.0°C)  ALARM  sensor = Intel PECI
intrusion0:  ALARM

acpitz-acpi-0
Adapter: ACPI interface
temp1:        +27.8°C  (crit = +92.0°C)
temp2:        +29.8°C  (crit = +92.0°C)

coretemp-isa-0000
Adapter: ISA adapter
Package id 0:  +28.0°C  (high = +87.0°C, crit = +91.0°C)
Core 0:        +28.0°C  (high = +87.0°C, crit = +91.0°C)
Core 1:        +27.0°C  (high = +87.0°C, crit = +91.0°C)

On an irregular basis I use the watch command which now works as desired:

watch "sensors | grep -E 'Core|fan2'"
Every 2,0s: sensors | grep -E ...  rosika-Lenovo-H520e: Thu Jan 19 14:04:06 2023

fan2:        1534 RPM  (min =   46 RPM)
Core 0:        +28.0°C  (high = +87.0°C, crit = +91.0°C)
Core 1:        +28.0°C  (high = +87.0°C, crit = +91.0°C)

Thanks a lot, Neville.

Many greetings from Rosika :slightly_smiling_face:

1 Like