Lost Gigabytes & Systemd Files -- Any Correlation?

Hello! I am new to Ubuntu/Linux and could use some help with this problem I experienced yesterday.

I was attempting to open a zip file, but something interrupted the process. I deleted the zip file. But then I discovered that my free space was short about 5 or 6 Gigabytes. I am guessing this space was used up by some kind of temporary file.

In looking for temporary files, I found the following:

Could these systemd-private folders be holding 5 gigs worth of files? I was unable to access their properties because they are locked.

Are there other temp files that could be using up those gigs?

I would like to get those 5 gigs back. Any help would be appreciated. Thank you!


thank you for the screenshot, that makes life easier to detect what is going wrong.

If you generally would like to have more of your storage available, I can recommend cleaning tools for Linux. They are easy to use.

This is the one I know. Maybe there are other & better ones out there.

Some useful hints for freeing space on Ubuntu:

And as @Akito said, there are some tools to help you out.

But what is up with those locked files, I don’t know either.

But a quick search brought up this:

and in slightly other words from an IBM FAQ:

The /var/tmp directory is made available for programs that require temporary files or directories that are preserved between system reboots. Therefore, data stored in /var/tmp is more persistent than data in /tmp . Files and directories located in /var/tmp must not be deleted when the system is booted.

So don’t rush things when it comes to deleting some “unknown” or “unnecessary” files…
Have you rebooted yet and are they still there?


Yes, I have rebooted; and I’ve also tried autoremove. But I will try Bleachbit and some other of the 7 Simple Ways (Thanks to both Akito and Fast Edi). I guess I also need to be patient (and hope that these files eventually disappear in time). I read a couple of articles that suggest these files remain on the system for 10 days (or more). But it irksome not to know what these locked files are holding. Could be a few kilobytes or it could be a few hundred megabytes. I just don’t know.

Maybe, if it’s just to determine the size of the files, you could either start your file manager as root or open a terminal and fire up “sudo ls -l” in /var/tmp/
Don’t know if that does the trick, though…

Thanks again! The locked folders may be about the same size as the flatpack folders (about 41 KB each). I hope they will disappear in time, though. The good news is that I recovered more than 8 GB using the methods above (about 6 GB with BleachBit). On the negative side, the locked folders did not disappear – and I also have them in another temp folder. I am wondering if these locked folders happen only with Ubuntu, or do other Linux systems have them as well.

OK, just tried this at home:

So I have the same files present. And they are all from today as I started the machine. But it’s Ubuntu (Mint) too.
I think, that this is “normal” then. Can’t speak for SUSE or Fedora though.

By the way, you schouldn’t have to use sudo with the ls command as you see in my screenshot. My bad.