Lubuntu 20.04 live: problems with recognizing umts-stick out of the box

Hello altogether,

I have a question regarding new Lubuntu focal fossa.

Presently I´m running Lubuntu 18.04.4 LTS, 64 bit as my main system. This one should receive updates until April next year.
So basically I´m not in hurry to do a fresh install.
Nevertheless I like to try things out in advance as I´m not so pleased with surprises that pop up at an inconvenient time.

Therefore I decided to give Lubuntu focal fossa a try by creating a bootable usb-stick with ventoy (https://www.ventoy.net/en/index.html )
which by the way is a script to make a stick bootable for more than just one ISO. It seems to work fine and I succeeded in booting the Lubuntu 20.04 ISO.

So I could try it out as a live system.

There´s one thing that struck me as odd though.

I ran into problems establishing an internet connection with my umts-stick. I never had any problems with that using my present system (bionic beaver).

The thing is: My umts-stick is my only means of connecting to the internet.
It´s an Aldi umts-stick and "lsusb" recognizes it that way:

Bus 001 Device 015: ID 12d1:1001 Huawei Technologies Co., Ltd. E169/E620/E800 HSDPA Modem

When running “lsusb” on focal fossa live the stick is listed. So no problem there.

The real problem lies in the usage of the network-manager symbol in the taskbar. Focal fossa now uses “nm-tray” and clicking on that my umts-stick doesn´t appear at all.

After configurating the parameters of the stick by adding a new connection it now appears in the popup menu but has a little “x” on the left side of it. It´s still not available.

BUT:

As a workaround I tried the following:

I typed my old command (“nm-applet”) as I know it from bionic beaver and a second symbol appeared in the taskbar.
And immediately - without any further ado - a popup appeared asking me for my PIN (referring to the umts-stick which all of a sudden is recognized).

After entering the PIN I could connect to my provider using my 4 weeks flatrate. Everything worked just fine now.

So basically what it comes down to is the following:

“nm-tray” doesn´t work out of the box and I cannot get it to work.
The command “nm-applet” works fine. The stick is immediately recognized all by itself.

Can anyone give me some background information as to what´s going on?

Thanks a lot in advance.

Greetings.
Rosika :confused:

P.S.:
I posted the exact same question here: https://discourse.lubuntu.me/t/problems-with-recognizing-umts-stick-out-of-the-box/1291
(the Lubuntu support forum) but haven´t received an answer yet. Therefore I´m trying my luck here. :slightly_smiling_face:

1 Like

Hi @Rosika, Ubuntu 20.04 and connectivity problem seems to happen often. Just doing a search here for ‘20.04 wifi’ comes up with 4 reported problems. I know Lubuntu is not Ubuntu but that’s where it came from.
If my memory is correct, the problem was corrected by D/L the needed driver for the device. You might want to read thru these previous posts to see if one applies to your problem.

2 Likes

what about running journalctl -f to see if it gives you any pertinent information? i would try doing so before plugging in the stick to see if there are any noticeable errors. then it might also be helpful to have it running when you issue the nm-applet command in a separate terminal.

3 Likes

@easyt50:
Hi and thanks for your answer.

I just did a search for “20.04 wifi” and there really seem to be quite a lot of results. So I´m going to look them through.
I wouldn´t have guessed that there were widespread issues with that because everything used to work fine until focal.
Still it´s weird that the command nm-applet will give me access to my stick right away.
So theoretically the respective driver should be present…

Thanks again for the suggstion.
Greetings.
Rosika :smile:

1 Like

@01101111:
Hello, nice to here from you again.

Good suggestion. Thanks.
journalctl -f is a command I wouldn´t have thought of in that particular situation although I often used it on a variety of occasions at times.
Sounds good. I´ll try that as soon as possible and report back.

Thanks again.
Many greetings.
Rosika :smile:

2 Likes

further troubleshooting might prove helpful, but it looks like your nm-applet instinct might have been fortuitous. according to the lubuntu manual page on advanced networking nm-tray isn’t especially good at more advanced networking tasks. the example focuses on vpn’s but also mentions having difficulty with passwords. the last paragraph describes how to replace -tray with -applet if a body is so inclined :slight_smile:

2 Likes

@01101111:
Hi again.
Thank you so much for this hint.

I´ll try that and report back as soon as possible.

Greetings .
Rosika :wink:

1 Like

@01101111:
Hi and thank you so much :smiley: .
It worked, it really worked. :+1:

Following your reference https://manual.lubuntu.me/stable/G/AdvancedNetworking.html the paragraph

Changing nm-tray for nm-applet

contained the solution.
Curious thing though: although I have used this manual a few times it never occurred to me looking in the “AdvancedNetworking” paragraph.

going to Preferences ‣ LXQt settings ‣ Session Settings.
There go to the Autostart tab. You will see a list with checked and unchecked box,
to autostart nm-applet, check Network to disable autostart for nm-tray uncheck nm-tray.

That did the trick.
So basically: checking “Network” and unchecking “nm-tray” and then logging out and logging in again.

After connecting my umts-stick and waiting for a few seconds I was given the popup asking for the PIN.
And the rest (configuring the right parameters) was as always.
Could connect to my flatrate without any problems now.

This issue really kept me bugging I have to say. It´s phantastic that it could be solved.

Many thanks again for your kind help. :clap: :clap: :clap:

Greetings.
Rosika :slightly_smiling_face:

2 Likes

i am glad to hear that worked :slight_smile:

i read a few posts in the forum about others having issues with nm-tray and for whatever reason decided to take a look at what kind of advanced options might be available.

i admit to being a little bummed when i found that page in the manual since i spent some time trying to figure out how to write a udev rule to launch nm-applet when you plugged in the umts stick, but the answer in the manual sounded easier to implement by far. i doubt i would have made the connection to that page had you not mention both -applet and -tray in your post.

3 Likes

Hey @Rosika, I will second that. Welcome back @01101111. Nice to you active on the board again. I as well as many other miss your willingness to help on a problem and the knowledge / background you have to draw on.

4 Likes

@all

Hi again and thanks for the new feedback.
Sorry that I couldn´t answer earlier but I really had to work in my garden yesterday (all day long :frowning_woman: :slightly_frowning_face:).

@01101111:

Thanks for keeping digging. :+1:
I always try to include as much info as I can. But of course it´s bound not to be enough in some cases.

Good thinking. That one didn´t occur to me I must admit.

I myself was thinking along the lines of creating a very simple script simply containing the command
“nm-tray” and adding that to autostart.
Or even using cronjob.
Anyway with your help it could be solved very elegantly.

This nm-applet thing for me almost proved to be a deal breaker as far as new Lubuntu is concerned.
I was already considering LXLE as an alternative(https://lxle.net/ ).

Thanks so much again.
Greetings.
Rosika :smiley:

@easyt50:
Hi,

Thanks for your opinion.
Greetings.
Rosika :smiley:

2 Likes

and sometimes it feels like too much wouldn’t even be enough. some linux mysteries just are :slight_smile:

i originally heard about creating udev rules when i was testing anitX and inserted optical media was not set to automount with the default file manager. i didn’t have enough knowledge then to write a rule, but the idea of getting your system to do something specific when a peripheral was attached was interesting.

in case you are interested or need more info about udev, i found these two pages to be helpful reading: the arch wiki and reactivated.net. the arch wiki was good for understanding the broad strokes and reactivated gives great examples (though the command used is outdated. udevadm from the arch wiki worked on my system) about what kind of info can be used to create rules in different circumstances.

3 Likes

@01101111:

Thanks a lot for the additional info and the links.
Sounds interesting.

I´ve heard about udev rules in the past but really couldn´t bring myself to learn the necessary stuff behind it. Shame on me. :frowning:

But the links you provided really seem to make for good reading. I intend to have a closer look on them.
Thank you so much.

Many greetings.
Rosika :smile:

2 Likes