Lubuntu update caused big problems (help needed)

Hi all, :wave:

I´m sorry to say I´ve encountered a huge problem today. :cry:

I guess (but I´m not sure) that the most recent system update has corrupted my OS (Lubuntu) to some extent.

The latest kernel update provided me with 5.4.0-100-generic (which I think was still ok). I believe I triggered the respective update the day before yesterday.

Yesterday however there was something new to be updated:

ii base-files 11ubuntu5.5 amd64 Debian base system miscellaneous files

replaced

ii base-files 11ubuntu5.4 amd64 Debian base system miscellaneous files

This seems to be when the catastrophe happened. :woozy_face:

When I booted my system today it was on 20.04.4 instead of 20.04.3.
Well, to me this looked good and I thought nothing if it. :no_mouth:

When the login screen appeared (showing the Lubuntu logo etc.) everything was still behaving the normal way.

But when the login procedure came to an end the login picture still remained visible for quite a while (perhaps 15 secs. or so) before my desktop wallpaper was being displayed.

This was NOT normal behaviour as the wallpaper would be shown immediately after login… :thinking:

What was still more disturbing was the fact that thunar file-manager didn´t start immediately as it used to. It certainly took well over a minute to start after clicking on the icon.

Th worst thing however: it turned out not one of the usb-sticks which are attached to the PC at all times were shown in the file-manager. :exclamation:
Until now they were automatically mounted and displayed in the file-manager.

Plus: my third HDD-partition (I have root-, home- and a data-partition) wasn´t mounted either and indeed not shown (thus unavailable) in the file-manager. :exclamation: :exclamation: :exclamation:

This was horrid indeed, so I played back my latest timeshift backup (1 week old) and now I´m on kernel 5.4.0.99 again.

Plus:

ii base-files 11ubuntu5.4 amd64 Debian base system miscellaneous files

again.

What can I say:
everything works perfectly again like it used to. :relieved:

  • Thunar opens up quickly.
  • All USB-attached media (3 USB-sticks) mounted and displayed in file-manager automatically
  • The same with the third HDD partition
  • after the login procedure the wallpaper is displayed immediately

The only deplorable thing is: I´ve lost all my bookmarks, history, saved login-passwords add-ons in firefox. :slightly_frowning_face:

When starting firefox it complained about something. I´ve forgotten what it was exactly but I think it had something to do with the version number.

It would´t start unless I opted for a new profile. That one seems to have overwritten everything - so everything is in a virgin state with firefox. :sweat:

Well, for now I´ve disabled all automatic updates. So Lubuntu shouldn´t look for them all by itself.
As long as I don´t perform a manual update things should be alright I guess.

BUT: that´s no solution. :angry:

Sooner or later I´ll have to update.

Does anyone have any good ideas as how to proceed now :question: I´m really stuck here.
Something like that had never happened before…

Many thanks in advance and many greetings.
Rosika :slightly_smiling_face:

1 Like

hi @Rosika ,
I would wait for the next round of updates. If this is a universal problem they will have fixed it in the next round, maybe
And of course, do a timeshift just before you try

And you might watch the internet for any reports of this disaster. They might tell you why it happened and when the fix will come. I doubt if it only happened to you.

It would have been interesting to look at dmesg before you rolled it back. Too late now, dont go back there.

I think you just convinced me to start using timeshift. My clonezilla is not as good.

I can imagine your panic
Regards
Neville

1 Like

Hi Neville, :wave:

how good of you to respond so quickly. Thanks a lot. :heart:

Seems to be good advice.

Yet I´m not sure what exactly to look out for as I don´t know what package-update corrupted the system in the first place.
Potential candidates seem to be the kernel itself (although I doubt it) and this base-files thingy.

Definition: “Debian base system miscellaneous files”

env LANG=en_GB:en apt-cache show base-files

says:

Description-en: Debian base system miscellaneous files
 This package contains the basic filesystem hierarchy of a Debian system, and
 several important miscellaneous files, such as /etc/debian_version,
 /etc/host.conf, /etc/issue, /etc/motd, /etc/profile, and others,
 and the text of several common licenses in use on Debian systems.

As base-files was the last package I upgraded before system corruption kicked in I very much suspect this package to be the culprit (not sure though). :thinking:

Yes, that´s good advice also. Thanks.

I was looking around around a bit already but couldn´t find anything positive yet.

Do you know a special place where to look :question:

You´re quite right, Neville. I´ll try to remember that in future. :blush:

Yes, timeshift (Timeshift – TeejeeTech ) saved my day. At least for now.

I was also trying to post the topic in a dedicated Lubuntu forum:

but something´s weird there too:
It says:

This site is in read only mode. Please continue to browse, but replying, likes, and other actions are disabled for now.

and I´m not able to log-in. :slightly_frowning_face:

Thanks so much, Neville.
Many greetings from Rosika :slightly_smiling_face:

1 Like
1 Like

I was thinking just a google , something like
Lubuntu bug or problem or errors after update
and maybe give version numbers

Akito has solved the Lububtu forum issue
There is an Ubuntu forum, it seems to be fairly active.

There must be a place for Lubuntu bug reports.

Sounds like a filesystem problem.

You can afford to wait a long time. Most of these updates are trivial security patches which you can do without.

Is there any way you can blacklist the suspected package and allow other updates to proceed? That might not be desirable, other things may depend on that package.

If and when Lubuntu fix it, you can safely upgrade because they will replace the problem package with a new version and your update will skip the sick version.
That , by the way , saves on downloads. If you wait long intervals, you skip versions when you download.

Cheer up
Neville

1 Like

Has Lubuntu moved to Thunar from PCmanFM? Or are you using Thunar as default and still have PCmanFM installed??

1 Like

@Akito
I was about to suggest Lubutnu had fallen victim of their own update bug, but you spoiled it.

2 Likes

Hi everybody, :wave:

be thanked a lot for your responses. They´re very much appreciated. :heart:

First of all one positive message:

I managed to get back my old firefox-folder. :relieved:

Being somewhat desperate yesterday I also posted the same thread on the ubuntu forums:
https://ubuntuforums.org/showthread.php?t=2472188 .

User dragonfly41 suggested

But you might be lucky to find your old Firefox profile buried away. I suggest this since you refer to creating a new profile […]

Run the command firefox -P … capital P … and you might see other profiles with your bookmarks etc.

And indeed my old firefox profile was still available. :slightly_smiling_face:
But I had to update firefox to version 97.0 first. The old install still wouldn´t work with the old profile.:

sudo apt update
sudo apt install firefox

That way I got the new version of firefox without updating all the rest (which would be available) … thus hoping to avoid running into trouble again.
Still there would be quite a lot of package updates…

@Akito:

Thanks a lot for the link. How good to have an explanation for that one.
So it may be hoped the Lubuntu forum will be in working order soon.

@nevj:

Good thinking. I´ll tray that. Thanks.

O.K. That´s certainly something to go on. Tnx.

Phew, that´s quite a relief. :relieved:

Plus I´m sandboxing most of the apps I´m running, particularly browsers and e-mail clients of course … which should provide an additional layer of security.

Yes, I´ve often used this option in my VMs:

(example: excluding firefox-esr from updates):

sudo apt-mark hold firefox-esr firefox-esr-l10n-de

To get a look at the current status of packages set on “hold”:

sudo apt-mark showhold
[...]
firefox-esr
firefox-esr-l10n-de

To unhold packages:

sudo apt-mark unhold firefox-esr firefox-esr-l10n-de

Yes, I was thing along those lines, too. Hmm, not sure how to proceed… :thinking:

Plus: I might want to have an idea first about what package is the culprit…
That I don´t know for sure at the moment (but: see: P.S. below )

Thanks for the heads-up, Neville. :heart:

@clatterfordslim

Hi Mark,

Lubuntu has moved from pcmanfm to pcmanfm-qt (because the DE is LXQt now, I guess).

I installed thunar because it´s great for configuring custom actions. :wink:

Many thanks and many greetings to all of you. :heart:
Rosika :slightly_smiling_face:

P.S.:

I made it my habit of running a script I once wrote regarding updates.
So after an update I get the results of what has changed in a text-file.

I was just looking it up. I ran the script last Saturday at 6:30 PM local time. So the updates had been applied only minutes before.

As the problem occured on Saturday and NOT before I may (hopefully) safely say that these two packages received an update:

42c42
< ii  base-files                                    11ubuntu5.5                           amd64        Debian base system miscellaneous files
---
> ii  base-files                                    11ubuntu5.4                           amd64        Debian base system miscellaneous files
2604c2604
< ii  snapd                                         2.54.3+20.04.1ubuntu0.1               amd64        Daemon and tooling that enable snap packages
---
> ii  snapd                                         2.54.3+20.04.1                        amd64        Daemon and tooling that enable snap packages

So if logics won´t fail me I may deduce that is has to be one of those two packages…
I guess setting them on hold might be the next step (before risking another system update). :thinking:

1 Like

Hi all, :wave:

so sorry to bother you again. :slightly_frowning_face:

But I´m stuck for now - as far as how to proceed.

You already know that I´ve applied my timeshift backup and therefore the state of my system is how it was on Feb 13.
As far as future updates are concerned:

… seems to be good advice for the time being (thanks @nevj ) but there´ll be a time in the future when I´ll have to apply updates, I guess.
Besides, not to apply the latest patches/updates seems not to be in line
with what I´d consider to be good housekeeping for my system. :blush:

So what I´ve done is:

sudo apt update && apt list --upgradable

to get a look what´s up.
This is the result:

env LANG=en_GB:en apt list --upgradable
Listing... Done
base-files/focal-updates 11ubuntu5.5 amd64 [upgradable from: 11ubuntu5.4]
cryptsetup-bin/focal-updates,focal-security 2:2.2.2-3ubuntu2.4 amd64 [upgradable from: 2:2.2.2-3ubuntu2.3]
cryptsetup-initramfs/focal-updates,focal-updates,focal-security,focal-security 2:2.2.2-3ubuntu2.4 all [upgradable from: 2:2.2.2-3ubuntu2.3]
cryptsetup-run/focal-updates,focal-updates,focal-security,focal-security 2:2.2.2-3ubuntu2.4 all [upgradable from: 2:2.2.2-3ubuntu2.3]
cryptsetup/focal-updates,focal-security 2:2.2.2-3ubuntu2.4 amd64 [upgradable from: 2:2.2.2-3ubuntu2.3]
language-pack-en-base/focal-updates,focal-updates 1:20.04+20220211 all [upgradable from: 1:20.04+20210802]
language-pack-en/focal-updates,focal-updates 1:20.04+20220211 all [upgradable from: 1:20.04+20210802]
libarchive13/focal-updates,focal-security 3.4.0-2ubuntu1.1 amd64 [upgradable from: 3.4.0-2ubuntu1]
libcryptsetup12/focal-updates,focal-security 2:2.2.2-3ubuntu2.4 amd64 [upgradable from: 2:2.2.2-3ubuntu2.3]
libxnvctrl0/focal-updates 470.57.01-0ubuntu0.20.04.3 amd64 [upgradable from: 470.57.01-0ubuntu0.20.04.2]
linux-firmware/focal-updates,focal-updates 1.187.26 all [upgradable from: 1.187.25]
linux-generic/focal-updates,focal-security 5.4.0.100.104 amd64 [upgradable from: 5.4.0.99.103]
linux-headers-generic/focal-updates,focal-security 5.4.0.100.104 amd64 [upgradable from: 5.4.0.99.103]
linux-image-generic/focal-updates,focal-security 5.4.0.100.104 amd64 [upgradable from: 5.4.0.99.103]
linux-libc-dev/focal-updates,focal-security 5.4.0-100.113 amd64 [upgradable from: 5.4.0-99.112]
python-apt-common/focal-updates,focal-updates 2.0.0ubuntu0.20.04.7 all [upgradable from: 2.0.0ubuntu0.20.04.6]
python3-apt/focal-updates 2.0.0ubuntu0.20.04.7 amd64 [upgradable from: 2.0.0ubuntu0.20.04.6]
python3-distupgrade/focal-updates,focal-updates 1:20.04.37 all [upgradable from: 1:20.04.36]
snapd/focal-updates,focal-security 2.54.3+20.04.1ubuntu0.1 amd64 [upgradable from: 2.54.2+20.04ubuntu2]
ubuntu-drivers-common/focal-updates 1:0.9.0~0.20.04.5 amd64 [upgradable from: 1:0.9.0~0.20.04.4]
ubuntu-release-upgrader-core/focal-updates,focal-updates 1:20.04.37 all [upgradable from: 1:20.04.36]
ubuntu-release-upgrader-qt/focal-updates,focal-updates 1:20.04.37 all [upgradable from: 1:20.04.36]

If I´m not completely mistaken (at least) one package has to be the culprit as far as the mess after my latest update is concerned. :thinking:

Basically my question is:

Has anyone of you got any info about problems regarding any of the packages here as far as possible updates (i.e. new versions) are concerned :question:

I don´t want to try getting another system update without setting something on hold.
The question of course is: which package might be the culprit :question:

Thanks a lot in advance.
Many greetings.
Rosika :slightly_smiling_face:

I can not find any info.
I would wait a while longer
then if no info arises
try upgrading one packet at a time, from your list
watch out for dependencies dragged in
leave base-files and snapd till last
backup between every step
it will be tedious

Sorry, I cant think of a better way
Neville

Hi Neville, :wave:

thanks so much for your reply. :heart:

Sorry to have bothered you. I didn´t mean to have you (or anyone) actively look up things for me.
It was rather: if anyone happens to know anything about problems regarding those packages… :blush:

I´m a bit unsure about the time frame. No idea what´s an “intelligent” time to wait.
A few days, one week, two weeks… :question: :thinking:

Yes, that makes sense, as those two are my mains “suspects”… :wink:

snapd would be the least of my problems, I guess. I have no snaps installed whatsoever. So I´ll be in no need of the latest version.

I´m not so sure about base-files though. :slightly_frowning_face:

https://packages.ubuntu.com/focal/base-files lists this package as essential.

It depends on 5 other packages, it seems.
So basically I have no idea what it does to my system if I hold back updates for base-files:thinking:
Yet I very much suspect exactly this package to be the culprit.
Of course I may be totally wrong …

Many thanks again and many greetings.
Rosika :slightly_smiling_face:

Time to give Lubuntu a chance to identify the bug and find a workaround.
For me that means weeks

There is a slight chance that this issue is peculiar to your setup. No way to know other than wait for other users to complain…

It is even possible that you had a download error or a machine glich, and that if you repeated that fatal update the problem would not occur.

If you have to solve it yourself, do the one-package-at-a-time update approach

Regards
Neville

Hi Neville, :wave:

Thanks for your assessment. :heart:

I was considering something like that, too. Yet on the other hand up to that moment (last Sunday) I never encountered any difficulties after updates; and I´ve been using Lubuntu for years now.

Ah, I see. Well, that might be possible of course.

O.K., I guess I know now how to proceed.

Yet there´s still one question which gives me headaches.

You said:

Therefore I´m not sure about the implications of setting e.g. base-files on hold. :thinking:

On https://packages.ubuntu.com/focal-updates/base-files I see under " Other Packages Related to base-files":

depends:

- awk
- libc6
- libcrypt1

Not sure what that exactly means. Do those packages depend on base-files or vice versa :question:

I issued the command apt-get -s install base-files in order to simulate an upgrade and got the following result:

NOTE: This is only a simulation!
      apt-get needs root privileges for real execution.
      Keep also in mind that locking is deactivated,
      so don't depend on the relevance to the real current situation!
Reading package lists... Done
Building dependency tree       
Reading state information... Done
The following package was automatically installed and is no longer required:
  libpcre2-32-0
Use 'apt autoremove' to remove it.
The following packages will be upgraded:
  base-files
1 upgraded, 0 newly installed, 0 to remove and 23 not upgraded.
Inst base-files [11ubuntu5.4] (11ubuntu5.5 Ubuntu:20.04/focal-updates [amd64])
Conf base-files (11ubuntu5.5 Ubuntu:20.04/focal-updates [amd64])

So it seems it´s just base-files which will receive an update…

What do you think: considering the latest findings would it be safe (i.e. without any negative implications for my system) to exclude base-files from an update :question:

Many thanks indeed and many greetings.
Rosika :slightly_smiling_face:

Recently, I remember reading about snapd security fix related to serious security issue. It is not related to your real issue but you may want to upgrade your snap version soon if you use snap actively.

If the same issue happens again, you may want to check your system journal logs to see if you can figure out what is going on…

$ journalctl -p 3 -xb

1 Like

Yes it is probably safe. libc6 is important, it is the C programming library. Debian base-files package contains the filesystem heirarchy - ie it is essential and fairly important. It would certainly cause a problem if there were a bug in it, but I would have expected lots of people to be reporting problems if that were the case. That does not mean it must be updated, any bug-free version will do, unless they make a radical change that affects compatability with other packages. Debian do not usually make radical changes within a release. That is how they keep it stable. The Debian site says it depends on awk but does not mention the others.

Do the update without base-files and snapd. Do a backup first. I would still do it one package at a time, in case it is one of the other packages. Use script when running updates.

Another thought. Think back, did you do anything to the computer just before the fatal update?
Things like… add a package, remove a package, change a configuration,
leave a usb device connected, change the keyboard or mouse , make a new disk partition?
I am trying to find something that might have triggered this.

The simulated update was a good idea.

Regards
Nevillev

The solution to the root of all problems. You will always be safe, if you have a tested to work backup at your hands. Then you can knock yourself out and in the end still recover from it.

Just create a backup. Always.

3 Likes

Hi to all of you, :wave:

thanks so much for your latest answers. You´re really great. :heart: :+1:

@Akito:

Yes, that´s great advice. Tnx a lot.

As it is I do a complete disk-backup once a month by means of clonezilla. Despite doing a disk-backup which covers all three partitions (incl. MBR) it´s possible to restore a dedicated partition like the root partition (if wanted).

Still, in a worst case scenario this might be a month old. Therefore I configured timeshift to perform a snapshot on a weekly basis. :wink:

Of course before trying anything new I just manually created a timeshift snapshot.

@ahmetbombaci:

Hi Ahmet,

Thanks a lot for the info.

I see.
Well, I think in my case I may skip the snapd update then as I have no snaps installed whatsoever.
Lubuntu came with snapd installed by default and I never bothered to uninstall it. Therefore it would get updates had I not set the package on hold.

Well, that´s really great advice. Be thanked a lot. :heart:
That´s exactly what I´m going to do if I run into problems again. :+1:

@nevj:

Hi Neville,

thanks a lot for your reply as well.

Tnx for the compliment. :blush:

Thanks for the confirmation.

Yes, I think so, too.
Besides, if I don´t update it (by setting base-files on hold) I won´t get the new version of it.
And the old one hasn´t caused any problems till now; so I assume its bug-free.

Yes, that´s what I´m worrying about, too. :thinking:
At any rate, I think I´ll try excluding base-files from updates as a first step.

It´s been a while since I last used script, so I had to read up on the matter.
Seems like a good idea, although the output of the “typescript”-file is not particularly well-readable.
But it can be improved to some extent by issuing the command
col -bx <typescript >cleanedfile
(as I´ve learned).
The resulting file certainly provides better results when using less.

Thanks for the suggestion.

No actually I did nothing out of the ordinary… except that I always leave the USB-sticks plugged in.
That however has never given any cause for complaints.

Thank you so much, Neville. It´s certainly much appreciated. :heart:

Many thanks to all and many greetings.
Rosika :slightly_smiling_face:

P.S.:

In the meantime I tried another system-update, setiing base-files and snapd on hold first.

After a reboot and a cold-start I can confirm it went well and there are complaints whatsoever.
So it seems to be very certain that either of the two aforementioned packages has to be the cuplrit. :thinking:

I have recently installed exa (aka modern ls) from debian unstable (sid) repo. I have not paid extra attention first but it upgraded my libc6 version as well due to dependency. At first, it did not cause any problem but a few days later I figured out it broke dmenu. Since I had ubuntu custom version of libc6, I decided to revert everything.

I have libc6 version 2.31-0ubuntu9.2 in my system and it was upgraded to 2.33 after installing exa.

Probably, not related to this issue but still it is a core library and it may cause to break your system.

I used the following command in my case to understand the issue was related to libc6:

journalctl | grep dmenu

I think the error message itself was not very clear but after a quick web search, I understood that it was failing during libc6 function call.

1 Like

So, exa was not the problem, but the dmenu dependency. Ubuntu dependencies should never be installed on Debian systems, except explicitly allowed by the maintainer.

1 Like

dmenu is another independent package/cli application developed by xmonad team. Comes with suckless-tools. It is nice to use in small scripts in terminal when you want to make a multiple choice from a menu.

I do not know default libc6 version of lubuntu but in my case (Ubuntu 20.4 LTS) package name was 2.31-0ubuntu9.2 so I assume they forked 2.31 and did some changes… I was not sure what kind of customization ubuntu team made in libc6 package.

exa worked well and I did not observe any problem for a few days until I executed one of my scripts that uses dmenu. I also did not realize any weird thing in my system. dmenu was the first thing that I found broken. Since libc6 is a core package and may break a lot of things which I cannot test in depth, I decided to revert packages back to original versions and uninstalled exa.

exa is a nice tool but I could live without it. New Ubuntu LTS is coming soon so I may try to install it in a few months.