Magical disappearing sound!

I have a 7 day old install of linux mint 20.1 on my Dell Vostro 2420. The sound worked flawlessly up to this morning. For no reason it just stopped. I did all the steps in your great article ( ) with no luck. I loaded up a live usb mint 20.1 and the sound works well. I am at a loss. I am now going to go back one kernel to see if its a kernel problem. Prey for me. Otherwise I will need to reinstall the system and start ll over, yuck…. There are no easy answers, in this world of OS’s… I also want to know if you want to remote into my laptop and fix it yourself? A novel idea!!!


Did you update Ulyssa since the sound worked ?

Yes, and that is a possibility. something went wrong with that update? What do you think?

Thanks for replying

Did you, by any chance, set up the Timeshift tool ?
And, if yes, did you try to return to a previous image ?

I actually would guess that you changed some sound settings unknowingly.

Whether the operating system is the problem, could possibly be determined by creating a virgin user account (which will have default settings) and logging into this account.

However, for cases like this one (updates screwing up something), timeshift is the perfect answer.

1 Like

I had a similar problem with Linux Mint 20. The sound would work one session and then not work on another.

All I had to do was go to the Volume Icon on the bottom panel and then click on Sound Settings. Once Sound appears , the OUTPUT tab should be default displayed and you can verify the output DEVICE. Make sure that the correct Speakers are selected instead of the Headphone jack.

My PC would randomly switch over to Headphones on different Startups, but it hasn’t done it in long time.

Good luck.

No, did not set up timeshift. At this point, I’ve tried everything on the Itfoss tutorial, went back a kernel, reinstalled pulse / alsa, created a new user (still doesn,t sound). So, having my files all backed up already, I have no choice now, I will reinstall the OS fresh. This is a first for me. Never had an issue with sound before.

I concur, as I always have headphones plugged in, for real surround sound, as you can’t get more surround than a full size pair of headphones, especially in films when there is whispering going on. One day I unplugged headphones and realized no sound out of speakers, for me it was because it had booted up muted as the sound settings read at boot, whether or not it is the same as the last time it was booted. Left click sound icon in panel and click unmute or the slider to on.

Perhaps you can wait a bit as there is actually an update on PulseAudio :

pulseaudio (1:13.99.1-1ubuntu3.10) focal; urgency=medium

  • d/p/0703-switch-on-unknown.patch
    • The 0703-switch-on-unknown.patch was introduced from the version of
      ubuntu3.9, this patch could bring a regression similar to this one:,
      so just like the commit eaa6d5d6c1a7 (switch-on-port-available: Fix
      switching away from unplugged headphones), change the
      0703-switch-on-unknown.patch to move the code to
      (LP: #1908167)