Manjaro Mate Running In Virtualbox

Been awhile since I have used Manjaro. It is really running well in
virtualbox, with only basic settings. Kernel version is 5.13.12-1- MANJARO.
Really like it when the virtualbox-guest-additions come preinstalled.
I may try this on a 120GB SSD I have, but not today.


I’m running XFCE edition at home, was using Mint 20.04.2 till trying to delete an app off of my panel and all the panels deleted, leaving me having to logout then back in again. The weird thing about Manjaro, though cannot say for any other Arch install is that my Focusrite USB powered Microphone, instrument amp does not get recognized at all. Install Ubuntu-Restricted- Extras in a Ubuntu based system and it recognises it.

My GOXLR works flawlessly, if you load it up in Windows first, then switch over to Linux Pulse Audio will run beautifully through it, the only sound effect is the bloop for blooping out swearing. I particularly like the fact that my own theme works well in Manjaro.

To get around the Focusrite not working, installed Linux Lite on a spare SSD, dual booting with Manjaro having to have Manjaro booting first, as Manjaro will not boot on Linux Lite side running first in Grub, as Manjaro is running LZF,LSF something like that in their boot screen, that Linux Lite does not recognise.

1 Like

I got my Focusrite working in Manjaro, it works only if you have Pulseaudio settings or OBS-Studio open. Though oddly OBS reads it as a camera. :thinking:
Unfortunately I have said goodbye to Manjaro as my daily driver, as I need to save my weekly Corona test result emails as PDF in Thunderbird for work, every time I save it comes out garbled, so am using Linux Lite 5.2, Ubuntu based XFCE as my daily drive. The PDF add on in Thunderbird works flawlessly in Linux Lite and the weird thing is, is that Thunderbird in Linux Lite and Manjaro are both the same version.

I am not surprised between the working difference between Manjaro and Linux Lite or any other Debian based distro. My machine is UEFI capable but is running bios_boot for several reasons. Out curiosity and of wanting something to do, I moved EndeavourOS and Manjaro over to a 1tb gpt drive on two separate partitions. I also used MXlinux and Mint for this experiment. I can run MXlinux and Mint
without any problem, but when EndeavourOS or Manjaro is thrown into the mix, everything changes.
I realize this is in part of the bios_boot I am using with a gpt drive. In order to get either EndeavourOS
or Manjaro to boot on a gpt drive, they have to have a 8MiB unformatted bios_grub partition, for grub
to write too, I believe this is true for any Arch based distro. I find it almost impossible, to even get the
two Arch base distro to sync and boot, while the Debian based distros work just fine. I can use a
Rescatux CD and boot any vmlinuz it may find and even W10.
I will now try using a msdos 120GB SSD with four partitions and see if EndeavourOS and Manjaro
will write and boot with Mint and MXlinux.

I finally have the booting sorted. I have found that Arch based Grub and Debian based Grub, do not
play well together. Arch based Grub will boot a Debian based distro, but it doesn’t work the other way.
The fix is to put the boot flag on, I chose Manjaro, and set /etc/default/grub.
All other OS’s /etc/default/grub are set with
You then run, in my case grub-install /dev/sdb and then run grub-mkconfig -o /boot/grub/grub.cfg to
update Manjaro /boot.
Stuff like this can get crazy but I fixed the problem, and gained a little knowledge along the way.

1 Like

I too have noticed that about Arch, as I’m using Manjaro for gaming in and Linux Lite for everything else. Linux Lite has their own Splash Screen, takes forever to boot using UEFI, even off of Manjaro’s grub. With my build a Ryzen 5 2600 you need a dedicated Graphic Card NVIDIA 1660 Super in mine, with the new Proprietary drivers NVIDIA displays your make of machine instead of splash screen, but when booting up Linux Lite, it puts the name up of my motherboard ASROCK, then puts their spinner splash screen up afterwards. So now I’m thinking of going to something else, got the hopping bug back again. :grinning_face_with_smiling_eyes:

Arch has also just updated to version 91 of Thunderbird, which is fully unsupported of the PDF exporter add on that I use in Linux Lite. Booting with Linux Lite reminds me of KDE with two splash screens, though Linux Lite is XFCE. I’m thinking about Arco Linux, but will have the same problem with Thunderbird. It’s all well and good being on the cutting edge of software, but when you’re used to something being there and being able to use it, without the hassle of having anything break in the process, or in this case having to wait for the devs to catch up with add ons to work with the bleeding edge version that I’m using, but it never worked properly anyway it was garbled in code, when you exported emails as PDF. Though thinking about it I wonder if Manjaro is missing a Font to not make it garbled? Too late now of course, will wait a couple of months.

1 Like


You might consider using EndeavourOS. I have moved away from Mint to using
EndeavourOS as my boot drive for my machine. It is a rolling release but I have
installed the 5.10.63-1-lts kernel for stability. The one thing that is in need of installing
is os-prober, it is not installed by default, and the one will also have to edit
I have this installed and running on a 120GB SSD GPT drive, my PC is bios_boot, so I
had to have the unformatted partition for boot, but not the efi partition. It boots really
fast and has been fun to work with.
BTW that 32MiB unformatted partition could have been 8MiB but I had other plans
that probably will never happen

Well, not properly tested updates and upgrades can be extremely painful. This was my main reason to end my Garuda-Linux venture into the Arch world and coming back into the fold of the reliable Kubuntu after half a year or so:

Despite making rollbacks as easy as they get, with btrfs and timeshift, you can revert to the 5 previous states from the bootloader, too often I had to struggle with buggy updates from the Arch repositories. All fine, if you’re into software testing, not so good if you aim to just use the software. In the end, by reverting, you also miss the updates that actually fixed previous bugs.

However, I’m starting to feel a bit suspicious that I did something wrong with my current installation because I haven’t seen a Kubuntu update in several weeks (except for the Vivaldi browser which gets one every couple of days).

1 Like

Does Kubuntu come with Synaptic? If not I’d install it, open it and click on upgrade. We have moved up to Kernel now, depending of course of which Kernel you’re currently using. Firefox had a update too. I’m moving to XFCE Debian 11, as anything extra I need can add PPA’s for, of trusted ones of course. After seeing the install Tutorial on It’s Foss website this week, through weekly newsletter I had forgotten all about Debian, got it running in Virtualbox in Linux Lite, used Linux Lite for a week now. Not that impressed with it, as they use their own update manager through Synaptic and it does not have enough options, it updates your system in the background, without a proper GUI.

Kubuntu uses Discover as software centre and apt as package manager. So far, both always worked fine (BTW: just after I posted this, two small updates came in).

I’m on kernel 5.11.0-34, so that seems pretty recent to me and FF on v92.0, which is also current, according to the website. Perhaps, I just overstated the time since the last round of updates.

Actually, I never had any troubles with updates and upgrades, with one exception: Python updates usually break apps that use them or depend on it. Unfortunately, more and more programmers use it to “enhance” their programs.