Mecer 2140C - I hope it can be rescued from my bungling the boot up!

I got a entry level lap top for my wife to play her card games. Of course I couldn’t handle Win 10 taking up virually all the 32G so visiting son-in-law Gary kindly got Linux Mint going perfectly and loaded a few card games.

Not sure when but subsequently I was trying to increase memory by adding USB card(s) and ended up having to download and install Mint (now 19.3)…

LM 19.3 loaded perfectly with the USB drive! However when I removed the USB drive and switched the Laptop it seemed to be on a loop with the name Mecer, and some Linux writing changing places on the screen but going nowhere…

Now for my botch: I went into the BIOS and changed some settings - now booting with the USB stick or the Laptop the screen just stays black and Nothing happens :open_mouth: Also nothing when I try and press “Esc Esc Esc” to get back into BIOS

Hoping someone can assist

Regards
Clive

Hello.

What do you mean exactly by this?
What kind of “USB cards” did you use?
And did your action require a new installation?

Can you be a little more specific about the output on the screen?

Is the ESC key the right key to get into BIOS?
Is there no other key on bootup to switch the starting device? e.g. F2, F12 or so?

1 Like

micrI was trying to get the Laptop to read a 30G micro card but it would not “see” it. It has no problem with normal USB memory cards but I would have liked to have a “hidden” memory card. By substitution it was established that the laptop “reader” seemed faulty. I was only trying to check if there was anything mechanical I could see with the fitting of the micro card

When I booted with the USB drive where I had downloaded the Mint 19.3 it booted smoothly and had everything working well. Also the installation to the laptop ran smoothly until complete. Upon removing the USB drive I then tried to boot the laptop on it’s own. The screen showed “Mercer” and as that disappeared it momentarily showed about two lines of text too quickly for me to read than back to Mercer and so on in a loop.

Up to then I was using “Esc” as the BIOS entry so I did not try any other key or keys.

Thanks Fast.Edi

So to get this straight:
Are you still able to boot from the USB drive?

Is the installation that might be on the notebook a fresh install without user data (you mentioned that this error rose directly after the install)?

If so, it may be an option to just re-install your LM and look if this solves the issue if there went something wrong with the last install (maybe GRUB?).

If you can enter the bios, make sure it is set to boot from the usb drive…as long as you can do that, you are home free, so to speak :wink:

as long as the usb drive still contains a “live distro” of LM, that is.

reply to Fast.Edi
No, The screen and laptop show no sign of life - ie cannot boot from USB drive or even get into BIOS (I did try your suggestion of other keys to get BIOS but none worked)
The installation on the notebook is a fresh install of Mint 19.3 with no user data - the error arose when I tried to “fault find” the rolling screen display (described above) when booting up the notebook from it’s own installation (not USB drive)
I thought the same and in fact did reinstall LM which went faultlessly again except for the rolling screen display…

Reply to kgwoo
Yes agree. That was the first thing I did - 1st USB drive, 2nd “hard drive” I’m just trying to recall what they called this eMMC drive but I didn’t change the name.
Something else that I altered in the BIOS seems to “lock” the BIOS. I wish there was a hard reset button :>)

OK, that’s honestly not too good…
Can you perhaps get your hands on an external monitor?
So we can check if there is something wrong with the display (what I highly would doubt).
Also: Are there certain “beeps” that you can hear when powering up the notebook?

1 Like

Hi Fast.Edi,
The laptop is barely 5 months old and had virtually no use so I also doubt the screen would have failed. There is no sound at all when turning on the machine.
Thanks for your time and also to kgwoo
Regards
Clive

Good morning (at least in my place…)
I have a last “test” for you to try:
Remove the battery (if possible) of the notebook, wait about half an hour and then turn it on with the power plug only.
If that doesn’t help, put the battery back in and try again.

May I ask where you reside?
Is it possible for you to take the notebook back to the shop to have them look after it?
In Germany we have a gueranty for items for between 1 and 2 years.
Given all the informations, it might just be really broken, not just misconfigured.
When the machine is literally doing nothing anymore, a helpful advice from the distance isn’t really possible.

1 Like

Hi Edgar,
I saw your comment (above) on e-mail. I thought ‘good idea!’. In 10 minutes the back was off and the battery out.

Alas, still dead! Also with the battery back in dead.

I am in Pietermaritzburg, South Africa. I may have had some garantee if Win 10 was still on the machine but I doubt now.

Many thanks for your assistance

Clive

Just a thought, do you have any indication when you try to power up, any LEDs lighting up? If not possibly your power supply is not working.

I’m sure the power supply is working since the battery is fully charged. There are two LEDs lit after I hold down the ON switch for a few seconds. The one is the ON indication and the other shows a little lock with a 1 in it. (I had to use a magnifying glass to see the 1. However pressing the ESC key continuously does not bring up the BIOS.

Thanks for your comment
Clive

One LED is probably power and the other is the number lock indicator. I’m in the US and all the bios switches I’ve seen use the following methods, repeatedly hitting the Delete, F2 or F12 key when the computer is booting. If you google your computer name and model you should get more info on how to enter the bios. Example, enter the following into google search-“YOUR COMPUTER NAME AND MODEL how to enter bios”. That way you will know if your hitting the right key to get you into the bios. Good luck.

I’ve done some checking on Mercer laptops. Made in South Africa, the key to enter the bios seems to be different for different Mercer laptops. I would suggest trying all the following keys. Push power button and immediately start pushing the bios key repeatedly. Try them one at a time until you find what works. F1, F2, F11, F12 or the delete key. Seeing that Mercer is a South African company you might be able to call them to find out more info.

Hi Masterbrewer,
Thanks for your comments. Before it “stopped” working the Del key was the one that called up the BIOS bcause I used it a few times.

There are 3 LEDs in a row: Power on, Caps lock and the third one, that I mention previously looks like a lock and has what appears to be a digit I on it. The power and the third LED are lit but thats all - no other sign of life :>)