Media players - back to the console : moc and mocp

Sayonara’s been jacking me off just lately… If I pause a song, then unpause, it just stops any output (could be issues with the transition from pulse to whatever that next bit of tech is (“PipeWire”?) - and I have to quit and re-open - dunno… But it’s damn flaky and had enough of it… A shame… Sayonara 1.4 was ROCK SOLID and nice small footprint, simplistic, but pretty functional and reliable… I’ll still keep it because it’s meta tag handing features are worth it just on that count…

And all too hard to try and get Sayonara1.4 to work in Ubuntu 22… Heck I loved that player so much I compiled it on a Pi4B with 64 bit Raspbian (but it hardly worked) - after having no luck compiling it for armhf (on the 4B) - to discover comments by the author, when people were trying to compile it for i386, won’t compile on 32 bit…

Anyway - I HATE Clementine (it’s just ugly) and I aint using VLC (I’ve stopped using it now in favour of MPV) - so I’m now going back to the terminal and using “moc” and “mocp”… Still need to figure out / tweak my .config files for it… but it does the job…

I also use MPV to watch TV streams coming from my Pi3 (via TVHeadend).

Just out of curiosity, Dan, I tried to find Sayonara while I was browsing the new MX distro (KDE). The MX Package Manager had Sayonara 1.7.0-stable3 in the collection tabbed Debian Backports. I agree that it’s an attractive, simple player. Accessing my music files on my external hard drive, I’m currently playing a tune, pausing and restarting it without problems. Would 1.7.0 solve your problem?

1 Like


I think it’s running as a SNAP (not even sure, how does one tell?)… Actually - no it’s not a snap :

╭─x@titan ~  
╰─➤  which -a sayonara
╭─x@titan ~  
╰─➤  file /usr/bin/sayonara
/usr/bin/sayonara: ELF 64-bit LSB pie executable, x86-64, version 1 (SYSV), dynamically linked, interpreter /lib64/, BuildID[sha1]=2845b6baadad473e8097fd5de93e89b6b065c8b1, for GNU/Linux 3.2.0, stripped
╭─x@titan ~  
╰─➤  file /bin/sayonara
/bin/sayonara: ELF 64-bit LSB pie executable, x86-64, version 1 (SYSV), dynamically linked, interpreter /lib64/, BuildID[sha1]=2845b6baadad473e8097fd5de93e89b6b065c8b1, for GNU/Linux 3.2.0, stripped

Dunno why it shows up twice, usually I’d expect one of these to be a symlink to the other…

I’m running 1.7.0-stable3 (ever since I installed Ubuntu 22, 2+ months ago - hasn’t been update AFAIK)… I preferred 1.4, it was more “compact”, maybe less features, but I don’t use any of the new features anyway - I don’t stream audio, I don’t use a media database or server - ALL my music is organised into folders, per artist, then per album, by year (e.g. /mnt/BARGEARSE/MPZ/ACDC/1976-TNT-OZ-FLAC) … I strongly suspect my symptoms may be outside Sayonara’s control (e.g. Pulse or PipeWire)… But I’d prefer to run Sayonara 1.4… Loved the app so much, I chipped in some $$$ to their paypal… But it’s not going the way I want…

I seem to remember Winamp did this too, started off tiny and minimal, then went all BLOATED and tried to be all things, to all men…

So - I’m perfectly happy with moc / mocp… Might see if I can get it working on MacOS too…

I remember Winamp–and its llamas–but only vaguely and through a great deal of fog. But I have the lowest of standards. Any player works for me.

1 Like


There’s a bug in moc / mocp that’s been around since AT LEAST 2017 - when I boost global volume up to over 100% (I ALWAYS allow “Over-Amplification”! why wouldn’t one in the first place???).

Anyway - it kills moc and mocp! For at least FIVE years… the finger of blame is pointed at PulseAudio… But - why would the app crash?

Anyway - I found a remix of Slayer’s 1985 THRASH-METAL-GOLD “Hell Awaits” (removd the muddiness from the original) and THERE’S NO F–KING way I’m not cranking the dial as far as it can go - but it just crashed moc! Pezzo di merda! The remix only seems to be available on youtube, so I ripped it (yt-dlp, then split it into separate tracks with a cue file [and wrote a shell script to generate a CUE sheet]).

Some of the solutions suggested (FIVE YEARS AGO) re-compile from scratch… GTFOOH! a big FU to these “linux elitists”…

Hey - waking this up…

There’s no sayonara in MacOS - which is now my primary UNIX and my primary desktop… Quartz is like 10,000,000,000x better than f–king gnome (or XFCE or Pantheon)…

I bought a player called Colibri *, for MacOS - and it’s okay. But OSS stuff has way more features…

moc and mocp kick arse in the UNIX shell every Mac computer comes with since the dawn of OS/X and since “Apple Silicon” we now have WORKSTATION class Unix machines with RISC processors that wipe the floor with Intel and AMD (okay some fucking intel i9 can do this and that, but it will eat the energy budget of a 3rd world country to do so) :

This is my new favourite stoner metal band, BRUTUS : out of Belgium, new album dropped today (which I pre-ordered months ago), lead singer is also the drummer, and she doesn’t only kick bass drums, she kicks arse!

Sure - I had to “hack” it a bit - to make it (moc / mocp) work - I like that shit - my shell script to fire up jackd so moc doesn’t shit it’s britches (note - I can increase my OS volume to 100% and MOC to 100% independantly of one another - and NEITHER crashes my music listening experience like it does on Linux desktop) :

╭─datripp@loge.local ~/bin  ‹main*›
╰─➤  cat knocking.bash
#!/usr/bin/env	bash
# we need jackd installed and kicked off... before any other crap is considered :
# e.g. after homebrew is installed : "brew install jackd" or sumpin:
/opt/homebrew/bin/jackd -d coreaudio &

Sure - apple sucks, but I reckon they give back nearly as much as they take (e.g. CUPS - if anyone remembers how REALLY shitty UNIX printing was before CUPS - sure - you much think CUPS was an improvement on lpd and its ilk - sincerely UNIX printing SUCKED BALLS and Microsoft did it better).

In some ways - MOC / MOCP is better on MacOs - because “soft mixer” is indepentant of my desktop’s mixer / volume controls… and - 100% SOUND comes out heaps better out of Apple kit…

Also - BTW - I am no Steve Jobs fanboi - AKAIK he was a horrible person and basically someone like me ( a working class slob from Australia) would call him a C_NT (or in more refined speech “a prized sea-hunt”)… Died the same year as Dennis Richie and all these fucking sob stories about what an awesome wanker Jobs was - AFAIK he was just a failed Hand Job(s)… He was just better at stealing ideas than Bill Gates…

\° Colibri’s actually pretty good… does a half arsed decent job of playing my growing collection of FLAC format music… and the developer is of Hungarian extract, but living in New Zealand, and when I mentioned an issue - he reached out to me directly with a fix - and IT WORKED!

So when I need a GUI player - I’ll continue to support Colibri - and this is also part of the name of a pretty awesome book I read recently by Jeff Vandermeer (author of the novel that the AMAZINGLY trippy movie Annihilation is based on) called “Hummingbird Salamander” (Samandra Colibri in Castilian Spanish).

More about BRUTUS out of Belgium :

I just purged Google Chrome the f–k off both my MacBook’s cause it decided arbitrarily how I wanted to display my Google Chrome window - HEY SERGEI BRIN - this is my FUCKING computer and I will decied how I will layout my windows and browser tabs…

And if that’s the way Sergei Brin (don’t be evil my arse) and his big brothery botherish mates want to go - on my Ubuntu 22.04 :

╭─x@titan ~  
╰─➤  sudo apt purge google-chrome-stable 
Reading package lists... Done
Building dependency tree... Done
Reading state information... Done
The following packages will be REMOVED:
0 to upgrade, 0 to newly install, 1 to remove and 20 not to upgrade.
After this operation, 301 MB disk space will be freed.
Do you want to continue? [Y/n] y
(Reading database ... 314714 files and directories currently installed.)
Removing google-chrome-stable (106.0.5249.103-1) ...
Processing triggers for gnome-menus (3.36.0-1ubuntu3) ...
Processing triggers for man-db (2.10.2-1) ...
Processing triggers for mailcap (3.70+nmu1ubuntu1) ...
Processing triggers for desktop-file-utils (0.26-1ubuntu3) ...
(Reading database ... 314603 files and directories currently installed.)
Purging configuration files for google-chrome-stable (106.0.5249.103-1) ...


One of the best things about “big tech” is that each of of the messianic leaders at the top of their pyramid schemes, can’t stand one any other one… that lack of collusion is a MASSIVE benefit to mankind :smiley: :heart:

1 Like

Yes, there is strength in diversity… one of the fundamental laws of population biology.

1 Like

Man - I just found and tried out : MusikCube :

Getting moc and mocp running and working in MacOS is a bit of an ordeal - e.g. jackd / coreaudio crashes if using bluetooth audio sink… But it works okay if using the headphone jack on the macbook…

MusikCube carries right on (when using bluetooth audio):

Didn’t run it from the download link for MacOS M1 - installed it using homebrew…

(note Motorhead only appears twice 'cause the one with the Umlaut is a symlink :smiley: )

MusikCube is a bit fussy too, and confusing… like - you try to do stuff with the keyboard, and nothing happens, and you think it’s hung, BUT NO - YOU’D BE WRONG! It’s actually, in reality, waiting for mouse input! Bizarre! Like the vol doohicky at the bottom left, that can be fiddled with via seemingly random mouse clicks…

Either way - I love both and the old-schooledness of it :smiley:

Don’t think I’ll be rushing back to GUI music players (even if Colibri is pretty awesome on MacOS)

The bluetooth device I was trying to use was a Jabra headset - ostensibly for using with Teams Telephony - they’re pure garbage and won’t be using them for audio… With ALL the volume settings maxed out - it’s still too quiet… Plug my Sony headphones into the MacBook’s audio jack and I can crank it up GOOD and LOUD :heart: - and I prefer the more UNIX-y nature of moc/mocp (e.g. “<” [,] and “>” [.] to increase volume!) - but MusikCube’s pretty good too…