Mega problems with Mint 20

OK, I’m lost and need some help to figure this out. I installed Mega on Mint 19.3 and don’t remember having any problems.Mega-Terminal
When I try install from terminal and screen below if I double click on the name.
I also tried “sudo apt-get -f install”, but that did not change anything.
It said problems with dependency, but not what or how to fix.

2020-11-13 12_39_25-MEGA Desktop App - MEGA - Firefox Developer Edition

Did you download this?

Yes, thank you. That was my starting point. I also did a search for the error and that’s were I got the “sudo apt-get -f install” and the terminal command for the install. But either method gets the same result.

Found a work around / answer from ‘Linux Mint Forum’. “For Linux Mint 20 instead use the Ubuntu 20.04 download, until such time that they add Mint 20 in their distro selector. The Ubuntu 20.04 download installs fine on Linux Mint 20.”

You need these dependencies for 20.04

Then Megasync should work here is the website from whom these came from

1 Like