Megasync not working

First, using dual-boot Kubuntu 23.04 & Linux Mint 21.1. Megasync user for several years. It was working until 2 days ago on LM. Mega support is stumped, and it could actually be something on their end, but since getting a couple of things working that were not (via help on here) gonna give it a shot.

I have uninstalled/reinstalled, using both flatpak and sys pkg. No change.
It just keeps trying to log in. Is never successful.

I have never had to allow it in firewall, but not sure to how to check that it actually is and not being blocked there.

Without being able to successfully login, you cannot get into settings, only the proxy setup.

Any thoughts on why this suddenly started happening?


Can you temporarily disable the firewall?
Have you checked with Mega?

When I said support was stumped, I mean they spent hours having me send them screenshots, screen recordings, log files, etc. and they finally said they had to escalate it as they could not resolve it.

After about 6-8 installs of the desktop app in various distros over 5 years, I have never had to mess with firewall, I only mentioned it because who knew that would fix my KDE Connect SMS app (connects your phone to desktop)? It never said in the KDE docs that you had to enable firewall with specific ports, but i found on a forum that it was definitely requried and once I did, it started working in LM (never had to do that in Kubuntu, maybe I never had the firewall on there).

I ran ufw status and all is enabled, including, just in case, I had added 8080 for Mega. When I sudi ufw disable, it reports firewall stopped and disabled on system startup so I assume it is disabled (have not rebooted as I intend to turn it back on after checking Mega). But it still just sits at “logging in”.

I’m gonna mention this (even though I fail to see it would have ANY effect whatsoever) but the day it stopped working, I booted up and Thunderbird asked me for my saved passwords for email…kept pasting them back in to no avail and finally checked bridge for Protonmail, which said “no internet connection” but i did have internet. Checked browsers, went to reddit to see reports of their server being down, so that made sense. But it was at the same time that the spinning circle appeared on the red M on taskbar so I hit it and saw “logging in.” Needless to say, eventually Protonmail came back online, Thunderbird started working again. But Mega never has. The only reason I mention it is trying to access settings in Mega, I saw the proxy window which had server and while I know nothing about how these things work, is the imap server address for Protonmail.

So firewall is not the issue. What else?



Maybe it needs a webserver like apache2.
Try sudo systemctl status apache2.service
the address makes me think about a webserver, but on second thought I could be wrong.
How about you try this command: sudo apt purge megasync

i also use mega sync but not terminal base. GUI is most reliable
you can install mega sync from Flat-hub. and use

Command: sudo apt purge mega sync

This command remove all dependencies related to mega sync like logger file, cache, config file

Pardon my ignorance, but I fail to see as to why you would need a dual boot with LM and Kubuntu. Try one either LM or Kubuntu and see if evertthings works. There are better ways of running two Os,s without a dual-boot.

Because I keep giving old laptops to my adult kids with one of the two installed and need to be able to help them as they have never used Linux. I install anydesk on each and can remote show them how to do stuff or fix issues, but sometimes just telling them how to do something means I need to see the OS, as I forget. I never had a reason to switch from Kubuntu (have used it almost five years) until one heard about LM and I installed it for them and since I had not used it, dual booted my own so I could learn the differences.

But Mega was working for the last month using LM.


What do you mean by being old laptops?

Like, a 2016 HP Intel Pentium N3700 dual core, upgraded ram to 8 gb and replaced hdd with ssd.

A 2012 Intel i7 6th gen with 16 gb RAM nvidia gt 965 and ssd.


I don’t use the CLI either–when Mega is working, but cannot access the GUI since it stopped working. You would think with sudo apt purge and reinstalling flatpak that I would get the pop up window where you first tell it to sync everything or only some; it just reappears on the taskbar with the login prompt.


Then I assume the laptops were able to run W10? Do the laptops have a slot for two drives to be installed? I have no use for Mega, but if LM worked, then use LM.

I am not sure what you are suggesting or why. The laptops are running Linux and are with my two adult kids who live, apart from each other, on their own; they are not dual boot, mine is. And only the i7 had two drive bays (which is rare for laptops back when they had cd drives) but I removed the 2nd ssd to give it to the old HP so that both would have faster drives.

They each have their own desired systems installed and are using the one they like, including Mega, which i installed on both, under my account, so that their stuff could be backed up. Mega is working on theirs.


Then your machine is at fault, are you using a laptop or a desktop PC?

A desktop: i9 9th gen 32 gb ram with 2 ssds and 1 ext hdd.

Very good!! Now, is Linux installed on separate drives?

No, I am using one drive, dual boot, and as I said, Mega has been working on both Kubuntu and LM until 3 days ago: been working for 4 years on Kubuntu and the last month since I installed LM. Give me a minute and I am going to boot into Kubuntu where it was last working, and confirm it is still working there.


Booted into Kubuntu, same thing with Mega happening there. Had a lot of updates to apply, so rebooted 2x to get them applied. Am using my laptop, W11 to use the forum while seeing what happens on Kubuntu this time.

After all updates applied, Mega is not working there either, but I did get a popup saying Error: cannot connect to, 1143, which is the IMAP port for email using Protonmail bridge. Yet all the emails came into Thunderbird as of current time.

Do you think it is possible that 3 days ago when the Protonmail server went down and took half a day to come back up that something affected Mega? Even though email is still working? If you haven’t read it, see my reply to @nevj.


Very likely!! I have never used Protonmail, I just use Thunderbird for my email client.

I use Thunderbird, but with Protonmail you cannot use it without the bridge.


@4dandl4 what if I used Timeshift to restore LM back to before the Protonmail bridge went down? If something got tweaked with the localhost:, would that fix it? (I know very little about how these things work with localhost).