Microsoft fonts

sudo apt update && sudo apt install ttf-mscorefonts-installer

Updating from such a repository can't be done securely, and is therefore disabled by default.

I have tried also with Software Manager. It seems to freeze after the install bar shows about 75%.
My system is up to date.

Which Version of Mint are you using? On my mint 20.3 MSCorefonts install just fine.
Which server are you using? sometimes there are discrepancies with servers not completely syncing with Mint. Try a different server if it persists.

I had a similar issue and don’t remember exactly what I did. A quick search turned up many results from stackoverflow and this one: Updating From Such a Repository Can't Be Done Securely

Give those a read.

Try sudo apt install ubuntu-restricted-extras
This will install codecs and ttf-mscorefonts in one.

Try going to a different update mirror in update manager. The top one should never be Linux Mint repo, as it is way too slow. Change it to a mirror near you.

It downloads quite quickly, but half way through comes up with:
Clicking OK does nothing.

┌─────────────────┤ Configuring ttf-mscorefonts-installer ├─────────────────┐
│ │

│ If you acquired this product in the United States, this EULA is governed
│ by the laws of the State of Washington.

│ If this product was acquired outside the United States, then local laws
│ may apply.

│ Should you have any questions concerning this EULA, or if you desire to
│ contact Microsoft for any reason, please contact the Microsoft
│ subsidiary serving your country, or write: Microsoft Sales Information
│ Center/One Microsoft Way/Redmond, WA 98052-6399.

│ Reference:

│ │

sudo apt install ubuntu-restricted-extras gives continuous Waiting for cache /var/lib/dpkg/lock-frontend

Which version of Mint are you using? What hardware are you using?
In terminal type or copy and paste
inxi -Fxz
This will list about OS Kernel Hardware too. Copy the list that comes up and post it here. It’ll give us a better idea of the OS you’re running and what on.
Synaptic package manager might help? Just wondering when you tried from the software center, is it a Flatpak or a Deb file??

Push right or left to highlight the OK button push enter, as the box that comes up is keyboard only.