Mint windows don't stay sized

There are times when I want to have multiple windows/programs open and displayed side by side. I resize the windows to do that and drag them to each side of the screen for viewing but if I get too close to the sides/corners the windows will automatically enlarge themselves again. How can i stop this from happening

I am not running Mint at this time, but I know I have disabled auto resize, just can’t remember how.
I did find this, hope it helps.
"If you are using Compiz, I would say that is the
most likely culprit. There are many ways to
change the behavior of windows from within it.
Explore its settings at >Menu >Preferences

CompizConfig Settings Manager.
Another source of changes is the gconf configuration
editor. Look at either >Menu >Preferences
Configuration Editor or >Menu >System Tools
Configuration Editor, depending on which edition
of Mint you are using."

I’m not running compiz…so marco would be it. I don’t any configuration program for marco. Now I’m mint 20

In Ubuntu (upon which Mint is based), if you drag a window against the top to the screen it will open as full-screen. If you drag a window to the far right or left of the screen the window will open at half screen size on the right or left. This is useful when you want to work on two pages side by side. You may have to specifically enable or disable these features. I’m not sure of the situation in Mint.

Nu înteleg de ce nu recurgi la desktopuri multiple…e foarte simplu si in acelasi timp vast,încăpător !!!Doar un mouse spre colt si gata !!!

YES…that’s exactly whats happening. I’ve shrunk a couple of windows but when I’m dragging one to one side or the other it will resume full size. I don’t see any configuration program to deal with that.

perché raramente ho bisogno di più desktop

Maybe you are bumping the window against the top of the screen (which will return it to full size). When dragging, leave a little bit of space between the top of the window and the top of the screen.

I’m not sure if it is the default setting or if you have to find it and set it, but on all my computers double clicking a window title bar will toggle between full-size and reduced-size for that window.

Well the problem has been solved. I changed some thing in the settings that was to me not obvious in it’s ramifications. No more automatic resizing. Thanks guys!