Mint won't open, probably an issue with "owner"

I just did a recent re-install of Mint (on /dev/sda1) but now, instead of opening up Mint in all its glory, I get the Mint splash with the progress dots, followed by only a blinking cursor. I strongly suspect the issue is one of ownership of files, because this was a re-install (after reformatting and etc). Here is the timeline.

  1. I installed from a Live USB and everything went great. I updated and installed the programs I needed and it seemed to go great. That is, until it didn’t.
  2. First problem was Software Store (i.e., mintinstall). THe GUI would not open, although update and upgrade worked just fine.
    –> The solution I found online was that the old cliff (from the previous install) and the new cliff were not the same. The fix was to run sudo chown cliff:cliff followed by the target directory (which I have forgotten). Voila!
  3. Similar issue starting Firefox, so I did the same sudo chown cliff:cliff /.mozilla/firefox then ran from the terminal *firefox -P* to create a new proifile. Voila!
  4. Now, I must have tried the same trick on the wrong directory to create this problem. Mistakes R Me!

I strongly doubt the problem is not the hard drive. My evidence:
a. badblocks shows no problem, fsck shows no problem
b. All three of the kernels listed in grub have “recovery” options, and all open up just fine, offering me the choices of dpkg, root terminal, resume, etc.

Therefore, I think it is an ownership issue. What can I do?
a. Can I just change from cliff to cliff like I did before? If so, which directories?
b. Will I need to create a new owner? If so, how does that happen?
c. Whichever solution, is it best to run it from the recovery mode of Mint itself, or should I do it from outside, such as my /dev/sdb1 Ubuntu or from a live CD/USB?

Run the recovery mode first Cliff, that will find any problems. If that doesn’t work then in Synaptic Package manager see if there are any broken packages that need repairing and repair them if they do. I take it you’ve already done this in the terminal ; sudo chown -R -v $USER:$USER $HOME if not it is worth trying that as well.

I tried your terminal command three different ways ($USER:$USER, $CLIFF:$CLIFF and $cliff:$cliff) and got the same error message all three times:

/etc/sudoers is owned by uid 1000, should be 0

So I went to the sudoers file in the Mint directory and it reads:

This file MUST be edited with the ‘visudo’ command as root.

Please consider adding local content in /etc/sudoers.d/ instead of

directly modifying this file.

See the man page for details on how to write a sudoers file.

Defaults env_reset
Defaults mail_badpass
Defaults secure_path="/usr/local/sbin:/usr/local/bin:/usr/sbin:/usr/bin:/sbin:/bin:/snap/bin"

Host alias specification

User alias specification

Cmnd alias specification

User privilege specification

root ALL=(ALL:ALL) ALL

Members of the admin group may gain root privileges

%admin ALL=(ALL) ALL

Allow members of group sudo to execute any command

%sudo ALL=(ALL:ALL) ALL

See sudoers(5) for more information on “#include” directives:

#includedir /etc/sudoers.d

Hmmm.
The directory **sudoers.d** does not have anything informative that I can see.
Now what can I do?

0 = root
1000 = first user (you)

So the sudoers file is owned by you which is wrong.
Don’t use sudo until you fix this issue. Log in as root user to fix the problem as proposed by the system.

I would be working from the root terminal in Recovery mode.
Do I just run the command that Dandy suggested without using sudo? How do I fix the problem with sudoers?

su -
chown root:root /etc/sudoers

I did as @Akito advised,

chown root:root /etc/sudoers

Then I ran the command as @ElectricDandySlider posted:

sudo chown -R -v $USER:$USER $HOME

The screen scrolled through a lot of changes, but the problem seems the same.
Are there any other owner associations I should look at or modify?
If so, how?

More information.
I ran ls -l / | more in recovery mode and discovered what may be the problem.
The following directories are owned by root: dev, proc, root, run, sys, tmp and usr
The following are owned by cliff, and I suspect should not be:
bin, boot, etc, home, initrd.img, lib, lib64, lost&found, media, mnt, opt, sbin, snap, srv, timeshift, var and vmlinuz

Does this point the way to a solution?

Just run it on my system 19.1 Mint which is working perfectly fine and all are root. The only time my name is mentioned is before any terminal command is put in. So I suspect that you are correct in the probable cause of the problem and the probable solution to this. Without further research, I don’t know what that is at the moment.

Re-install the OS, it is the safest bet. Worse would be if you would rely on some owner change and then after a long time you find yet another important folder that is not owned correctly and then it would cause even bigger problems. That said the system is a fairly new installation in the first place, so might as well just re-install to be safe und get it done easily.

Make sure you delete the entire root partition, while leaving the /home partition unformatted during the re-installation process.

1 Like

I must admit that I also think this is the best course of action here as well and I was hoping that someone else would mention it . I did also think that other things were worth a try first as it is a bit drastic to do a re-install, but sometimes it is the best and only solution there is.

It definitely is not the only solution, but I am sure it is the easiest and way better than manually fiddling around with an anyway new installation. In the beginning, as long as everything is rather fresh, a repeated installation won’t hurt much.

1 Like

As a long time Mint user I would say the best course at this point is as has been said, reinstall. if by chance you have a seperate home (/home) partition I would make sure I also formatted that and re did it. good Luck. P.S. If you can hold off till the end of the week you may want to download and install 19.2 when it is released as stable.

1 Like