Missing the ESP flag

I have Ubuntu only on this computer and when I check with gParted your suggestion regarding ESP, find I only has the boot flag active.

This post is regarding : How to Actually Install Ubuntu on USB

Previously this was a Win10 machine. Fast & Secure Boot are disabled.

Any advice please on how I might fix this issue. Ubuntu did install a 512 Mb fat32 partition for /boot/efi/ as mount point. The rest is an extended partition with the ext4 partition in it, and a swapfile in root.

In my BIOS the CSM shows Boot device Control set to UEFI & Legacy. Also has Boot from Storage Device set as Legacy only.

Much appreciate your comments and assistance.

Cheers Amit

There may well be no issue here.
It seems that the ESP flag relates to Windows 10 should it be present.
In my case I only have Ubuntu installed on my “C Drive” SSD and that provided itself with a fat32 512M partition mounted as /boot/efi/