Need Help Opening a Program in Wine

Hello, what must be done in order for Wine to run this Windows program called VectorVest? Here is the full setup.exe file link as a free download from my personal file sharing website so anyone can tinker with it to hopefully get it to run properly. It’s a stock investment tool program that nobody can even log into unless they paid for a subscription but I cannot even get the program to boot up at all. :frowning_face:

I ran this setup.exe file in Wine and the program supposedly successfully installed because I can see the icon in my applications list but clicking on it only makes my cursor do the loading thing and then nothing. I already enabled permissions and already enabled 32 bit WIne mode to no avail.

Thank you very much.

I downloaded it and tried. It obviously missed some .Net dependencies, this was clear reading the message printed in terminal, after I started it.
I tried to make it work, and succeded to a point, but can’t test it further.
I suggest you to get winetricks (apt install winetricks).
Create a 32bit wineprefix

WINEARCH=“win32” wineboot

Then use winetricks to install dependencies into wine.
I used this:

winetricks dotnet472 d3dcompiler_47 d3dx10_43

This takes some time, you have to answer some install questions (next-next-finish etc, a’la MS), and you’ll see lots of error messages in terminal. This is no problem.

After that installed your app into wine.
It started, and asked me to login.
This happened on Debian Buster, with WINE 4.0.
I repeat my steps with a brand new wineprefix, to be absolutely sure.

Yes, it works. :smiley:


Wow you’re a genius! I wish I was as smart as you are at Linux. You know you’d help a lot of people if you posted your findings on this website here

You’ve helped me so much I can post your findings there and give you the credit or something if you want? I can’t wait to try this out and get back to you. Thank you very much kovacslt.


I wish I was a genius you think I am. :slight_smile:
I just had a lucky moment.
These hints just help to start the program under WINE. There’s absolutely no guarantee that will work flawlessly. I assume you already paid for the login option.
So after you sucessfully launched your app, do login, an thoroughly test its functions.
If it works as you expect it to work, doesn’t crash every minute, then you may to post the ideas to that forum. I don’t need credits, special thanx or such :wink:
If I could help you, and you are really happy with you Linux, that will be my payment :smiley:


Hi Kovacslt,

I tried this on xubuntu 20.04 lts and it isnt working any help ?

WINEARCH=win32 wineboot

wine: WINEARCH set to win32 but ‘/home/user/.wine’ is a 64-bit installation

Hi @sic698 ,
I think you already have there a WINE prefix, and it’s 64 bit.
There are more options:

  1. You don’t need that prefix. In this case just remove it, and rerun the command.
    cd ~
    rm -rf .wine
    WINEARCH=win32 wineboot
    1/b - just in case: you don’t need that prefix, but it may contain some saved file, which you may want to use later. If this is the case, instead of removing it, better rename it.
    cd ~
    mv .wine wine-bak
    WINEARCH=win32 wineboot

  2. If you absolutely want to keep that prefix, and use it as the default, don’t touch it.
    Create a new one.
    cd ~
    WINEPREFIX=~/wine32 WINEARCH=win32 wineboot

That will create a 32 bit prefix under “wine32” in your home folder.
Remember, anytime you want to use that WINEprefix, you have to explicitly adress it, for example calling
winetricks dotnet30
will try to install .Net 3.0 into your .wine prefix. Doing this for your newly created prefix will look like
WINEPREFIX=~/wine32 winetricks dotnet30

“wine32” is just an example, you name it to your liking.
I think you get the idea…