Need wine 8.0 to be available in playonlinux

Hi all, :wave:

I need wine 8.0 (amd64) for a certain programme to run in playonlinux but when looking at what playonlinux has to offer (using the the wine-versions tab) I see the latest versions available are 7.22 for “x86” and 6.17 staging for “amd64”. :thinking:

Is there any other way of getting playonlinux to use wine 8.0?


after doing some research I came up with the manual installation of wine 8.0 (but not for playonlinux). I did the following:

 tar -xvf wine-8.0.tar.xz
 cd wine-8.0/
 ./configure --enable-win64
 make && sudo make install

So I actually got wine 8.0 (64bit) installed (:smiling_face: ) in a certain directory on the main system but I´ve no idea how to get it imported into playonlinux:slightly_frowning_face:

Does anyone know a solution to the problem :question:

Many thanks in advance and many greetings
Rosika :slightly_smiling_face:

Hi Rosika,
Playonlinux is wine with a gui
I dont think you can import a newer wine binary into the playonlinux binary
You may be able to get the source code of playonlinux and wine8.0, then substitute the wine8.0 source code into playonlinux source code, then compile it. It would be a big job, and there may be incompatabilities to deal with.


I might modify that.
It depends on how playonlinux is constructed.

  • if it is an integrated module with the gui and wine compiled together… what I said above applies.
  • if it is just a gui that calls wine, then you may be able to trick it into calling wine8.0
    What you would need to do is find where the wine binary is in your filesystem and make it point to your newly installed wine8.0. It may already do so… depends how you installed wine8.0

So that may be a little brighter. You need to determine whether playonkinux has wine builtin, or whether it calls it as a dependency.

1 Like

Depends on your installed Distro,
Duck search shows some static distros not many but
found this

paragraph titled as
How to Install Wine 8.0 in Ubuntu and Linux Mint

and of course rollers EndeavourOS would have also .

1 Like

I just tried to use Steam’s version of wine to install some software - no go… did nothing…

So in installed wine separate from steam - steam has it’s on WINEFREFIX (for Proton / SteamPlay)…

i.e. sudo apt install wine

Then I installed my software : Autodesk Sketchbook Pro.

wine ~/tmp/sketchbook_8.7.1.0_win64.exe

and it installed without error…

works 100%… such a surprising pleasure to have something just work… :smiley:


Hi again and thanks a lot to all of you for your answers, :wave:

@nevj :

I thought that, too, but theoretically it can be done (see below).

Well, I compiled it from source (see steps in my post #1 ). Now wine-8.0 resides in a dedicated folder. The problem is how to integrate it into playonlinux… :thinking:

You can actually make playonlinux use a variety of wine versions. It just depends on what is on offer.
The tab “tools” —> “manage wine versions” triggers a new window which lists all available wine versions ready for installation within playonlinux…
… but for 64 bit versions it stops at 6.17-staging.

@artytux :

thanks for the link. I´ll look into it.

@daniel.m.tripp :

Seems you had better luck with solving your “problem”. :wink:


I also posted my query in the playonlinux forum (here and here)

It seems it can be done:

Now let’s give a practical example for a better understanding. At the time of typing this there is Wine 7.0~RC2 available but in POL there’s nothing above 6.18 in the x86 section and 6.17 in the x64 section. I’ve been following the devel branch lately so I installed this 7.0~RC2 devel version.

  • create a folder named i.e. Wine7.0 somewhere in ~/Downloads or wherever you see fit
  • download there all x64 devel_7.0~rc2 files from the Wine repository here (except for those containing dbg or winehq in their names)
  • download there all x86 devel_7.0~rc2 files from the Wine repository here (except as above)
  • create two folders: ~/.PlayOnLinux/wine/linux-amd64/7.0 and ~/.PlayOnLinux/wine/linux-x86/7.0
  • open each of the downloaded packages one at a time (through Archive Manager, not GDebi), select all available folders within ./opt/wine-devel/ and drag them to their corresponding folders created earlier - 32bit to 32bit folder, 64bit to 64bit folder

If everything went well there will be four subfolders in each 7.0 folder: bin, include, lib64, share in the amd64/7.0 folder and bin, include, lib, share in the x86/7.0 folder - each with their own files.
Now opening Tools > Manage Wine versions from POL’s main menu you should see version 7.0 installed for both 32bit and 64bit Wine. Proceed with creating your prefix(es).


When manually installing a 64bit Wine version in PlayOnLinux, make sure that you copy these files ‘wine’ and ‘wine-preloader’ from the ~/.PlayOnLinux/wine/linux-x86/{wine_ver}/bin folder into the ~/.PlayOnLinux/wine/linux-amd64/{wine_ver}/bin folder
and copy the ~/.PlayOnLinux/wine/linux-x86/{wine_ver}/lib subfolder into ~/.PlayOnLinux/wine/linux-amd64/{wine_ver}/,
otherwise you will get problems. In the 64bit Wine versions which can be downloaded by PlayOnLinux itself, these aforementioned files and lib subfolder have already been included.

I tried that of course but couldn´t get the same results:

quoting myself as an answer:

I followed your instructions very precisely for installing devel_7.0~rc2 but there is a point which differs from your instructions.

You wrote

> If everything went well there will be four subfolders in each 7.0 folder: bin, include, lib64, share in the amd64/7.0 folder

Well, there isn´t, at least not in my case. There´s just share and bin but no include and no lib64.

The same with the x86/7.0 folder: just share and bin.

Any guess why that ´s the case?

> When manually installing a 64bit Wine version in PlayOnLinux, make sure that you copy these files ‘wine’ and ‘wine-preloader’ from the ~/.PlayOnLinux/wine/linux-x86/{wine_ver}/bin folder into the ~/.PlayOnLinux/wine/linux-amd64/{wine_ver}/bin folder

These files are not there either.

That´s where I got stuck… :slightly_frowning_face:

Still: thanks a lot to all of you.

Many greetings from Rosika :slightly_smiling_face:

1 Like

I wonder do you need to have Wine 8 present, before you install playonlinux?

1 Like

Hi Neville, :wave:

I guess not as I have 3 different 32bit wine versions and 3 different 64bit ones installed by playonlinux. The wine version tab tells me so.

However on the main system wine is also installed and I get just one version here:

wine --version
wine-6.0.3 (Ubuntu 6.0.3~repack-1)

So they seem to be independent from each other.

Well, after having dealt with the problem quite a lot I decided to solve it the traditional way, i.e. printing a pdf file. :blush:

The background of my question was :

I now (hopefully) succeeded in getting my income tax declaration ready.
For this I bought an income tax software (designed for WIN systems of course) and I got it running on Linux Lite with the help of playonlinux.

All that remains to be done is transmitting the tax declaration to the tax authorities.
For this I have all login credentials (ELSTER certificate and PW) at my disposal and
the programme should be able to deal with it.

But here the problem arises. It´s exactly this part which cannot be done for some reason. :slightly_frowning_face:

Another Linux user however could get the tax transmission going but he used wine version 8.0 for that.

Well, like I said, I´ll print the pdf file on paper now and let the postal service deliver it for me… :blush:

Thanks a lot anyway for your help, Neville, and indeed thanks to all of you. :heart:

Many greetings from Rosika :slightly_smiling_face:

1 Like