Nemo sidebar missing folder

After D-A-Y-S of getting stuff copied from both OS on my dual boot Linux to an external /Data partition, I was finally ready to say it was done…finis…but somehow there was an issue where I thought I had created a new Documents folder on the internal drive of LM OS (after accidentally deleting it instead of renaming it) and where I created symlink. Then I noticed the lock on it, so I opened as root and changed permissions. It works, yes. BUT when I looked in the left pane (side bar) of Nemo, the “Documents” folder had an exclamation icon. It said it could not find it. I tried everything to find a way to point to the new folder but could not figure it out.

Searching for this issue, I found ItsFOSS article on Nemo but this was not covered. It was asked about in comments, but no answer was ever given.

What generates these folders in the sidebar if not the Home folder? I know it is not the end of the world to have it missing from the file tree on the left, but it bugs me. How do I get a Documents folder in that tree that points to the correct one?

Sheila Flanagan

Are you saying, Nemo would not recognize a symbolic link
to the Documents folder?

Perhaps Nemo has some memory of the original setup?

@nevj no, I don’t think so. The symlink worked fine after I created the new Documents folder in home with the link inside. None of the other files with symlinks had an exclamation on them in the sidebar, only Documents. Since that is the only one I recreated, I assume it could not find the “old” Documents and somewhere there has to be a way to point to that new folder in /home.

I was moving pretty fast and after going into old Documents and removing all files as they were already on /Data, when I moved up to /home, I accidentally deleted the empty Documents folder. No big deal, right? It was empty. SO I created a new one and inserted the symlink there.

When the exclamation point appeared in the left on Documents, I finally gave up and deleted it from the sidebar since it said it could not find it. Now I cannot figure out how to create a new Documents folder in the sidebar and have it point to that new folder in home.


This was so unbelievably easy to solve: I never tried to drag and drop the new Documents folder to the sidebar–it worked!

So I learned something about Nemo on LM.



Thunar brings up the folders automatically.
Drastic solution… purge Nemo and reinstall it… that will destroy all configurations!

1 Like