Newly installed Linux Mint stops at grub> prompt when booted

I am new to Linux and have just installed Mint on an Asus VivoMini. When I boot up it loads as far as the grub> prompt, but then stops. If I type “exit” it carries on and Linux loads normally. But why does it stop at grub> ? It’s a simple single boot system, nothing complicated. I think it may need some instructions loading at the grub> prompt, but I’m not sure what they should be.

Can anyone help?

Give this place the once over.

Special Attention to number 29.


Think if you are new to Linux and or mint … then I would do a total new installation again to see if that clears the fault… if not then follow the ideas given in the reply by 7blade and the link suggested.

Thank you 7blade. That worked perfectly. Unfortunately it didn’t solve the problem, so I’ll have to keeo looking.
I’m not confident that doing a re-install would make any difference, but I have handed the install usb stick back to the owner, so that’s not an option.

If you only run Linux Mint and there are no other operating systems on the computer, the grub menu is hidden by default.

To make it visible, as root*, add these lines to /etc/default/grub.d/90_custom.cfg :


Then type the following command in a terminal:

sudo update-grub

Then restart your computer.

* This means, e.g. sudo nano /etc/default/grub.d/90_custom.cfg

1 Like

But I don’t want to make it visible. I want to make it invisible, which you say should be the default, but it isn’t, at least in my case.

All you need is your own USB stick. Then you can put an installer onto it and re-install the system, if the issue bothers you too much.

Find the line:
Change it to:
Then find the line:
Change it to:

Didn’t work?
Try here:


Thanks 7blade. That certainly looks like the same problem I have, but the detail is way above what a beginner like me can understand … and they still don’t seem to have solved the problem. So I’ll wait a little longer in case anyone can suggest something else, then, if not, I’ll just have to live with it.

Much appreciated.

Hi Akito.
I have finally got around to doing what you suggested and I’m pleased to report that it worked. I don’t know why it didn’t work the first USB stick, maybe it was an earlier version of Mint. However I’m very pleased to say that I’m now a happy bunny and thank you for your advice.