No audio output. Audio setting frozen

I am not able to use the Fn keys to control the audio no audio output is coming even if I try and adjust the control using the volume dropdown. In setting it seems as though the sound option have been frozen. However I am able to use and control the audio output at the login time, problem starts only after I log in to the desktop. See for settings screenshot https://prnt.sc/sgc2be

It was working alright yesterday. I have pulse audio on my system. I had installed it via cmd and then without removing or deleting that installed it from ubuntu software centre as well. When i kill this process i get automatically logged off “gsd-sound”. From that screen until I log back in, I am able to control the audio

Could you elaborate on that?

I cannot use the fn keys nor the audio setting. Literally saying there is no sound. Only time i get sound is at the time of login or when i kill the process “gsd-sound” from task manager.When that process is ended i get reverted back to the login page,but it does do much help.

This is the code i used:
$ snap install pulseaudio
$ snap connect pulseaudio:home core

then installed the software again from software center

Why did you install the software twice?

I suggest uninstalling both. Reboot PC. Then install from normal repositories. I would advise to not use snap at all.

Well i did know any better,wanted audacity to record PC audio. And that snap cmd line was what i found online the first time before i stuble on the GUI version of it. Can you say how i can uninstall the snap?

1 Like

You are a life giver mate, that worked, removed the snap and now its working. Fn key for audio as well as the audio itself. Didnt reboot though,without doing that it worked

cmd used:

sudo snap remove pulseaudio

2 Likes