No Matter What Browser Cannot Connect To Linux Mint Website Only Through Proton VPN Since updating Firefox to 84.1

Hello, my first time posting here and since having updated to Firefox 84.1 here in Linux Mint 20 XFCE edition, cannot access Linux Mint website. Only through VPN I can access it. I’ve tried other browsers Brave, Chrome, Chromium and they too do not connect to Linux Mint’s website or forum pages. I am at a loss and am considering reinstalling Mint anyway as, as time has gone on using it I have bulked it out a bit.

Well, well, well just had to add this that I found and now have a really fast Internet.

Just had to change some settings in Firefox, just ticking a box DNS over HTTPS, it goes straight to CloudFlare and boy Firefox goes zoom, as quick if not quicker as Chrome. Just thought I’d share this as DNS in Firefox is not switched on as default until you activate this. I love Firefox.
1 Like

Could you try to access the website with your computer from someone else’s home?

1 Like

Hey, I can feel the frustration especially at this time of year. I have just gone to Mint’s main page with Abrowser and it fully loaded in three seconds. :wink: So you too could try Abrowser as I don’t trust Ffox-Mozilla or ubuntu I also use both Epihany and Midori - Web is the web browser for the GNOME desktop and for elementary OS, based on the popular WebKit engine. It offers a simple, clean, beautiful view of the web featuring first-class GNOME and Pantheon desktop integration. Its code name is Epiphany. - Midori is a Web browser that aims to be lightweight and fast. It aligns well with the Xfce philosophy of making the most out of available resources. It has a customizable interface using the GTK+ toolkit.
Wish you the best of luck and Season’s Greetings :snowman_with_snow:

1 Like

I’m going to take my Laptop with me to work tonight. (I don’t do Xmas hence why I’m working tonight.) I t has the exact same setup as my Desktop and I will report my findings. Merry Happy Xmas.

1 Like

I wonder whether this is really an issue related to the Firefox upgrade. I have it too, and I can reach without problems. As you can reach it through VPN, I think, our ISP’s (Internet Service Provider) DNS (Domain Name Server) might be corrupted.

Correlation is not causality

Can you still pingand traceroute the site?
If not, try the numerical IP If the latter responds, it’s definitely a DNS resolution problem.

Can you login to your router? If so can you change dns server? Does it still not find mint website
Good luck

The weird thing is, is that on my partner’s computer using the same Router, she’s using Windows I can get to Linux Mint website through her chrome. When I installed Chrome and try it says cannot find that site

The above picture is Firefox and it ain’t loading even in Windows either. I don’t understand it I am now using Manjaro and even that does not like it. I think I might try a different Kernel and see if that has anything to do with it, as I still think maybe a Firefox thing or a Bios Update, but my computer is a modern one, built by myself and the weirdest thing is, as soon as I upgraded Firefox to 84.1 it just does not want to go to Linux Mint’s website. I have even restarted the router to see if that makes any difference and it doesn’t.

So what was the result at work?

It connected with chrome but not with Firefox and now it connects here at home with tor browser. So I reckon there is something screwy going on with the new Firefox. Pic below of Tor browser.

Tor Browser using Duck Duck Go too, as I do in Firefox.

1 Like

Tor Browser is based on Firefox.

What kind of internet connection did you contract as? Cable or something else?

I’m using fiber 999MB upload and 4.9MB download Wired in not Wireless. The one at work is a lousy Wireless connection of 1.3MB download with BT. Here at home we are with Southern Scottish Electric, they are with Vodaphone.

No, I’m not talking about speeds, but the kind of internet you have at home. If you’re at Vodafone, I assume you have a cable connection?

You can easily recognize if you have a cable connection by checking if your router at home is connected to a TV cable output.

Yes I guess we do, the only new thing we got when I applied after being with them for eight years with a lousy 1.2MB connection, was a new Router. They were with BT but then the move over to Vodaphone had hiccups, where connection would keep cutting out. Spent a fortune on the phone calling them. The speeds would be better if we were closer to the exchange.

If you checked the TV cable output and it is indeed a cable connection, then your home probably is under the chains of DS Lite which all these Vodafone (and friends) pricks force upon their customers.

To sum it up, DS Lite means, you share a single static IP address with a LOT of customers. That in turn means, if just a single customer gets an IP ban for doing something naughty, all other customers who this IP address is shared with are IP banned as well. So if you sometimes experience that you cannot address certain websites from your home but e. g. from your work place, this might be a reason for this behaviour. This seems to be even more likely, if you are able to connect through Tor, as this basically changes the IP address you access online resources with.

P. S. : Always test connections with a private browser window (incognito) . Firefox is very eager in saving cookies unnecessarily, which might be another reason why a website fails to load or loads in a weird way.

My router that they gave us is connected as normal routers do. My partner’s Windows 10 machine managed to go to Linux Mint fine through her chrome.

Did you try ping

The result should be something like this:

PING ( 56(84) bytes of data.
64 Bytes von ( icmp_seq=1 ttl=52 Zeit=27.1 ms

Try to add the lines


to your /etc/resolv.conf file.

The above cured it thank you Mina :smile:

1 Like

If this is true, the problem wasn’t Firefox, but the bloody wankers from British Telecom.

1 Like

Weird ain’t it? below is Firefox, so just need to fix this with maybe adblocker? As that bypasses other weird stuff on the Internet, especially Mark Greaves’s version with Who Just Care script that he added in Peppermint 10 Respin. I shouldn’t have to, but it’ll speed the Internet up a bit as using your solution lags a bit.

Whether you use an ad-blocker or not, is entirely up to you. It will not speed up the resolution of DNS entries, though it might improve loading times if you’re on a very crappy connection.
Anyway, at some point, even the shittiest internet service provider will update its DNS records and things will get back to normal.