No option to edit (press E) from dual boot GRUB screen

After recently installing NVIDIA drivers for GPU usage my ubuntu 19 OS was getting stuck on the purple boot screen (showing “ubuntu” with 5 dots below it)

So as per the blog of https://itsfoss.com/fix-ubuntu-freezing/ it is recommended that while booting you go Grub screen and when you see Ubuntu option press E to go into edit mode for booting (to reset it to “nomode” command mode).

Now when I go to (what I think) is the Grub screen, I see no option to “Press e to edit”. I am no technical expert, but simply cant figure this out. Pressing E (or any other letter or function key SIMPLY DOES NOTHING)

Is it because this is UEFI mode? How do i fix this? Please help.

Firstly welcome to the community what you have there is the bios set up screen: the grub screen looks like this;

- this is why you can not do anything suggested there.
When you start you press F12 or whatever your system needs to enter the boot menu. That is the menu that allows you to chose which system to get in to.
You do not go to the bios set up as that only allows you to change your system settings like either Legacy or UEFI.
It is an easy mistake to make, particularly when you are learning as so many terms are similar. If you are unsure which button to press to get the boot menu on your system just google it

What you see in the picture is the UEFI of your laptop. If it always ends up there, when booting, then your GRUB2 is configured in the wrong way. You have to re-install GRUB2 for it to be bale to boot into GRUB2 and finally into Ubuntu, again.

1 Like

Yes I do press F12 which brings me to the blue screen above. I have alienware hardware and it seems there are only 2 options F12 and F2(which takes me to bios).

Is there any other button which I should try? (I tried shift, function buttons etc on boot but it seems only F12 and F2 work , they are also the only 2 options shown by alienware screen)

Hmmm ok. Can you pls suggest any way to do that?

You need to do a search for the answer to that as I can not answer that for you, sometimes you have to press delete it depends on your system as I have said to you in my answer to you. You could try the escape key, but I am really not sure on that

" sometimes you have to press delete" : I think thats what worked!! It brought me to the Grub2 edit screen(after another reboot). Thanks a ton!!

1 Like

Hello Parijat,

If Ubuntu is the only operating system on your computer, you may not see the Grub screen at the boot time. However, you can still access it with a little trick.

When you are booting up, press the Shift key or the Esc key or the Del key repeatedly. This will bring up the purple Grub screen. At this screen, press E to edit the parameters.

2 Likes