No Sound in 20.04...Again! [fixed it! kernel sound module was missing!]

I had been trying all (ALL) the remedies several times :sweat_smile: I did a “Dummy Output” search, and this answer popped up:

1 Like

I’m putting this here, as the missing kernel module(s) can wreak havoc…And, not just on sound hardware.

1 Like

I get this symtom with any Ubuntu version (except maybe 16.04) on my Gigabyte Brix NUC (Celeron)… Something to do with Intel chipset or something, fairly common - I’ve seen where people have fixed it, and I tried for a bit, and gave up (not that it was impossible - just that my care factor was low) it’s a tad annoying, but I can live with it - don’t really have much need for sound from it anway - and - sound works with a USB headset - or - over HDMI - just nothing out of the 3.5 mm stereo jack… i.e. if I plug it into DVI or VGA monitor - the only sound device I see is “dummy”…

I’ve had this symptom ever since 18.04, but also including 19.x and through to 20.04… I might try updating to 21.04 and see if that changes anything, but I doubt it… it is odd, because normally Intel drivers are a bit better on Linux than others…

1 Like

I trying more to set sound module its take more time to sound.

Note - my Ubuntu desktop machine (AMD Ryzen 7, 40 GB RAM) cr@ps out on sound when it boots - no sound from any “sink” - even though my motherboards sound card is shown in Gnome Settings…

I have to (via shell script - have redacted my swear words, and the .bash filename is also rude word) :

#!/usr/bin/env bash
# un____ ____ING PULSE the steaming pile of SH__E
pulseaudio -k
sudo pulseaudio -k
sleep 3
pulseaudio -D
sudo pulseaudio -D

It tells me not to use sudo to run pulseaudio, but I do anyway, becuase I can, and it’s my computer…