No Sound issue - Unalbe to detect sound input devide : Ubuntu 23.04

Hi There,

Please help me to get this working for me.

I have tried all possible listed solutions but non is working for me.

Shring more information related to my system.

Thank you in advance.

Regards,
Rajesh.

1 Like

Your problem is that there’s no sound device rather than just no sound, so I’m kinda not surprised that tutorial didn’t work for you. Try this and see if anything changes :

1 Like

Thanks Doron.

Atleast something is moving for now.

But, truns out kernal.org dont have codec listted with name of - Intel Icelake HDMI

https://www.kernel.org/doc/html/latest/sound/hd-audio/models.html

How we can proceed?

Thanks in advance.

Rajesh.

1 Like

Well, it turns out that that laptop is famous for this problem. The only other thing I managed to find regarding it was this - see if this gives you anything to work with :

1 Like

I had this issue on a Gigabyte Brix :


Except mine’s a Celeron (dual core), not an i5.
16 GB LPDDR3
256 GB M2 SATA SSD

I tried a whole bunch of different distros, Ubuntu 18, 20, elementary 5, CentOS 7, Debian - found a few online bits of info about getting it working, but none of that worked…

My solution? I GAVE UP and admitted DEFEAT… Sorry…

I don’t use it for a desktop! It now sits on my desk running Red Hat 8, headless (i.e. server).

One workaround I did try, that worked, was to use a USB soundcard (i.e. a USB headset) - so I could get audio, but that wasn’t ideal, so I abandoned that idea.

Sorry - if your machine has this chipset (Intel) for audio, you may be out of luck… Another thing to note - I did get this device to work on Ubuntu 16.04 connected to a TV with HDMI - audio came out okay - but I never tried this on Ubuntu 18. Have you tried getting HDMI audio out to work.

Please paste the output of “inxi -Fxz” in a reply (preferably a text paste, not a bitmap/raster screenshot! if it’s a bitmap screen shot - I’m not going to bother trying to read it - sorry) - note - I can’t install inxi on my REL8 system, so I can’t run it to compare…

1 Like

LOL I do that all the time … “can’t find anything else to do with this machine … so guess what, it’s a server now!”

1 Like

I tried again (I mostly hate admitting defeat - but sometimes discretion is the better part of valour) and inxi is still unavailable on my REL8 system.
However - I can get some details using lspci :

╭─x@fuglpige ~  
╰─➤  sudo lspci
00:00.0 Host bridge: Intel Corporation Broadwell-U Host Bridge -OPI (rev 08)
...
00:1b.0 Audio device: Intel Corporation Wildcat Point-LP High Definition Audio Controller (rev 03)
...

Can please advise paste output of inxi -Fxz (it always installs without issue on Debian and Ubuntu, in my experience) - and - lspci

Thank again Doron.

But looking at the trail and latest thread, it seems this is sitll not working. :frowning:

Thank you for sharing you story.

It seem we just need to wait until the release of codec fixes.

1 Like