No WiFi Adapter found. Ubuntu 18.04.3 LTS

No WiFi Adapter found. Ubuntu 18.04.3 LTS Any suggestions for

ASUS Vivobook X540B is WiFi only. No RJ-45connector. AMD A9 64 bit processor

sudo lshw -C network shows

*-network UNCLAIMED
description: Network Controller
product: Realtek Semiconductor Co, LTD
vendor: Realtek Semiconductor Co, LTD
physical id: 0
bus info: pci@0000:01:00.0
version: 00
width: 64 bits
clock: 33MHz
capabilities: pm msi pciexpress cap_list
configuration: latency=0
resources: ioport:e000(size=256) memory:fea00000-fea0ffff

You may have to build it from source - I had to do that for a USB 3 “AC” wifi dongle - that was maybe 3 years ago? Tried plugging it into a Ubuntu 18 machine again recently - nope - still not plug and play - have to locate the source code and build it… Don’t ask me how - sorry - I think I found the source and read the instructions (3 years ago) - pretty much gave up - I’d bought three of them - my daughters are using them on their Windows desktops fine… sometimes stuff like this also requires a rebuild of kernel objects too… PITA… Me? I’d try and find a USB wifi dongle that works out of the box…

Sorry can’t be much more help mate… someone else may have a better idea…

Firstly welcome to our friendly community. Hope you enjoy your stay with us.

Try looking in Drive Manager to add it from there. I am also pretty sure there is an article on this on the It’s Foss site, so it is worth searching there. Perhaps @abhishek remembers where it is or can help.

I can’t think of anything more as I use Mint.

1 Like

This page is for broadcom driver:

And it won’t work for realtek. Maybe you can give this a try: http://ubuntuhandbook.org/index.php/2019/04/nstall-rtl8723de-wifi-driver-ubuntu-19-04/

1 Like

I think I will be trying this on my HP laptop. I tried connecting through Ethernet ( without luck ), will it help if I use the ISO ?