Not able to boot ubuntu 20.04 or reinstall it

I am new to linux. I just baught Dell Vostro 15 3580 and I had windows 10 installed on it. I installed ubuntu 20.04 from usb. But now whenever I start my laptop , in first attempt the Dell logo doesn’t disappear, and for next attempts Grub screen appears. When I select ubuntu, only a black screen appears(with NO blinking cursor in it). If I select from linux kernal option, the boot hangs at “loading ramdisk…” line (same happens for recovery mode). However, if i plug charger into my laptop before starting laptop, ubuntu loads without any problem.

Then I tried to install ubuntu 18.04. However, when I choose any option (like install , or try without install), then the screen goes off and laptop starts restarting again and again. Are there any solutions?

Note- the bios version is 1.4.1. and there is no PPT security option to be disabled in it.

You can try if the following works:

Using nomodeset sometimes fixes a lot of graphics-related issues.

Actually I tried the nomodeset solution, but it didn’t work.

Does Ubuntu Live work?

No. It just starts restarting again and again when i boot live usb.

Take a look at this.

I updated bios to the latest version. Now it is working perfectly well. Thanks for your help☺️