NTFS permission issue

Well mine is formatted as NTFS as I use that particular partition to store files on windows and Ubuntu and access it from either OSes. I need help with this particular drive. I am unable to rename files or folder or even create new one on it from Ubuntu.However copy and past is working with the exception of cut not working.

Checked the properties and it is showing create and delete in the permissions. Tried installing another file-manger called thunar after reading around about the issue. The disk showed read only file system when i tried out this fix https://itsfoss.com/set-write-permission-ext4-partition-ubuntu-linux/

These are the steps I followed to to identify the read only file system message
1)sudo blkid
Result for my particular disk:/dev/sda6: UUID=“92A064BAA064A707” TYPE=“ntfs” PARTLABEL=“Basic data partition” PARTUUID=“f223115a-05df-4b39-aa6c-d0da54c5b870”
2) ll /media/$USER
Result for my particular disk: drwxrwxrwx 1 jithu jithu 4096 May 6 05:45 92A064BAA064A707/
3) sudo chgrp adm /media/$USER/92A064BAA064A707
Result for my particular disk: chgrp: changing group of ‘/media/jithu/92A064BAA064A707’: Read-only file system

I AM ABSOLUTE NEWB TO UBUNTU. Choose this OSes after reading some of your articles on Linux OSes.

I need help with this issue

This is the important part, however you should probably read through the entire thread.

I did read else where its OK to do that but not to mount the C drive. So I made 3 main partitions
C for Windows OS
D common storage for Win and Ubuntu
E for Ubuntu Os

and then some small stuff called swap and other things like I had seen in a tutorial video. I think it was abishek’s(site owners) tutorial

I am able to copy stuff to this common drive on Ubuntu. To do any kind of editing like renaming i would have to copy paste to desktop do my business and then copy it back to common storage.

It doesn’t matter which partition. All NTFS partitions can cause issues. However, if you mounted the drive read-only, you just need to remount it with rw permissions:

sudo mount -o remount,rw /dev/sdXX /mnt/shared

can you be little more specific to the command to be entered in the terminal…the drive name is :/dev/sda6.

I dont want to unmount all drives and turn them into read write mode,only this particular drive.

Chose to use Ubuntu as Win 10 is giving 100% disk error almost all time when i use any programs plus its kinda not that responsive like the apps here on Ubuntu. Tried reinstalling win10 to the latest release, it did work for some time.
Tried disabling super-fetch and windows indexing and even defender but to no avail

That’s a fact you are never supposed to ignore. :smiley:
Broken storage media often goes into read-only mode, if they still can.

Run these commands as the root user:

apt update
apt install -y smartmontools
smartctl -x /dev/sda

That will display information about the hard drive and possibly could show if and/or how it failed.

1 Like

It used to show that error even before i installed Ubuntu. I installed Ubuntu for the sole purpose of escaping from that

Here is the result from the command you provided… Its doesn’t provide much info

jithu@jithu-HP:~$ apt update
Reading package lists… Done
E: Could not open lock file /var/lib/apt/lists/lock - open (13: Permission denied)
E: Unable to lock directory /var/lib/apt/lists/
W: Problem unlinking the file /var/cache/apt/pkgcache.bin - RemoveCaches (13: Permission denied)
W: Problem unlinking the file /var/cache/apt/srcpkgcache.bin - RemoveCaches (13: Permission denied)
jithu@jithu-HP:~$ apt install -y smartmontools
E: Could not open lock file /var/lib/dpkg/lock-frontend - open (13: Permission denied)
E: Unable to acquire the dpkg frontend lock (/var/lib/dpkg/lock-frontend), are you root?
jithu@jithu-HP:~$ smartctl -x /dev/sda

Command ‘smartctl’ not found, but can be installed with:

sudo apt install smartmontools


Yes. You should not do that!

You did not run the commands, as root.

I am at a loss now, tried enter key and nothing is happening cant proceed further without exiting this…any ideas?

If you only executed the commands I have shown you, there is no way this could pop up. Interrupt the process and repeat issuing only the commands I have shown above.

That command is which that is making that screen-pop up. i tried again and its the same result
I dont know how to append root the the command lines you provided so i google and some one said to input “sudo -i” and that made it go root and showed # instead of $.

then i entered “apt install -y smartmontools” each time that window is popping up in terminal

That screen is some configuration for the app “smartmontool”…Google search showed to press tab and then enter when OK is highlighted and select desired configuration.

Following is the result for “smartctl -x /dev/sda”. I CANT MAKE HEAD OR TALES OF THE OUTPUT

Device Mode :     HGST HTS541010B7E610
Serial Number:    WX11A680JXZV
LU WWN Device Id: 5 0014ee 6b369065b
Firmware Version: 03.01A03
User Capacity:    1,000,204,886,016 bytes [1.00 TB]
Sector Sizes:     512 bytes logical, 4096 bytes physical
Rotation Rate:    5400 rpm
Form Factor:      2.5 inches
Device is:        Not in smartctl database [for details use: -P showall]
ATA Version is:   ACS-3 T13/2161-D revision 5
SATA Version is:  SATA 3.1, 6.0 Gb/s (current: 6.0 Gb/s)
Local Time is:    Wed May  6 16:39:11 2020 IST
SMART support is: Available - device has SMART capability.
SMART support is: Enabled
AAM feature is:   Unavailable
APM level is:     128 (minimum power consumption without standby)
Rd look-ahead is: Enabled
Write cache is:   Enabled
ATA Security is:  Disabled, NOT FROZEN [SEC1]
Wt Cache Reorder: Enabled

SMART overall-health self-assessment test result: PASSED

General SMART Values:
Offline data collection status:  (0x00)	Offline data collection activity
					was never started.
					Auto Offline Data Collection: Disabled.
Self-test execution status:      (   0)	The previous self-test routine completed
					without error or no self-test has ever 
					been run.
Total time to complete Offline 
data collection: 		(  840) seconds.
Offline data collection
capabilities: 			 (0x51) SMART execute Offline immediate.
					No Auto Offline data collection support.
					Suspend Offline collection upon new
					No Offline surface scan supported.
					Self-test supported.
					No Conveyance Self-test supported.
					Selective Self-test supported.
SMART capabilities:            (0x0003)	Saves SMART data before entering
					power-saving mode.
					Supports SMART auto save timer.
Error logging capability:        (0x01)	Error logging supported.
					General Purpose Logging supported.
Short self-test routine 
recommended polling time: 	 (   2) minutes.
Extended self-test routine
recommended polling time: 	 (  86) minutes.
SCT capabilities: 	       (0x303d)	SCT Status supported.
					SCT Error Recovery Control supported.
					SCT Feature Control supported.
					SCT Data Table supported.

SMART Attributes Data Structure revision number: 32
Vendor Specific SMART Attributes with Thresholds:
  1 Raw_Read_Error_Rate     POSR-K   100   100   050    -    11
  3 Spin_Up_Time            POS--K   056   055   021    -    1375
  4 Start_Stop_Count        -O--CK   100   100   000    -    1889
  5 Reallocated_Sector_Ct   PO--CK   100   100   010    -    0
  7 Seek_Error_Rate         POSR-K   100   100   030    -    42838
  9 Power_On_Hours          -O--CK   100   100   000    -    633
 10 Spin_Retry_Count        PO--CK   100   100   050    -    0
 12 Power_Cycle_Count       -O--CK   100   100   000    -    238
183 Runtime_Bad_Block       -O--CK   100   100   000    -    0
184 End-to-End_Error        PO-RCK   100   100   097    -    0
187 Reported_Uncorrect      -O--CK   100   100   000    -    0
188 Command_Timeout         -O--CK   100   100   000    -    1
189 High_Fly_Writes         -O-RCK   100   100   000    -    0
191 G-Sense_Error_Rate      -O--CK   001   001   000    -    2046
192 Power-Off_Retract_Count -O--CK   100   100   000    -    133143986207
193 Load_Cycle_Count        -O--CK   097   097   000    -    7012
194 Temperature_Celsius     -O---K   039   050   000    -    39 (Min/Max 37/39)
197 Current_Pending_Sector  -O--CK   100   100   000    -    0
198 Offline_Uncorrectable   ----CK   100   100   000    -    0
199 UDMA_CRC_Error_Count    -O--CK   100   100   000    -    0
200 Multi_Zone_Error_Rate   ---R--   100   253   000    -    0
240 Head_Flying_Hours       -O--CK   100   100   000    -    156013
243 Unknown_Attribute       -O--CK   100   100   000    -    310252
                            ||||||_ K auto-keep
                            |||||__ C event count
                            ||||___ R error rate
                            |||____ S speed/performance
                            ||_____ O updated online
                            |______ P prefailure warning

General Purpose Log Directory Version 1
SMART           Log Directory Version 1 [multi-sector log support]
Address    Access  R/W   Size  Description
0x00       GPL,SL  R/O      1  Log Directory
0x01           SL  R/O      1  Summary SMART error log
0x02           SL  R/O      5  Comprehensive SMART error log
0x03       GPL     R/O      6  Ext. Comprehensive SMART error log
0x06           SL  R/O      1  SMART self-test log
0x07       GPL     R/O      1  Extended self-test log
0x09           SL  R/W      1  Selective self-test log
0x10       GPL     R/O      1  SATA NCQ Queued Error log
0x11       GPL     R/O      1  SATA Phy Event Counters log
0x24       GPL     R/O    277  Current Device Internal Status Data log
0x30       GPL,SL  R/O      9  IDENTIFY DEVICE data log
0x80-0x9f  GPL,SL  R/W     16  Host vendor specific log
0xa0-0xa7  GPL,SL  VS      16  Device vendor specific log
0xa8-0xb6  GPL,SL  VS       1  Device vendor specific log
0xb7       GPL,SL  VS      74  Device vendor specific log
0xbd       GPL,SL  VS       1  Device vendor specific log
0xc0       GPL,SL  VS       1  Device vendor specific log
0xc1       GPL     VS      93  Device vendor specific log
0xe0       GPL,SL  R/W      1  SCT Command/Status
0xe1       GPL,SL  R/W      1  SCT Data Transfer

SMART Extended Comprehensive Error Log Version: 1 (6 sectors)
No Errors Logged

SMART Extended Self-test Log Version: 1 (1 sectors)
Num  Test_Description    Status                  Remaining  LifeTime(hours)  LBA_of_first_error
# 1  Short offline       Completed without error       00%        69         -
# 2  Short offline       Completed without error       00%        68         -

SMART Selective self-test log data structure revision number 1
    1        0        0  Not_testing
    2        0        0  Not_testing
    3        0        0  Not_testing
    4        0        0  Not_testing
    5        0        0  Not_testing
Selective self-test flags (0x0):
  After scanning selected spans, do NOT read-scan remainder of disk.
If Selective self-test is pending on power-up, resume after 0 minute delay.

SCT Status Version:                  3
SCT Version (vendor specific):       258 (0x0102)
SCT Support Level:                   1
Device State:                        Active (0)
Current Temperature:                    39 Celsius
Power Cycle Min/Max Temperature:     37/39 Celsius
Lifetime    Min/Max Temperature:     25/50 Celsius
Under/Over Temperature Limit Count:   0/0
Vendor specific:
01 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00
00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00

SCT Temperature History Version:     2
Temperature Sampling Period:         1 minute
Temperature Logging Interval:        1 minute
Min/Max recommended Temperature:      0/60 Celsius
Min/Max Temperature Limit:           -41/85 Celsius
Temperature History Size (Index):    128 (45)

Index    Estimated Time   Temperature Celsius
  46    2020-05-06 14:32    38  *******************
 ...    ..(  2 skipped).    ..  *******************
  49    2020-05-06 14:35    38  *******************
  50    2020-05-06 14:36    39  ********************
  51    2020-05-06 14:37    38  *******************
  52    2020-05-06 14:38    39  ********************
 ...    ..( 24 skipped).    ..  ********************
  77    2020-05-06 15:03    39  ********************
  78    2020-05-06 15:04    38  *******************
  79    2020-05-06 15:05    39  ********************
  80    2020-05-06 15:06    38  *******************
  81    2020-05-06 15:07    39  ********************
 ...    ..( 12 skipped).    ..  ********************
  94    2020-05-06 15:20    39  ********************
  95    2020-05-06 15:21    38  *******************
 ...    ..(  4 skipped).    ..  *******************
 100    2020-05-06 15:26    38  *******************
 101    2020-05-06 15:27    39  ********************
 102    2020-05-06 15:28    39  ********************
 103    2020-05-06 15:29    38  *******************
 104    2020-05-06 15:30    39  ********************
 ...    ..(  5 skipped).    ..  ********************
 110    2020-05-06 15:36    39  ********************
 111    2020-05-06 15:37    38  *******************
 ...    ..( 14 skipped).    ..  *******************
 126    2020-05-06 15:52    38  *******************
 127    2020-05-06 15:53    37  ******************
   0    2020-05-06 15:54    38  *******************
 ...    ..(  6 skipped).    ..  *******************
   7    2020-05-06 16:01    38  *******************
   8    2020-05-06 16:02    37  ******************
 ...    ..( 20 skipped).    ..  ******************
  29    2020-05-06 16:23    37  ******************
  30    2020-05-06 16:24    38  *******************
 ...    ..(  7 skipped).    ..  *******************
  38    2020-05-06 16:32    38  *******************
  39    2020-05-06 16:33    39  ********************
  40    2020-05-06 16:34    39  ********************
  41    2020-05-06 16:35    38  *******************
 ...    ..(  2 skipped).    ..  *******************
  44    2020-05-06 16:38    38  *******************
  45    2020-05-06 16:39    39  ********************

SCT Error Recovery Control:
           Read:     85 (8.5 seconds)
          Write:     85 (8.5 seconds)

Device Statistics (GP/SMART Log 0x04) not supported

SATA Phy Event Counters (GP Log 0x11)
ID      Size     Value  Description
0x0001  2            0  Command failed due to ICRC error
0x0002  2            0  R_ERR response for data FIS
0x0003  2            0  R_ERR response for device-to-host data FIS
0x0004  2            0  R_ERR response for host-to-device data FIS
0x0005  2            0  R_ERR response for non-data FIS
0x0006  2            0  R_ERR response for device-to-host non-data FIS
0x0007  2            0  R_ERR response for host-to-device non-data FIS
0x0008  2            0  Device-to-host non-data FIS retries
0x0009  2            0  Transition from drive PhyRdy to drive PhyNRdy
0x000a  2            1  Device-to-host register FISes sent due to a COMRESET
0x000b  2            0  CRC errors within host-to-device FIS
0x000d  2            0  Non-CRC errors within host-to-device FIS
0x000f  2            0  R_ERR response for host-to-device data FIS, CRC
0x0012  2            0  R_ERR response for host-to-device non-data FIS, CRC
0x8000  4         8906  Vendor specific

SMART data looks fine. However, there are lots of hard drives out there, that have perfect SMART values and still fail (even happened to one of my drives, already).

Do you remember what disk errors you were seeing in Windows?
Did you ever let the drive fall on the ground while it was running?
Did anything else happen to your computer or hard drive?
Does it make strange sounds when it runs?

That said: until we haven’t figured out, what is wrong with the HDD, don’t use it!

1 Like

It doesn’t show any error in the literal sense just that “In task manager disk is always showing 100% utilised” even when the processes in the tray says otherwise.

Win 8.1, Ubuntu works smooth without showing any such issues. WIN 10 is the culprit. I thinks its mostly software related. Not optimised to work well or something. I think its an issue that plagues all versions of Win 10. PC was bought in 2018 last and came with Win 10 some version. Due to this same issue, I altogether stopped using this PC and relayed on my 2012 model DELL with broken display. Though of getting it checked by technician as I doubted it might be something with the HDD like someone might have damaged it or something.

Just before resorting to technician for the services, I uninstalled Win 10 and installed Win 8.1 and issue was gone, as in PC worked fine. Later I uninstalled that and installed Win 10 2019 November version and worked OK OK.

Main issue I observed is the performance hit at time when I use memory intensive apps e.g: browser with many tabs open, that when disk usage is shown at 100% while RAM and CPU level are within acceptable levels.

Reported cause for this issue from Googling, was that a program called Superfetch services(now renamed as Sysmain), Windows indexing services and at times Defender.
Disabling Sysmain and Defender bring down the instances of the issue but it still persists.

Present PC is running a 7th Gen i3. It could be hardware compatibility issues or like you said it possibly be HDD issues.

This code is returning the following output

“mount: /mnt/shared: mount point does not exist.”

That sounds exactly like my hard drive that failed without SMART errors. It really seems like your hard drive is failing. Just because it works better in Windows 8 or other systems, it does not mean that the HDD is OK. I experienced the exact same issue and it got worse and worse over time. Now my HDD only can read/write 1kb/s instead of several MB/s. So it technically “works”, but it is clearly failing.
Once I bought a replacement drive, cloned the contens from the old drive to the new one, everything was perfect again.

Do you have a replacement drive? If yes, try out if it is similarly slow. If it is not, your old HDD is most likely failing.

Yes. Of course. You have to change the mount point to the actual directory where the partition is mounted. However, as I said, you need to find out what the issue is, before you do anything with the HDD or you can break it even more and then make ALL files on it irrecoverable.

Damn I should have taken it for repair then, the warranty got expired last month. I dont have any replacement drive, even if i salvage from my old PC I don think it is compatible with HP, Only thing that’s there is external HDD

First thing I would do (which I also did when it happened to my drive) is back up everything on this failing drive to a new drive, so you don’t lose files. Once this is done and the backup is confirmed to work, then you can do more tests with the failing drive.

Important files and software exes are stored in external HDD and the rest on the lap with broken display… So that wont be an issue. I just use this for work which is mostly done online. With access to Ubuntu, things go much better than before, since browser is more responsive and fast compared to working on Win 10. If it weren’t for the black patches on the display of the other PC, I would still be using that.

Need each and every corner of the screen for reading charts as part of my works, misreading or delay costs dear in my field.

Anyway thanks a lot for your help. Broken Ubuntu yesterday trying to fix umet dependencies errors, just reinstalled it clean and with updates that issue seems resolved, with WINE installed most of my work could be done on Ubuntu.

Though I did encounter few performance hits on this, that mostly when moving large files to somewhere. Maybe that too is HDD related

1 Like