OBS Is Screen Tearing when there is no screen tearing whilst gaming

Did not know where to post this.
I’ve finally moved away from Windows Gaming to Linux Gaming through Proton, as support is unbelievable for Windows Games in Proton.

Been trying to record Resident Evil 8 Village all week, but end up with OBS and Simple-Screen-Recorder both tearing after recording. Not a sign of any tearing whilst I’m gaming? I have NVIDIA 3060 with 12GB of Ram, paired with RYZEN 5 2600 CPU six cores, twelve threads. On an ASROCK B450M Pro 4 motherboard, with 16GB of onboard Ram. Running Linux Mint Uma XFCE Edition 20.04.2 on a 2TB SSD. Before anyone says about Force Full Composition Pipeline, it is activated as is Option DPI 96x96, just to make sure that I don’t suddenly get tiny, tiny Fonts like we used to, after activating Pipeline. I have tested with screen tearing videos of black and white vertical bars off YouTube, it tears when recording the YouTube Screen Tearing Video. I also in NVIDIA settings have activated and had inactive VSync to Blank. I also turned off screen effects and still tearing. The only thing I have not tried is reinstalling my 1660 Graphic Card, as I think Linux is not ready for 3060, though other people have 3080 ti and 3090’s. The weird thing is, is this 3060 card does not get recognized in Neofetch, yet my 1660’s do. I will update you once I have reinstalled 1660 NVIDIA card.

If you run the game on HDD 1, then you have to record to HDD 2. You need two storage media.

If you record to the same device from which you run the game, the HDD is probably too slow to load the game and then write to it swiftly enough, simultaneously.


Neither HDD needs to be particulary fast. You can use 2 slow HDDs. Just don’t game and record on the same device. That’s it.

1 Like

I get noticable screen tearing when watching Netflix or full screen youtube videos, in Brave browser… I attribute this to my monitor (its only 60 hz). It’s a Lenovo 32" QHD, I run it over either HDMI or DP, and same / similar result. And also the same in VLC (full sreen)…

I haven’t really noticed whether this happens in games…

Note : also - the tearing is noticeable, but it does NOT make things “unwatchable” and if it’s compelling viewing (like I recently watched the gripping thriller Netflix series “Severance” : EDIT : this is an AppleTV+ series, not Netflix, watched it in Brave browser and AppleTV website) I barely notice it, it’s an annoyance, not a show stopper.

I am plannning on replacing nearly ALL of the hodgepodge of different monitors on my desk, L to R :

  • pair of Dell 23" FHD monitors - off my personal MacBook Pro M1 (2 x displayport from Dell D6000 USB C displaylink dock).
  • Lenovo 32" QHD over DP of my Ryzen 7 “gaming” setup (Linux ONLY - currently Fedora 35) + 20" over DVI 4:3 (1600x1200) Samsung.
  • AOC 26" FHD - my work supplied MacBook Air 13" (Intel CPU / GPU).

Good to see you’ve dropped Windows as your gaming platform. I’ve seen a few benchmarks recently of Top Shelf games getting BETTER frame rates on the Steam Deck, using Proton, than natively on Windows 10/11!!!*

Borderlands 2 (Linux native) is about the heaviest GPU / intensive game I play (and I still play it - and enjoy it - and haven’t finished all of the DLC I’ve bought for it over the last 6-7 years, but, despite being native, and having a heap of Australian and Kiwi voice actors, just can’t be arsed playing The Pre Sequel).

Most of the rest I play is stuff like Surviving Mars (Linux Native), Cities Skylines (native) - but - also Age of Empires II HD Edition (still the best ever RTS ever made IMHO - I loathe turn based strategy games). I do have a bunch of other games I’ve purchased through Steam, but I use other “engines” to play them, e.g. GZDoom or the open sourced engines for ID games using things like Lutris… I also have a Linux native version of Commandos 2 HD Remaster, but, when I played this game 20 years ago, there were cheats - but - I can’t get ANY cheats to work, and it’s unplayable for an old bugger like me, without cheats, I don’t get past the VERY first mission!

* I think one of those was the L4D2 sequel : Back 4 Blood… disappointing, as L4D2 was on of the VERY first Linux native games available on Steam. One of the others was Serious Sam 3. Both those games convinced me to STOP dual booting! Disappointing the latest installments don’t have Linux native versions, and Proton does, and will, make Game Studios LAZY about porting to other platforms…

Update - I also have Vallheim, native, I once played it for about 6 hours - but I just can’t really get my head around what I’m supposed to do in it… also - I’m a huge dinosaur nerd, and I bought Path of Titans recently - and I have to choose between snap and appimage (appimage failed - so trying snap)…

1 Like

I do record on separate SSD a 2TB storage drive for VirtualBoxing saves reinstalling ISO’s all the time. What I didn’t mention in original post, is that I upgraded to XFCE 4.16. Could that be a reason why? I never had this problem with my NVIDIA 1660 cards, though it has only been with recent experimentation with the 3060 card with installing XFCE 4.16. I will install later on today 1660 card and see if that improves it. 1660 cards have been out longer, worked flawlessly out of the bag since 18.04 days.

Do you have Pipeline activated in NVIDIA settings? I never noticed the tearing whilst playing the game, it was always after reviewing the recording. I have a slightly curved 32" BenQ gaming monitor with GSync built in. Always in NVIDIA settings on the OpenGL settings untick V-Sync and Monitor Flipping, which is meant to also stop flickering whilst recording, when Pipeline under advanced is activated you should not need V-Sync activated.

I only use Windows to get my GOXLR settings loaded for recording my Shure SM7B Mic. There is a GitHub script, but you still need the proprietary software to run it. Not bothered about the sound effects on it, just need the Gate, De-Esser off of it. I’m fifty this year and already have way too many gaps in my teeth, causing me to have very harsh esses, not Essay’s have not written one of those in years.
The only sound effect that works on it is the cussing beep in Linux.

The stupid design flaw, is that there is no power button for it, so plug it in, wait a billion years for Windows to boot, even though it is on a SSD on it’s own computer, sharing same screen and USB hub. It takes forever to boot because of all the checks Windows does during boot. Login and wait for the GOXLR Settings to boot, LED party on the GOXLR with it’s four mixing desk Equalizer handles moving up and down till the settings are loaded. Keeping GOXLR on then power off Windows go back into Linux and Bobs your Uncle, Fanny your Duck if you want to, if you got a duck to hand?? GOXLR gets recognized in Pulse and sounds brilliant. Why the makers did not write a script for Linux is beyond me?

Yes unbelievable all my games work out of the bag, with no lagging all in 1440p and only using Proton 6.3 nothing else. Apart from having to install the latest Wine Staging with all the 32bit codecs, fonts etc. Linux runs these games flawlessly and just keeps saying yes to everything I chuck at it. Apart from the tearing issue when recording. I’m as happy as a pig in Swill.

Well I’ve cracked it, it’s weird as after reinstalling my daily drive with NVIDIA 1660 Linux Mint Ulyssa 20.04.1 Sorting the Pipeline composition in NVIDIA Settings. watched a previous video of Resident Evil 8 that I done, no screen tearing. Put it down to being the 3060 card, not recognizing Open Source drivers, when I installed Linux Mint the first time round with the 3060. So look out for Resident Evil 8 on my YouTube channel played in beautiful Linux. :grin: Got to reinstall gaming side now, with Ulyssa again this time round instead of Uma.


Indeed, I pointed that out already many times in this forum. NVIDIA is just not very compatible with Linux tools. You usually should use the drivers provided by NVIDIA.

Did you get it to work with the open source driver, though? That would be astonishing.

Proprietary driver that Linux Mint goes off and finds, recommended 470 Drivers. It played ball after that, apart from letting in screen tearing over to OBS, which did record it, but now playing video back with 1660 Card that Nouveau recognizes, they ain’t there no more. Scratched my head a few times, in wondering why? When I first installed with 3060 card had resolution of 1024x768. Took me back to old heavy monitor days, with Ubuntu 10.04, though at least it wasn’t 800x400 like it was back then with 10.04, before getting NVIDIA drivers installed. Bloody nightmare that was, as the NVIDIA Driver window that popped open, was larger than the monitor, still in 800x400 resolution. Using tab button to get to the right part of the window to hit apply. No wonder Linus stuck his middle up at them. :laughing:

So even after I thought I’d sussed it, turns out the reason why getting screen tearing in XFCE is because must deactivate screen compositing, either before or after activating composition pipeline. Going to go back to my 3060 tomorrow, better performance. Smashed my curved monitor yesterday, weird thing is my old monitor was not curved and since I moved into spare room, always had left it near the window, where it is a sun trap. This monitor was not curved before, since it it’s been in the sun it’s warped outwards, looks good.