Observations of a distro hopper

Hi fellow members,

This article is being rewritten, it will teach me not use my rough notes when suffering from sleep deprivation.

Edit: Tuesday 1600hrs 29 January 2019.

Hi fellow members, this is the rewrite.

I have sampled many distros using: Gentoo, RPM, Debian and Arch platforms, in the last few months.

The criteria of the test, each distro had to install from a USB, with levels of post install fettling assessed, and if first impressions were favourable, and not a labour of love to get to it function, it would be evaluated for one week on my test machine.

I think of Linux as a tool box, to choose the right tool for the job. A powerful rig with high end spec CPU, GPU, Cooling and Ram; can and should run any heavyweight desktop environment with ease. A laptop has inherent cooling issues, thus a lighter weight distro being paramount.

I will only summarise the highlights, I observed. At the the end of the day, it is an opinion and we’ve all have one; like armpits.

I have been keen to try a Gentoo based distro, to make an informed opinion, as all previous attempts have ended in abject failure.

This time I managed to install Sabayon Gnome, it proved to be a clean install, looked good, well polished and it had over 900 updates, to do, no problem I thought, seven hours later, I had left it to get on with it. It has only reached just under a third of the way through them. Each update was being processed and checked via at least three stage GPG check and verified by image-mirror, and was using hard-wired internet connection of 1000mbps. Lost interest and deleted. I shall try when their new annual snapshot is released and the updates not so numerous, then review it.

Redcore LXqt, both attempts, could download an iso, dd it to USB stick, boot it to the boot splash display and the auto-load would load the live session to a BSOD. Looking at the USB sticks afterwards suggested all iso files were all present and correct.

I have had success with rpm over the years, though not my cup of tea, PCLOS semi rolling platform using either Mate or LXDE has been an interesting diversion. Ditto with Gecko and openSUSE Leap editions. CentOS 6 Gnome and KDE Enterprise desktops were both fully featured with apps, only lacking DVD playback, proved useful for longevity purposes. With CentOS 7 I saw quality control issues with KDE, it had been parred down, and many KDE apps did not function correctly, then the firewall issue with Gnome, that occurred from the outset left me nonplussed and uninterested by this point. Not tried since mid 2016.

Both Gecko and openSUSE Tumbleweed editions will install painlessly, during post install upgrades, fatal errors are thrown up that prove fatal to both. Erase and reformat the stick with dd, re-image new iso image to stick via dd, once installed, the upgrade to both, proved fatal again. Delete.

Fedora, I look at in VB occasionally but its six monthly cycle, not something I’ll consider, for long term use, due to poor experience with their bi-annual upgrade system, when using Korora and Fedora 23 through to 25.

PCLOS KDE, nice and easy, same old issues with KDE, would freeze and kept crashing. Delete.

This turned out to be very interesting with the unexpected, I’ve seen this before and those same old.

MX-Linux, using the Debian platform and the new kid on the block, version 17 with 4.15 kernel exceeded my expectations and really tempted by it, but like version 18, it only came with Nvidia 390 driver and my device required at least the 4.10 driver. Version 18 is well polished and thought out, and tweaked with fully functioning Plymouth to clear up the diagnostic scripts. Miss systemd, and the tools that go with it, as they have altered the system by use of a shim for their use and gave a technical reason, why.

Debian Gnome, loaded it with Gnome extension goodies, i.e log out button and dash to dock panel, clone icons from github to transform its rather drab vanilla look to a real beaut. But the same old apps creek and froze, hung or did not want to co-operate. i.e Cheese, User and Group pages. Work progress for Debian, thus deleted.

Linuxmint Cinnamon, Ubunt platform with the Y themes and icons sets enhancing their standard they have set for Cinnamon, over the years. Subtle improvements all round, notably getting rid of their drab icon set in Libre Office. Used as an aide to help assess Ubuntu relented issues.

Peppermint, Ubuntu platform, still a great distro, but being hampered by Ubuntu slow boot.

Netrunner KDE, same old issues, kept crashing, still best looking KDE out there.

Neptune KDE, functional, did not crash as much, or as pretty as Netrunner. Similar to Devuan purplish log in/out screen, the shutdown and reboot buttons, did not function. Deleted

Debian LXDE, still as functional, now I have mastered all the nuances and tricks to turn LXDE into a work of art with different icons and themes, conky (a Frankenstein MX-Linux theme), compton compositing, plank with all the apps auto-started via the lx-session>config>auto-start file (with @plank etc), rather wasting time using the GUI auto-start page, which was always a pig. A shame really as this desktop is being slowly consigned the dustbin of history.

KDE neon, Ubuntu platform, this did surprise me, essentially it proved to have the cleanest boot time of all Ubuntu based distros I’ve tried since 18.04 was released. A parred down KDE, yet with their own distinct feel and look. I have observed over recent years most of KDE apps have been falling apart, first noticed it with CentOS 7 KDE, it only came with a terminal, file manager and browser. When I tried to load the usual KDE apps the known KDE problems occurred. Deleted.

Bunsenlabs, heard great things about this former CrunchBang distro, use the Debian platform, first impression, looked pretty and functional with planish wallpaper and the right-click menu which adds apps to the menu list dynamically. I noticed the laptop was overheating after only 45 mins use, the SSD drive had reached 55c. Let it cool down and install tlp, acpi and various sensors and laptop tools, an hour later 51c, and cpu was 95c, this was with the laptop cooler running at full whack. Deleted.

Manjaro and Arcolinux are worthy mentions, I favoured Manjaro, because Arcolinux also used the yay, yaourt and aur repos. But saying that, Eric Dubios, of Arcolinux has a lot of easy to follow and well written tutorials, supplemented with video, on about every facet of all the desktops he is offering, up to 12. His website is very well presented and excellent reference guide.

I ran Manjaro Gnome on my my main rig from October 2018, without issue, until 26 & 27 Jan 2019, when I tried several new recipes of Debian backports with 4.19 kernel, and Debian 10 Buster. Once all fettling was done and fully loaded, it turned into a slug. Reinstalling Manjaro on Sunday afternoon was a pleasurable as my Ubuntu experiences many moons ago being clean and easy, with post fettling compared to Debian, being a gentle stroll in the park. No ACPI BIOS bugs reading like a bad case of measles, essentially just had to adjust the swap and pressure cache file and the wallpaper, then personal touches, it was good to go. The whole desktop was and is again, a pleasure to use, all apps working without fuss.

Manjaro Openbox, currently still on the Dell 5430, this is a well presented, functional and highly polished desktop, err….Window Manager. Now I have get used to the Openbox quirks, it uses the Xfce Thunar file manager, tint2 and polybar to house drop down menu, system tools and app launchers, the sum of its parts make a simple yet slick working environment. Plus point it runs much cooler (Bunsenlabs disk high of 55c and cpu 95c), the disk temps are 33c to 38c during prolong use and cpu hardly goes above 70c using the same operating methods and and laptop cooler.

Manjaro i3 and Awesome, did not take to them, they are Tiling Windows system. Nor did they have the clean lines of their Openbox.

Manjaro Architect, had several aborted attempts due to its lack of intuitive feel, it is my potential learning tool prior to practise installing Arch, as this is my Bucket Wish List (final computer must do), install Arch, using the purist method.

Antergos, like Redcore would download and could burn to USB stick, boot to the boot splash display and auto-load the the live session, then the BSOD. Looking at the USB sticks afterwards suggested all ISO files were all present and correct.

Archlabs, installs using their “utext” installer (can’t remember its name precisely), but quite intuitive and again a useful learning aid for doing the real thing. Once installed, it had numerous issues and lacked a certain quality control. My limited knowledge of Openbox, did not help. The terminal with its neofetch, never reflected any icon or theme changes, I made. Whereas ArcoLinux, Bunsenlabs and Manjaro versions would. As much as I liked Archlabs premise and installer, Manjaro’s Openbox is more functional and polished, outta the box.

Arch, failed during torrent download over a three week period, last tried 10 or 11 Jan, still gave “too many files open to preserve download file” error.

Debian experiment
Laptop backported linux-images 4.18 and 4.19 tested on 6th and 3rd gen laptops, no issues before, during or after, seamless. Both still boot up within 14 to 15 secs.

Pleased with the laptop tests I then successfully installed backports to my main rig with the 4.19 kernel and Nvidia drivers, only to find it to be very sluggish on boot up. Whereas the 4.09 kernel took 14 to 15 secs the 4.19 kernel took 30 plus.

Debian Gnome 10 (Buster or Debian testing) tried several recipes, the official iso is to test the installer only apparently, as it would not update, nor able to upgrade it. The minimal Stable install was painless, as the update & upgrade, reboot, then install Gnome desktop install 4.19 Linux-image and 4.19 Nvidia driver code, like the Stable install with backports it became a slug taking 30 plus seconds to cold boot.

Full specs of computers used and their purpose

Main Rig used to test Debian backport and Buster, currently has Manjaro installed
Master Cooler (MasterBox MB511 RGB) Case
AORUS Z370 ATX mobo
CPU i7-8700
32GB Ram
GTX GeForce 1060 6GB Nvidia card
Samsung 1TB SSD
Liquid cooled

Test Laptop
Dell Latitude 5430 non v-Pro
CPU i7-3520M
16GB ram
1600x900 display
Samsung 250GB SSD
Laptop cooler KLIM 300 (720rpm to 1050rpm fan speed)

Backport test only (still has Debian Stretch installed Nov 2017)
Dell Latitude 5470 v-Pro
CPU i7-6820 HQ
32GB ram
FHD 1920x1080
Samsung 500GB SSD
Laptop cooler KLIM 300 (720rpm to 1050rpm fan speed)

Installation media and method
USB3 DataTraveller G4 8Gb stick, three used.

Usually would use Gparted to wipe and format stick, if any doubt arose I would erase using dd then format it using dd. This always being the optimum solution.

I would downloaded an iso from each distro’s site, SourceForge and Linuxtracker, to eliminate doubt of iso integrity, also checksum each. Still had dud installs, even when USB showed all files were present and correct.


This became a three prong objective, when my Bitfenix rig i7-4970, ASUS Q87 mobo, 32Gb, GTX 1050Ti graphic card, expired and I could not source a new mobo. In September of last year, I then bought my current Master Cooler rig (specs above).

  1. I was looking to find an OS that would run on this rig.
  2. Do my usual distro hopping
  3. Keep at least one machine with Debian on it.

The results along the way are genuine and mixed, tinged with disappointment where I would of liked a different outcome. I have NO axe to grind, just my observations while distro hopping.

Objective achieved. Though not as I hoped for, but satisfactory.



Very interesting post. Though, the first thing I noticed that something crucial is missing:

You still need to post the full specs of your target machine, since this has a lot to say about compatibility and whether a distribution will or will not work.

Especially when using different laptops.

Well, that’s perfectly normal with Gentoo. It is a very niché distribution for when you want to do every bit of work on your own. I guess, if you want to be more manual than Gentoo, then you have to build your own LFS system.

As far as I recall, the second kernel is very new and not considered stable, so this might happen. Well, as longs as it doesn’t take longer than 1 minute to boot up, I don’t think this is an issue. Since my gaming rig takes about 10 minutes to boot into Windows 10, anyways…

I use Debian 10 Buster KDE with the 4.19.0-1-amd64 kernel on my 4GB RAM and 5 year old i5 laptop and it boots up within 15 seconds, easily.

My friend was using this as his main distribution and the problem he had with it, that some issues never really get fixed and the updates that came with this point-release model were usually adding new unnecessary features and not fixing bugs, at all. There were also some issues with the 32-bit version of the distribution, I think they discontinued the release of that, or something similar to that.

This and the fact this distribution is using Openbox, reminds me strongly of Crunchbang #! when it still was alive. I got to know this WM with Crunchbang 12/13 and it definitely has many advantages compared to other WMs/DEs, especially when it comes to lightweightness. It wasn’t completely my type of thing, especially when nowadays there is most of the time no need anymore for such an extremely lightweight desktop solution. ( As already mentioned, my little older and document/browsing focused laptop easily handles KDE, without noticing performance issues, at all. )

Another example for why listing your specs is important.

Did you try downloading from different sources or only from a single torrent?

I would’ve commented more if I knew your hardware, because some of the failures might be hardware dependent, so we can’t be sure it’s mostly the distributions fault.

That said, I didn’t comment much on the Arch-based distributions, since this is kind of its own world and I am already within Debian’s world, so it would be too inconvenient for me to try to get used to a completely different concept of managing my own distribution. That’s why I didn’t use any Arch-based distribution since I first time Arch Linux many years ago, which means I can’t really add my 2 cents if I don’t have any.

Same here. I also have at least 2 opinions on several topics.

I will respond to some of your critique points, as they were selective my friend, when rewrite is done :sunglasses:

1 Like

Curious to read this when it’s ready. :slight_smile:

1 Like

is this with an ssd?

Yes, newly bought. It was the cheapest one available though, which means that they tend to have a worse r/w performance than a good HDD once you step over a certain data amount limit in a small time frame.

1 Like

Hi, to answer your point, yes. I tried again yesterday evening (2nd Feb 2019), LinuxTracker and Arch sites. Both failed.

1 Like



is a newer version.

Checksum SHA-1 for Arch 2019.02.01:

1 Like

Thanks for your input.

The this word did take me to a site, not functioning.

I did not bother trying then or yesterday with the checksum as you can see the download throw up a fatal error, then it froze at the 58.3% mark. Thus being useless.


1 Like

The link doesn’t work for me, at all. It should open your default torrent client and mine, too. But it doesn’t do anything for me. It seems to be a bug within Discourse.

Yes, it only works with a complete file. The checksum in my post is for the newer version.

1 Like

@anon56357095 will you try the new version?

I had, as you can see, has that fatal error message, again.

It’s not that important, would have been a useful exercise to see how their install works, first hand. I viewed a YouTube video some time ago.

1 Like

I think this should solve your issue.

If the link above helps you, it means that it is a system-wide setting and it could happen anytime again with any other file sync.


Well, I’ve never come across this issue before and the quick search I had done weeks ago did not reveal anything, thought it purely an Arch problem.

cat /proc/sys/fs/file-max was 320000 and edited the /etc/sysctl.conf file fs.file-max=200000


Wow… I nearly disto-hopped today…

Booted up Fedora 34 on my “newish” 2nd hand Thinkpad E495, and nearly everything just “worked”, and it was allegedly running Gnome 4 on Wayland… and I thought “cool”… then I thought… this looks too easy… maybe I’ll try arch or gentoo instead, or even f–king slackware for pain on top of shits and giggles and that “oh wow, smell the nostalgia!” (aka remembering when I chose IRQ 4 instead of 5 when I recompiled my kernel image)… then I thought further, genuflected even, on my trials and tribulations over a SIX MONTH period in 2018, just to try and get my employer’s Checkpoint VPN SNX client to work on a “linux”… and thought better of it… and decided… nah f–k that sh_it - I’ll stick with what I know for the time being…

Can’t use wayland till those sluggards over at symless port their monolith product (I’ve hunted around for alternatives - and - there aint none! Barrier? It’s just a port of synergy, and they’re asked for crowdfunding for wayland support - and if that works - what’s stopping symless from backporting that wayland code into their product?) over to wayland, and when I want Ghome 4.0, I only gotta wait till October and “do-release-upgrade”…

– edit update –

there could actually come a time, where there’s some “killer app” feature in Wayland that I cannot live without - and - you’ll find me juggling 35 keyboards and 70 mouses (because yes - I sometimes have 2 times more mouses than keyboards, sometimes 3!) across my desktop so I can use that “killer app” feature…

Now just imagine (yeah - I’m dreaming) if that “killer app feature” was keyboard and mouse sharing :smiley: :smiley: :smiley: :smiley:


well it looks like the time has finally come…

I’m gonna distro hop…

The last straw?

F–KING UBUNTU “Installing Updates…” “Do not turn off your computer”…


I only rebooted 'cause I wanted to ensure my keyring was reset, as I’m testing USB FIDO 2FA thingies and wanted to see if I could still get into my Google shit in Brave or Chrome - with, or without, the FOB…

Well - Mr Shuttlecock (sic) - you can F–K right off with that, and then when you get there, you can keep F–KING right off - ad finitum/ad nauseam… next time you’re in space, forget to seal your EV suit when you step out of the ship!

I’m thinking Fedora… Or Debian 11?

Don’t see the point in a Ubuntu derived distro, unless maybe it’s elementary… hmmm… Leaning towards Fedora… I used to be a big SUSE fan, it was my main goto distro in the early 2000’s… But I just dunno these days… been too long…

Lets see how long it takes me to get frustrated when I cannot get my employers SHITTY VPN client working…

Shit! teetering between Fedora and elementary 6… Not going to dual boot…

Contenders :

  • elementary 6 “odin”
  • fedora 34
  • dDbian 11 Bullseye

I think elementary’s gonna be the easiest to get work’s SHITTY (it’s an abomination) VPN client working…

I just hope elementary installer / live is going to figure out how to decrypt my ZFS incrypted NVME system disk…

1 Like

Based on your above sentences, Bullseye could be your friend for a short time only.
It’s quite new now, and I expect some stuff to appear in the backports later, but still, the “cutting egde” will definitely wear off soon. :smiley:
If you change your mind, Debian can be your everyday workhorse, I think.
I ride Bullseye on my laptop since a week or so, and I plan to upgrade my desktop soon - just get some time to do it safely between a finished a project and a newly started one… :grin:

1 Like

I’m test driving elementary 6 on the Thinkpad E495… already wiped / formatted over Ubuntu 21.04… Shame I couldn’t use ZFS encryption, but elementary doesn’t boot with ZFS support, so I guess I’m stuck with LVM on LUKS or whatever…

Bullseye is still using Gnome 3.8… so yeah… won’t be bleeding edge enough for me…

1 Like

Wow - that was quick!

Checked out elementary 6 on LUKS / ext4… didn’t spend long enough to find out…

Installed the elementary tweak too… tweaked it a bit… installed Synergy KVM…

Couldn’t figure out how to make the terminal app semi-opaque / transparent - and realised - YOU CAN’T you need to run dconf editor or sum other such rubbish to get such a basic feature? That’s a show stopper for me!

And much as I like the look and feel of elementary, it’s locked down “tamperproof” nature ends up frustrating the f–k outta me!

So - right now in the middle of installing Fedora 34… stay tuned…

Any PopOS users here? Do they follow Ubuntu closely ? i.e. would PopOS 21.04 force updating during boot up?

1 Like

Would be funny to see you to install Gnome DE on top of Linux Mint :smiley: