One of My Bootloaders is Missing

I have two hard drives, sda and sdb. There is a Mint installation on sda (/ = sda1 and /Home = sda2) and Ubuntu on sdb1. All of it Legacy (i.e., not uefi), and each drive has its own GRUB page.

It was working just fine Friday morning, and Ubuntu was fine Saturday. But Sunday evening, I got the following error trying to boot into Mint:

Error: attempt to read or write outside of disk HD0
Error: You need to load the kernel first
Press any key to continue …

And then it froze. Tried recovery mode, same error. Tried booting from sdb selected from that same GRUB page, same error except it was HD1.

When I boot with F10 and select HD1, my Ubuntu GRUB page appears fine, and Ubuntu starts like normal.
However, if I try to select Mint from that sdb GRUB page, I get the same error message, but no freezing.

I tried updating GRUB, which found Mint, but it changed nothing.
I tested the file systems on sda with the Disks utility, and no problems.
I can browse sda from Ubuntu and even open files there.
I examined the partition tables in GPartEd, and everything looked OK.

Then I tried to fix things.
To err is human, but to err in Linux is Instant Karma.

  1. I ran grub-install /dev/sda. It used i386, and now nothing I do on bootup launches sda, and the GRUB page from sda is gone.

  2. I opened grub-customizer and wrote GRUB to MBR on sda. No effect.

  3. I booted to the CD “Boot Repair Disk” (based on Lubuntu) and chose the default option to automatically fix most boot problems. No help.

At this point, I am nervous about making even more mistakes. Too much Karma to bear. I can live with Ubuntu, so I can wait for a better way out of this.

The GRUB entry for Mint is:

insmod part_msdos
insmod ext2
set root=‘hd0,msdos1’
if [ x$feature_platform_search_hint = xy ]; then
search --no-floppy --fs-uuid --set=root --hint-bios=hd0,msdos1 --hint-efi=hd0,msdos1 --hint-baremetal=ahci0,msdos1 b50b7293-56fa-47df-afef-4dbe28af4c8f
search --no-floppy --fs-uuid --set=root b50b7293-56fa-47df-afef-4dbe28af4c8f
linux /boot/vmlinuz-5.4.0-107-generic root=UUID=b50b7293-56fa-47df-afef-4dbe28af4c8f ro quiet splash $vt_handoff
initrd /boot/initrd.img-5.4.0-107-generic

Any idea what might’ve be the cause of this? Some update maybe?

Only a clearly incorrect clue. I opened the case and moved SATA cables out of my way looking for the brand on the graphics card. It was too gentle a move, I suspect, and if it were an improperly seated connection, the files would not be browsable, SMART-able, etc. But later today, I will try pushing them in better.

Not necessarily. Sometimes the symptoms can be rare and seem benign. What you experience might be definitely related.

1 Like

Mr @Akito was correct. It was as simple as pushing the SATA cable more firmly in. A few remedial tweaks and I am back to normal.

1 Like