Open a mnt drive in terminal but it shows no content with Is command

Hi all, I am trying to open some image files to do a multiple file rename as per the weekly letter.
When cd to mnt then cd to the drive containing the files I get no content when using the ls command.
Disks shows it as mnt/Data500. When I use Nemo it shows all the directories and files.
How can I change the path for this drive so it can be seen in Terminal?
Any help would be greatly appreciated.

1 Like

what about going up a level with cd .. and checking permissions with ls -l there just to make sure read is enabled for your user?

Thanks cordx, I can read all the directories and files, but my problem is the cd to mnt shows my drives but no content. Seems the path to the mnt HDDs is not going to the correct address. When I use DBeaver to open a file it goes to home/myname/mnt/ where it shows drive names but they are empty. I have to go via 'Other Locations/Computer/mnt/ then the drives show and I can access the content.
Quite confusing for me, both paths show the drives, but only the second one shows content.
Seems there two ‘mnt’ locations

1 Like

quite confusing indeed. were you able to rename using the Other Locations path? i don’t think it will help fix anything, but i would also wonder what path lsblk gives.

Could only use the Other Locations in GUI, not in terminal.
When I open a file manager it shows my name and when I open there I get a mnt option but the drives show no content.
When I open the File System and open mnt the drives are there and content available
This is a screenshot of lsblk if that is any indication of what I’m doing wrong.

which distro are you using? is this a network share?

Linux Mint Tessa 19.1
This is a stand-alone PC, wifey uses WiFi from my modem, but we are not using a network at the moment

1 Like

any objections to me adding this to the linux mint category in case one of the mint users sees it and can offer some help?

A screenshot of the two mnt instances
Is there an easy way to move these to the brian/mnt directory from the /mnt directory.
That would solve the dilemma.
Please do so it can only help.

in this instance, can you check the properties (i know i’m using a different file manager. i just want to see if yours has anything similar) and see if it shows the file path like below? i’m wondering if yours has a similar “location” view.

If I could change the path to /brian/mnt/Data500 it would help

That’s usually the correct location, when speaking about GUI file explorer.

Either that is an error or a pathetic atempt to make the pluggables “more accessible”.

Confirming that /dev/sda1 is mounted on /mnt/Data500.

Other Locations is just a fancy way of displaying pluggable drives in the file explorer. It has nothing to do with how the media is actually mounted.

sudo mount -o remount,rw /dev/sda1 /home/brian/mnt/Data500
1 Like

Hi Akito, tried above suggestion but maybe I’m missing something.

1 Like

i see you are in /home/brian/mnt. have you already created an empty /Data500 directory in /mnt?

I think I made a mistake there with the command.
The safe solution that should definitely work:

sudo umount /mnt/Data500 && sudo mount /dev/sda1 /home/brian/mnt/Data500
1 Like

Thanks Akito, that worked. I also changed my other drive using the command but changing sda1 to the other drives path and name. Thumbs up for that!:grin::star_struck:

1 Like

Hi cordx, yes I had already created empty directories for both of my mnt drives. Got the solution from Akito.
Thanks for your help and patience:wink::upside_down_face:

1 Like