Read only Windows partition

I trying to access a Windows partition and I can but only as ‘R/O’. I believe the partition needs to be ‘fsck’ but how do you do that from Linux? I could go back to Windows, but right now it will not boot (another problem).
Some info: fdisk -l shows /dev/sda4 128198758 468860927 340662170 162.5G f W95 Ext’d (LBA)
Partition is mounted at cd /media/easyt50/Data
And the files listed by ls -l shows
drwxrwxrwx 1 easyt50 easyt50 4096 Jun 19 20:40 Music
drwxrwxrwx 1 easyt50 easyt50 4096 Jun 19 21:05 Notes
Then under Notes ls -l shows;
-rwxrwxrwx 1 easyt50 easyt50 144011 May 11 2017 ‘CPU table.txt’
-rwxrwxrwx 1 easyt50 easyt50 152 Dec 23 2017 ‘Den New ONes.txt’
-rwxrwxrwx 1 easyt50 easyt50 2235 Feb 8 2017 Freedom.txt
-rwxrwxrwx 1 easyt50 easyt50 571 Dec 19 2017 Jim.txt
So as far as I can tell, I own the files and directories and I have R/W access to them. But when I open the file ‘CPU table.txt’ it is R/O. That’s why I believe the partition needs to be checked. Searching the Web, I found an answer for Linux, but the procedure no longer works / installs.

what does mtab show for that disk?


here’s a couple links about ntfsfix (i have never used it. just heard of it), but most of what i have read says trying to get linux to troubleshoot ntfs isn’t a great idea. any chance you can clone the disk in case something goes awry?

the first link mentions possibly using the ultimate boot cd which i had used in the past, but don’t recall a chkdsk function. it might be worth a look. the second link mentions hiren’s boot cd which has a lot of interesting window’s utilities, but i haven’t used in years.


Here is the last 5 lines of mtab.

configfs /sys/kernel/config configfs rw,relatime 0 0
/dev/sda7 /home ext4 rw,relatime,data=ordered 0 0
tmpfs /run/user/1000 tmpfs rw,nosuid,nodev,relatime,size=803984k,mode=700,uid=1000,gid=1000 0 0
gvfsd-fuse /run/user/1000/gvfs fuse.gvfsd-fuse rw,nosuid,nodev,relatime,user_id=1000,group_id=1000 0 0
/dev/sdb1 /media/easyt50/Data fuseblk ro,nosuid,nodev,relatime,user_id=0,group_id=0,default_permissions,allow_other,blksize=4096 0 0

When you start your window partition press F8 and chose the options there, I can’t remember the exact things, but this will help as it lists them all - this will only work on that Windows Partition which you must selected to do it. Windows has a habit of becoming corrupted very easily which is another reason I swapped to Linux. If this doesn’t work then it may be the Linux partition that is causing the problem and others can advise on that.


that would appear to be your read-only (ro) cause. a couple thoughts on how to get it to be rw. this command that i learned from @Akito:

replacing /dev/sda1 with your drive /dev/sdb1 and then keeping in mind that you need to create the mount point for it to appear in. something like /home/easyt50/mnt/Data (or wherever you choose) seems like it should work.

the other option is that the disks utility allows you to edit the mount options. when i select my external from the list of drives in the left pane, its description appears in the right pane. underneath a rectangular representation of the disk partition there is a small (farthest right) button that looks like gears. the fifth choice down is edit mount options and i am wondering if you could signify rw there.


the disks utility method worked on my external which was previously rw. i added ro to the line that starts with nosuid,nodev so that it now starts with ro,nosuid,nodev (with the comma and no space between that an nosuid). it appears that then adds the new parameters/options to fstab when the system starts up.

edit: i forgot to add that the disks utility method did require a reboot.

the command line mount/remount option isn’t working for me so i may have given it in the wrong situation or with incorrect syntax for this situation


I was finally able to log onto Windows and perform chkdsk on the partition. Of course, this fix the Linux access to the disk to r/w. Not sure how to fix Window problem w/o just doing a restore.
What I am going to do tho, is copy that partition to a spare drive, then format it to ext4, and then restore it. One more step farther form Windows… LOL.
Thanks for the suggestions. I going to bookmark them for future reference.


Well, I got the r/o problem again. I restored my Windows partition and Windows now boot, but I thought that I would give this a try first.
Fdisk - l shows;
Disk /dev/mapper/truecrypt5: 501 GiB, 537944391680 bytes, 1050672640 sectors
Units: sectors of 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 512 bytes
I/O size (minimum/optimal): 512 bytes / 512 bytes
Disklabel type: dos
It is a bit strange dev b/c it is a TrueCrypt partition. I created a directory tt for a mount point.
sudo mount -o remount,rw /dev/mapper/truecrypt5 /home/easyt50/tt
mount: /home/easyt50/tt: mount point not mounted or bad option.
So it didn’t work. Maybe I did something wrong or maybe does not apply b/c it is a Truecrypt partition.

1 Like

I am confused about what you are trying to achieve. If you want to handle a TrueCrypt volume, just get VeraCrypt and all is well.

1 Like

I usually get r/w access to my TrueCrypt volumes by a different method, but I will check this out.
BTW, you help me solved / correct the other procedure. I have not hear of VeraCrypt.

@Akito, I d/l VeraCrypt but got an error on both the terminal & GUI option. “There was a problem opening the file …”. I do not have any other info. I believe I will stay with TrueCrypt since it seems to work. I just need to boot Windows and chkdsk the partition. Thanks anyway.

1 Like

You need to set it to TrueCrypt mode to be able to open the file.