Parole music player not playing mp3 in Xubuntu

I have recently installed xubuntu 20.04 with Parole media player 1.0.5. Following article Install All Essential Media Codecs in Ubuntu With This Single Command I have done “sudo add-apt-repository multiverse” and tried “sudo apt install xubuntu-restricted-extras” but got “Unable to locate package xubuntu-restricted-extras” so then did “sudo apt install ubuntu-restricted-extras” which loaded packages.

A recommended package was “gstreamer1.0-fluendo-mp3 libavcodec-extra” but when I tried to install this I got “gstreamer1.0-fluendo-mp3 is not available”.

Ran Parole with mp3 file but got no sound although the progress bar showed that the file was being read. The speakers do work since I got sound when the same file was played through Clementine. Clementine worked before loading the “extras”. Ran top while mp3 was “playing”.

I would be grateful for any help getting Parole working.

This may sound like a silly thing to suggest but did you try rebooting after installing the media codecs?

Hi Abhishek thanks for the suggestion, I did reboot after installing the codecs, just repeated to make sure but still no sound. I have reinstalled Parole, should I reinstall the codecs after this? Clive

The sound speaker icon in your panel right click it and left click properties. Left click Run Audio Mixer. Go to Configuration tab along the top, to the right. make sure it is set to Analogue Stereo Output.

No they should be OK try the above and reboot. Hopefully Pulse will kick in, had the same happen to me, also check to see that the sound itself isn’t muted. I have been caught out many times, especially if you’re using headphones, then unplug them. The settings don’t automatically change to default speakers, meaning you need to reboot without headphones plugged in, sometimes though it reboots to speakers being muted, just unmute them.

I missed the part where you said that Clementine player plays audio.

I have never liked Parole, as I don’t think it has been updated for a long time. In my Xubuntu 20.04 I always use Linux Mint’s Xapps they have Xplayer a media player all in one for music and Movies. Not a lot of people like PPA’s but these are trusted.

Hi clatterfordslim, thanks for the reply. I set up config as you suggested but still no sound. I have just found an item on where it suggested starting parole with sudo privilege, this worked. It’s a pain having to start it in the terminal but I guess that somewhere a chmod is required to get it going in GUI form. I will try Xapps if no further progress with parole.

You’re very welcome Clive.
That is weird, no ordinary app should only work with sudo privileges, surely that’s a security risk? I would of thought the Xubuntu team would of tested Parole before hand? If it’s needing to be opened this way, then it has not been updated for a very long time, or something missing to keep up with the latest coding in Linux??

Solved: the Volume etc has to be setup as follows.
Right click on speaker symbol in top panel - select properties gives:
pulse audio panel plugin select - general - run audio mixer gives:
volume control select - playback - parole playback stream- make sure not muted.

Thanks Mark for first suggestion, it put me on right track, sudo etc was misleading.