Password forced on startup


#1

I just did a install for a client on mint mate 19 32 bit
No problems worked first time as always
Except when the client came he then said want it to ask for a password when it starts up like windows does
My error I said log in automatic when did the install
So went in to users and groups to try to change the option from auto log in to password ask for
No option to make the change
Sure it was there before
Checked mate 64 bit on 18 and 17.3 and no option to change log in to password asked for
Checked the internet and found the video for 17 cinnamon and that offers a change
Did the option go away and I did not see the change or am I missing something … do you need 2 users to have that option
Tried terminal commands with passwd -a etc but nothing in help guided me to ask for password
I know the password and it works to do system updates and changes in control panel, install software from control center etc
Client has gone away to play with machine but sure he will be back and ask again … as he is coming from Vista with a 10 year old machine he still thinks rolls Royce for 25 euros bargain… hmmm
Thanks for any help or suggestions
Paul


#2

I am not using MATE so I cannot show you the GUI way.

However, if you want to use command line, try this: https://ubuntu-mate.community/t/disable-auto-login/1461


#3

Or just reinstall–you’ve already spent that much time anyway.


#4

Trouble with re install is 3 part
Already copied user files back on to system in correct places 6000 plus photos etc so long job to copy
Set up all the software client wants to use (chromium, etc)
I want to know for next time I am asked …

Hate when computer knows better than me !


#5

You could try this : https://community.linuxmint.com/tutorial/view/339 . Personally what I would do would be to do a complete back up on an external drive and then just do a reinstall. 10 mins to complete the clean install and then what an hour or less to do anything else. Next time you do this for another do an OEM as that sets a temporary password and then hand it over and let the user set their own password. That way it saves a lot of problems for you


#6

Hi there.
I was just curious and tried a constellation in a VB.
Installed Mint Mate 19 (v2) and configured it to ask for password at startup (in the installer).
Then booted up and had to give password for the user as expected.
Then I went to the preferences for the logon screen and filled in the user that is to be forwarded to the desktop without the need to give password.
Then restarted the virtual machine and landed straight on the user’s desktop without loging on.
After that I did it vice-versa and deleted the user in the preferences.
After a reboot I had to give password for the user again.
So I couldn’t reproduce your situation.

I see, that this doesn’t help your question, but it sure shows, that somehow something is not quite right with your system (?). A blank installation of Mint Mate should allow to switch between having to logon or not.
So the problem may be something else…

Greetings
Fast Edi

P.S. Would have provided screenshots, but they would’ve been in german, so not very helpful


#7

Thanks for trying
Interesting my own screen shots would have been in french so again would only confuse
It appears to work when there is a user and a guest or 2nd user it’s just when there is one user it is not working
Client has gone away to play with system but I suspect he will be back as his knowledge of computing is limited to email and browsers no more
Will set him up a guest and see what happens
Cheers


#8

Hello.
OK, in my test I only had one user…
Weird.