Pendrive in not formating-Help-Post

month ago i made pendrive bootable in my window machine using rufus and after installing ubuntu.I thinked to format that bootable pendrive i am unable to format pendrive. what is issue . i tried much video on youtube and stack-overflow but , it’s not solved.

Install gparted
In Terminal copy and paste sudo apt install gparted
Open gparted with your pendrive in and click at the top Devices then create partition table, hit apply then you’ll be able to format it to fat32 or whatever you intend to do with it?

it’s says cant write to /dev/sdb , because it is opened read only mode.

Open a Terminal and install gdebi with the following command
sudo apt install gdebi
Next go to this link to my Dropbox where Mint Stick is.
Download it then unzip it open up new MintStick folder and from the start at the top left right click the first deb file choose open up with other application choose gdebi and make it default by clicking on make default. I have just installed this on Ubuntu 20.04 I have on a spare SSD so it does work. A lot of them will say error already installed, or not supported anymore, just keep going to the next one through all these dependencies it needs for this program to work. Remember to close gdebi after each install, otherwise it could crash. Once all the dependencies are installed install MintStick do not install mint stick till you have gone through all the dependency files. Once installed insert your USB do not open it, problem with Ubuntu is it automatically opens so hang on a sec and I’ll be back once I’ve sorted the switched off the automount and will carry on with this post.

The problem is USB drives automount with Nautilus file manager. So we need to install dconf-editor
In terminal copy and paste or type sudo apt install dconf-editor
Once installed open it and click OK on the I’ll Be Careful sign that comes up.
Next follow this path in dconf-editor /org/gnome/desktop/media-handling/automount
Next scroll down to the bottom and switch off the switch as I have in the picture below.

Scroll right to the bottom and left click false, then close dconf-editor.
You should be able to insert your USB drive without it auto mounting. I use Nemo instead of Nautilus in all of my Linux desktops, it gives you more choice and customization. You should now be able to use mintstick without it erroring out. Here is a picture of mine installed.