PPA in Linux Mint 20

This problem was with Linux Mint Xfce 20.0 -----> Still learning about these PPA’s.
I went to install s/w that support Western Digital’s ‘My Passport’ external HDD under Mint 20 and got an error. The same procedure worked on Mint 18 and Mint 19. I just used it with MX 19 and it works there also. Here is the command and the output from it.

sudo apt-get install python-pip python-dev lsscsi
[sudo] password for easyt50:
Reading package lists… Done
Building dependency tree
Reading state information… Done
Note, selecting ‘python-dev-is-python2’ instead of ‘python-dev’
E: Unable to locate package python-pip

I don’t even know what ppa it is. Does the ppa have to wait until Mint OK’s it library? Like I said, in Mint 19 and MX 19 the command worked. So, I’m confused. Why does the command work sometimes and not other times?


it looks like it might come down to which packages are available depending on distro version and whether or not where you got the install command updated them for 20. just looking at my ubuntu 18.04-based bodhi 5.1 install, apt search shows

$ apt search python-pip
Sorting… Done
Full Text Search… Done
python-pip/bionic-updates,bionic-updates 9.0.1-2.3~ubuntu1.18.04.1 all
Python package installer

python-pip-whl/bionic-updates,bionic-updates 9.0.1-2.3~ubuntu1.18.04.1 all
Python package installer

since i don’t have any installs or vm’s based on 20, i looked here and found that focal only lists:

Package python-pip-whl

  • focal (20.04LTS) (python): Python package installer [ universe ]
    20.0.2-5ubuntu1: all

which is basically what that last line

seems to be saying.



Since Python 3 is the default Python version in Ubuntu 20.04, I think it should be the same case in Mint 20 as well because Mint 20 is based on Ubuntu 20.04.

For this reason, try and see if the package python3-pip is available on your system (instead of python-pip).

If you are interested in learning about PPA, I have written a super detailed guide here:


for whatever reason, this post reminded me of one of your older ones. if that is what you are trying to install, it looks like the commands have been updated to python 3 (potentially nice catch @abhishek) on the original site.


LOL @01101111, yes, it should ring a bell. About 2 years ago when I got started with Linux Mint it was you and @Akito who help (walk me thru) the install the first time. I saved the install procedure and it worked with Mint 19 and many other distro that I have tried.
So after 2 years, I’ve learned a lot, but I still have a long ways to go. I will need to update my procedure for Mint 20 / python-3.


did you still have a question or concern about ppa’s?

1 Like

I believe I am beginning to understand PPA’s a bit better. I re-read (maybe the 3rd time now) @abhishek guide on PPA’s. Since a PPA is private, then it might be there and again maybe not the next time I go to use it. Also it might be updated and then again maybe not for the next release of a Distro.

So every time I use the apt command, it uses the list of PPA’s found on my system to search thru. And if the item is not found I get the message ‘Unable to loacate package …’. Is this true for all apt commands, even the ones for the Distro itself?


WD support installed for Linux Mint Xfce.
I got the procedure to work with many thanks to @abhishek and @01101111. I also found a web page https://linuxize.com/post/how-to-install-pip-on-ubuntu-20.04/ that was also very useful.

Here’s what I ended up entering at the terminal. Any input / comments about the procedure will help increase my understanding of Linux / PPA’s. The – lines was output messages.

sudo apt update
sudo apt install python3-pip
pip3 --version
–pip 20.0.2 from /usr/lib/python3/dist-packages/pip (python 3.8)
sudo add-apt-repository universe
sudo apt update
sudo apt install python2
–python2 is already the newest version (2.7.17-2ubuntu4).
–0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.
sudo python2 get-pip.py
–python2: can’t open file ‘get-pip.py’: [Errno 2] No such file or directory
curl https://bootstrap.pypa.io/get-pip.py --output get-pip.py
sudo python2 get-pip.py
pip2 --version
–pip 20.1.1 from /usr/local/lib/python2.7/dist-packages/pip (python 2.7)
sudo apt-get install python-pip python-dev lsscsi
–E: Unable to locate package python-pip
sudo apt-get install python3-pip python-dev lsscsi
sudo apt install python-setuptools python-wheel
–E: Package ‘python-wheel’ has no installation candidate
sudo apt install python3-setuptools python3-wheel
sudo pip install py_sg
cd ~; wget https://raw.githubusercontent.com/evox95/wdpassport-utils/master/wdpassport-utils.py
chmod +x /home/easyt50/wdpassport-utils.py
sudo ~/wdpassport-utils.py -u


i think i look back at that page every three or four months when i find a new ppa i want to try just to make sure i am doing so correctly :slight_smile:

i’m not sure i understand the question entirely, but will try to answer what i think i do understand. in the case here it was a matter of the name of the package (python- to python3-) you wanted to install that had changed so your system couldn’t locate it in the mint or ubuntu repositories. the command itself apt install is a bit of an upgrade (of sorts) of apt-get install, but that doesn’t seem like what you were asking so i’ll leave it at that.

many times apt will find something related to what you were searching for like in your first example:

or in the case which happens to me often enough when i type a command incorrectly:

$ apy

Command ‘apy’ not found, did you mean:

command ‘apt’ from deb apt
command ‘asy’ from deb asymptote
command ‘apm’ from deb apmd
command ‘apf’ from deb apf-firewall
command ‘mpy’ from deb yorick-mpy-mpich2
command ‘mpy’ from deb yorick-mpy-openmpi
command ‘py’ from deb pythonpy
command ‘apg’ from deb apg

Try: sudo apt install deb name

times when i am not sure of the exact name of the package i want to install i will try a quick search with apt list or apt search (more detailed).

1 Like

Actually, there is a funny solution for that:

1 Like

Almost yes. PPA means custom repositories. When you use apt to install an application, your system searches for the application in all the repositories added to your system. If it finds the application (with exact same name) in more than one repositories, it installs from the repository that has the newer version of the application.