Printer printing out garbled characters


#1

My wife used W10 on her computer. She was printing a document a few weeks ago and was getting pages of lines on the page that looked like squares. We restarted her computer and printed - same problem - restarted the computer and printer - that fixed it. Here I am on a different computer and OS (kubuntu 18) and Im now having the same issue. When I asked around for help the only thing I hear is delete the print driver from my system and start again. Do we not have any other path other than the Windows remove and install method?


#2

Have you changed the printer cable?
Is it USB?
Just try to use another cable.


#3

Its on the network and I have tried another cable.


#4

When was the printer last working well. If you can remember that and if you have system restore enabled in W10 do a system restore from that point. As it is now working and yes I noticed that then do a restore point and if the problems happen again it should take you back to that point where things worked.

If you have timeshift installed then go back and restore from that in Kubuntu when it was working well. You could also try the same as you did with W10 and that might fix if for you.

If this doesn’t work then the drivers may have become corrupted as they often do in my experience in Windows and the only options that are really left is to re-install them.

I don’t know if you have been to this page as it might help you : https://wiki.ubuntu.com/DebuggingPrintingProblems