Problem getting started with VMs

Well getting back to Linux after being away so long has been a GRAND experience. Real pleased with this DarterPro so far and liking the POP!_OS a lot.

After getting all my normal work flow stuff all set up (mostly anyways, NEVER done tinkering) decided to give VMs a shot. Started with Gnome Boxes but ended up using Oracle VM manager. Oracle set ups are a bit more involved then Gnomes but seem to offer more control once I figured my way around the interface.

I have three VMs set up for starters; Ubuntu 22.04, Mint 21.1 and Debian 12.0.0. I think for now Mint with the Cinnamon DE is probably my favorite. I have all three running with most off my daily work flow things up and running. Which means I can fire up any VM and do everything I normally do without having to switch back and forth between guest and host. All three have multiple shared directories with the host and bidirectional copy and paste and drag and drop working.

Which brings me to my so far unsolved problem. I am unable to get my Debian 12 VM to show thumbnails for .pdf, .png or .jpg files. The default Gnome File app has preferences set to show thumbnails but still doesn’t work and the setup program ‘change desktop picture’ application doesn’t display pictures to chose from just rainbow colored ‘place holders’.

As a test I installed Nemo (Nautilus) and I can bump up file size limit and get the thumbnails to generate. This is nice as I prefer Nemo anyways but still want to get Gnome File working. And bothers me that the thumbnails don’t show in the Setup/Display menu.

Has anyone found this problem in Debian 12 and/or have suggestions where to go from here ? Been reading Duck Duck Go results 'til my eyes began bleeding, seems some folks think problem lies in the thumbnail generating program failing, but why does Nemo work ?

Of note the Nemo app is not following the system dark mode and fires up bright white, haha a real wake up call

Hi Richard,
It would seem the file manager generates these thumbnail things, by looking at the files

It may be that the file size limit is stopping it doing image and pdf files… they tend to be large.

Good to hear you are getting VM setup properly.



Nautilus and Gnome Files are the same thing. Nemo and Nautilus are not the same thing. I can prove this simply, open Gnome Files application, check what processes are running, and there’s
/usr/bin/nautilus - and I can kill it - and my Gnome Files application window closes (which is way better than MS Windows, if you kill explorer.exe, you kill your Windows desktop “shell”, which is itself Windows Explorer).

I don’t run Desktop VMs, usually - I do usually have quite a few headless Linux VMs (i.e. server type stuff) to test stuff for my job, because none of my customers have sandpits to test stuff but every time they drop some new tech on us, we’re expected to be full bottle on it already.

Anyway - both my Linux Gnome desktops, ubuntu 23.04 and Pop!_OS 22.04 have thumbnails out of the box.

I did notice something with Ubuntu 23.04. The file / open / save dialog boxes didn’t initially show thumbnails (note - they don’t show ANY thumbs in Pop!_OS (Gnome 42.5) in file operation dialogs from applications (e.g. browsers, open office), but then it started, and it wasn’t something I did, I guess I maybe just had to wait a bit? This has ever been the case since Gnome 41 - and I HATE it (no thumbnails in application open / save dialog boxes [“file operation”]).

Gnome 3.x would display thumbnails e.g. in Chrome, e.g. you see a picture on a website, you right click on it to save, but then you notice the thumbnail that you’d saved before and realise you already had that picture file.

Gnome 41 took that away - Gnome 43 (e.g. on Ubuntu 23.04) put it back, but it’s still a bit “piecemeal” - I have EVERYTHING set to dark mode, but the Gnome 43 file operation dialogs in Ubuntu 23.04 ignore that dark mode setting, so I get light grey file operation dialog.

Note: file operation dialog in Gnome 41+ is NOT Files nor Nautilus, it’s some kinda widgety thing - i.e. something baked into the DE. All my Gnome 41+ experiences, I’ve had default behaviour of thumbnails when I chose to display things by icons instead of lists, and I can zoom in and out to enlarge the thumbnails (not just images, but PDF, and mp4 / mkv video files too)


Hi Neville

I believe you are exactly right, same conclusion I came to.

Problem is, Nemo (File Manager I installed) lets you choose “Display Thumbnails” and “for files less than (choose size)”. So it can be made to work.

GNOME Files (the default File Manager with my Debian install). Lets you choose “Display Thumbnails” but has no size limit that I can find. And therefore it fails to display.

The Setting Manager must use the default file manager, because when I open Settings/Appearance/Background it doesn’t display thumbnails of your choices but just shows rainbow colored place holders.

Not a deal breaker but one of those things that make you go Huh!!!

Thanks, it has definatley been a learning experience VERY enjoyable :upside_down_face:

1 Like

Cool, thanks for setting me straight. Sometimes I type faster than I think, And I type very slow so … :roll_eyes:

Same here both my POP!_OS and Ubuntu 22.04.2 are using Gnome DE 42,5 and worked right out of the box.

I think you have closed in on the problem. My Debian 12 VM DE is Gnome 43.4, that is the smoking gun or at least points me in the right direction.

Thank you for sharing. You are “the man”.

Despite what I wrote earlier - I am seeing some inconsistencies in Gnome 43 on Ubuntu 23.04…

One folder (in the save dialog box) has no thumbnails for jpg files :

Go up one folder to the parent and there ARE thumbnails!

I seem to remember some script or command or CLI program you could run that would rebuild your thumbnail cache, I suspect whatever it was, was probably Gnome 3 specific and wouldn’t work in Gnome 4…

This is so utterly inconsistent, it’s no wonder that new users are deterred from Linux (although I’d NEVER recommend new users try a non LTS release).

Aside from inconsistencies with thumbnails, Ubuntu 23.04’s inconsistent “Dark Mode” is irritating :

I have AWFUL eyesight, and colour-blindness - until that line is highlight selected, I CANNOT read it - I can barely see the lines under it too, and it’s kinda visible on this screen I’m typing on - but it’s ALL illegible on the laptop screen I took that screen shot on!

I actually miss Gnome 3, kinda, sorta… Have seriously considered about going back to Ubuntu 20.04 because of how damn ugly and inconsistent Gnome 4x is!


Good (well not really good), but I was beginning to think I was loosing my one last good brain cell and just imagining the whole thing. :rofl:

Yes, these bleeding edge releases are a real hoot … :sweat_smile: not for the faint of heart at times, The Ubuntu 22.04,2 (latest LTS release from Ubuntu mirror) seems smooth as silk and I would recommend for new folks.

YES IT IS, startles me when it opens sometimes.

Thanks for taking time to look at this and sharing.

1 Like

After doing a bit more digging this looks like an old problem (with other older GNOME DE releases) may be reappearing. Seems maybe the default thumbnailer program (may be glitching).

Looks like most folks fixed by replacing the default thumbnailer program (gnome-desktop-thumbnail.c) with convert, gdk-pixbuf-thumbnailer, or even rolled their own.

To make things goofier seems the Thumbnailer Entry text file that drives this whole wacky train can be in either ~/.local/share/thumbnailers and/or /usr/share/thumbnailers.

And sometimes both which may expalain why I can make Nemo work but not Nautilis.

Seems I at least have a place to begin looking.


This is the offending Debian Gnome 43,4 VM I have been rambling on about.

As you can see the Nemo (file prgm) on left while it doesn’t follow system dark mode setting it can at least display thumbnails.

Where as the Nautilus on right while it follows dark mode, it fails miserably with thumbnails.

And these are the lovely background choices the Setup program gives you … :rofl: :rofl: :rofl:


Looks like the problem with inconsistent dark mode with Ubuntu 23.04 has been acknowledged and being patched.

“Ubuntu version of libadwaita not respecting the light/dark choice*” is a quote from from Ubuntu Forum and the fix is coming in a patch, maybe if I read this right …

Fingers crossed :roll_eyes:

1 Like

Dan found a work around for this (at least until they get it patched.

Install GTK3 Theme Switcher extension, then in the setup tab select Adwaita-dark (or your favorite dark theme) as both the Light Theme and the Dark Theme.

This way no matter which theme the offending application chooses it gets dark … :+1:

1 Like

Cheers mate… it’s not a huge “thing” for me right now - Pop!_OS on my main desktop with 2 x 32" QHD monitors is consistently dark, everywhere I want it darker (reminds me of a great Leonard Cohen song “You want it darker”).

Only happens on my Thinkpad running Ubuntu 23.04… I mostly don’t notice it… and considering going back to Pop!_OS on it anyway. I only switched to Ubu from Pop! during a bout of distrohopping, in the hope that something would address my WiFi issues - turned out it was the shonky realtek mini PCIe card - replacing it with an intel fixed it - so I might go back to Pop! - as I prefer it to Ubuntu - it’s not a huge difference from Ubuntu, but I prefer it.

1 Like

Same here, very pleased with the Pop!_OS, it just works! And all the cosmic extensions really make work flow sing for me. I keep nothing on desktop or docks. Learned to navigate all through the gestures on track pad and turn on bluetooth mouse only to play game now and again.

The rest are all in VMs mostly to see if I can get them working and learn about the differences. Right now I think my favorite of them is the Debian 12 Plasma and Mint Cinnamon a close second.

Next problem to work through is getting Dolphin (on my Debian VM) to see the Host shared directories, Not really a deal breaker as it has Nemo and Nautilus up and running. Just feels like a challenge … :rofl: