Problem uninstalling pycharm latest version from linux mint

I am Linux mint user and I have an intermediate experience with Linux. I use it for software development, web development, machine learning, deep learning, etc. I almost every time use jupyter notebook or vs code for most of my work, but recently I installed PyCharm [2020.1.3] on my Linux because I use it on my mac. But few days ago when I tried to uninstall it from my Linux Mint 20, it didn’t worked. I surfed through tons of articles on github, stackoverflow, It’s FOSS, quora, etc. I tried tons of different commands and I tried every possible way to remove it. But nothing worked. I don’t even remember how i installed it. PLEASE HELP ME

did you install it from the command line or the software center?

I suppose that is hardly believable as all JetBrains products are, to my knowledge, available only here:
https://www.jetbrains.com/products.html#

It would be also very helpful, if you would explain, what exactly you tried to do.

Usually, JetBrains installs their products with shell scripts or you just download a folder with a run.sh in it and run it just like that, without any installation.

Therefore, it would be nice if you would list all methods you tried to remove the installation, as you probably haven’t tried the most obvious one:
Delete the PyCharm folder.

1 Like

this link describes installing with snap. this one describes snap (as well as how to remove) and installing from download (removal also).

1 Like