Problem with usb stick?

Hi altogether,

I´d very much like to listen to your opinion on a certain matter.

Lately it so happened that one of my USB sticks (which are permanently connected to my PC via a hub) wasn´t mounted which would have been the case as per normal.
That I recognized as the stick wasn´t visible in the file manager.

Making use of gnome-disks I found out there wasn´t a respective entry either. Hmm, pretty weird. :thinking:

As a next step I disconnected the stick and used another port (this time a physical port of the PC itself). Now the stick was recognized and immediately mounted. :slightly_smiling_face:

After that I connected the stick to the original port of the hub again and this time it worked even from here! :slightly_smiling_face: :slightly_smiling_face:

I repeated the procedure two times more and the USB stick really seems to be working again.

But I´m still at a loss for words right now trying to imagine what could have the case in the beginning. :question:

Has anyone of you got an idea?

Many thanks in advance.
Greetings from Rosika :smiley:

my system: Linux/Lubuntu 20.04.2 LTS, 64 bit

Actually, I had exactly the same issue once: A pen-drive wouldn’t be recognized at one USB port (on the front). Switching it to a port on the back solved the issue. Later, it would also work on the front side.

I never gave it much thought, just mentally filed it under “inexplicable phenomena”.


Hi @Mina,

how nice to see you here again , :smiley:

Thanks a lot for your answer.
Well, if nothing else it´t good to know I´m not alone with this phenomenon and that it (hopefully) doesn´t necessarily have to be considered something serious. :relaxed:

Perhaps this might have been a (temporary) contact issue…

I was also using another USB stick until recently and this one really stopped working as it cannot be mounted anymore and seems to have lost its partitioning.
But this is something different as gnome-disk still recognizes the stick as being connected.
Right now I´m still in the process of trying to save some of its contents with testdisk/photorec ( TestDisk - CGSecurity ).

Curious though that both phenomena occured after having done my fresh/clean install of Lubuntu 20.04. :pensive:

I so hope that this is just a coincidence. It cannot have something to do with Lubuntu itself, can it? :flushed:
Or should I be worried?

Many greetings.
Rosika :blush:

1 Like

Hi Rosika,
No I don’t think Lubuntu is the cause, it could be bad connection or not enough power getting to the hub.

Is The hub USB 2 or 3?? Sometimes power to the hub can be the cause, especially if the lead to the hub from your computer is to long or you have over loaded the hub and it is not powering everything equally. Also is your USB stick USB 3 or 2??

SanDisk ones are backwards compatible with USB 2 and I can highly recommend them. Weird things do happen with computers, as I have seen first hand, scouring the Internet for an answer as my computer would not do what it done the day before, then after not finding an answer online a simple reboot was all it took to get the thing going again, for some odd reason.

1 Like

I don’t know any stick model with USB 3 support, that is not compatible.

1 Like

There are some out there that are not backwards compatible, or at least when I shopped round for some there was. Here is a link to a website about USB 3 compatibility.

I do not see any mention in this article about peripherals with USB 3.0 support not being backwards compatible. The whole article is talking about a different issue, that nobody will experience anymore, except they are using 10+ year old computers.

Exactly as a lot of people on this forum do use older hardware.

That does not matter anyway, because, as I already explained, the issue described in the article you linked has nothing to do with backwards compatability of a USB 3.0 stick…

Hi all,


Thanks a lot for your reply, Mark.

Phew, that´s comforting. Glad to learn that. :kissing_smiling_eyes:

I agree, this should be more likely.

I found out that the respective stick is
Device 003: ID 05e3:0727 Genesys Logic, Inc. microSD Reader/Writer .
Weird though that it´s marked as “microSD Reader/Writer” despite the fact that it´s a USB-stick.
Yet this has always been that way (for years now).

Well, it turns out it´s USB2.0.
As is the hub.
It´s really a small simple device, rectangular in shape and sporting 4 USB-ports.

Despite the good news I´ll probably want to purchase a USB stick (just in case). It´s certainly better to have one handy if need be.

Can you recommend SanDisk as a brand?
Tnx so much. :slight_smile:


Thanks for your views as well. :+1:

1 Like

Yes I can, they are all I use as USB sticks and SSD Drives too. I have 32GB USB sticks, all of my computers are kitted out with 1TB SSD Drives too and 2TB ones for gaming through Steam. I recently upgraded my PS4 to 2TB SanDisk SSD too. Their products are very reliable, prices are fair too.

1 Like

I think all these recommendations are more or less useless.

Exhibit A:

@clatterfordslim can recommend them and I know people that can. I, however, cannot recommend SanDisk at all. Their products break all the time and I constantly had problems with them. Then I stopped buying SanDisk altogether and used them only if I got some for free.
Since then I do not have issues, because I do not run SanDisk products anymore, except a cheap 20 bucks SSD, that I don’t care about, even if it would break. But I wouldn’t trust any SanDisk product, by now.

I usually buy Transcend products and am very satisied with them. Every company has its strengths and weaknesses, but I was happy with a majority of products they sold to me.


If I find the place I put them in, I can take a photo of the pile of SanDisk SD cards that broke (pretty much all), while their Transcend counterparts still work today. :wink:

1 Like

Are you heavy handed then? As I have dropped my main 32GB SanDisk Stick so many times that it has not broken, plus the great thing I like in my opinion is the shutter, that closes the USB when not in use. All mine are USB 3.0 and have had no problem with them. I guess silicone luck comes into the equation too?

Apparently you missed that sentence. Just because nothing happened with your SanDisk devices, does not mean anything.

If you still want to make dick size comparisons: I assure you, that I have plenty more electronic devices in a single room than you at your entire home. :roll_eyes:

Hi @clatterfordslim and @Akito, :wave:

thanks to both of you for your opinion and advice.

I see views on SanDisk products are mixed. But good to know Mark has had some positive experience with it. :slightly_smiling_face:

I wouldn´t have thought of Transcend. So thanks to you @Akito for the suggestion. :slightly_smiling_face:

In the meantime I tried to recover some files from the no-longer-mountable usb flash drive (see post #3).
As it seems to have lost its partitioning (just “unallocated space” says gnome-disks) it cannot be mounted anymore.
I gave photorec a shot and indeed it seems there are files that might me restored.
But as it´s a 64 GB stick the process would go on for hours on end. :thinking:.

Plus: anything recoverable would be recovered.
So I stopped the process and had a look at the result (so far). There were even mp4 film files which had been deleted on the stick in the first place.

The thing is: I need just a dedicated set of files, not anything which had ever been on the stick. :wink:

For this I tried testdisk in the hope of possibly making the stick bootable again (without loss of its present contents).

Yet this I couldn´t achieve.

Seems I got stuck. :frowning_face:
Never mind. I tried all I could.

Thanks a lot for all this input of yours. :hearts:

Many greetings.
Rosika :slightly_smiling_face:

1 Like

Two thoughts:

I’ve had occasions where a USB stick wouldn’t mount when placed in a socket where it used to work. Usually this is cleared up by shutting off the computer, waiting 30 seconds or so, and then re-starting, i.e., a full power cycle, not just an immediate re-boot. The OS sometimes stop listening to a particular socket. I think there’s a command that does this (but I don’t know it) and it seems to happen by itself now and then.

Another possibility is that the USB stick is failing. They do have a finite lifetime. Most of the sticks last for years but I’ve had a few that died young, especially the really tiny ones that I keep with my car keys. (BTW, they were not SanDisk brand.)

All machines eventually fail. Plan for it.

1 Like

I’ve had same issue multiple times and always blamed the thumb driver or SD card. Usually shutting down and a ‘cold boot’ fixes things
I only have USB 2 and an old laptop. (until I get around to putting new hard drive in desktop)
The most reliable thumb drives I have are LG 1Gb I bought probably 15+ years ago when prices were still a bit crazy ($80~$100 for 1 Gb)
I also have several drives (32~64gb) that worked one day but refuse to mount the next (or even later same day) even though they were properly removed. It’s quite annoying when an almost new flash drive stops working.

1 Like

Hi all, :wave:

thanks so much for providing your views on the matter.


Good to know that such a thing is possible.
Yet in the case of my non-bootable stick this wasn´t the case.

That seems to be it.

My other stick however does work now (after having switched ports). Let´s hope it stays that way. :relieved:

Thanks Don for the info. :hearts:


Hi Peter,

Me too. My Lenovo H520e just sports USB2.0 ports.
I see your experience with drives hasn´t been untainted either. I think we all have to put up with the state of affairs. :blush:

Thanks for your info.

Greetings to all from Rosika :slightly_smiling_face:

1 Like