Problems after installing themes and icons in xfce

Hi all, :wave:

yesterday I ran into big difficulties after having tried to install themes and icons. :frowning_face:

I read the article “11 Themes to Make Xfce Look Modern and Beautiful
on 11 Themes to Make Xfce Look Modern and Beautiful
and was intrigued to learn how easy it should be to enhance the look of the desktop on an xfce system.

As I´m running Linux Lite 6.2, which makes use of the xfce desktop I thought “why not giving it a try”.

I followed the instructions on the page and also the links given.

As I was especially interested in the “Sweet” theme I got hold of the packages “Sweet-Ambar-Blue-Dark-v40” for themes and “Sweet-Purple-Filled” for icons.

I created the folders .themes in the home directory and .icons, also in the home directory, respectively.
I unpacked the packages and put them in the newly created folders.

Running the “appearance” application showed me both the new theme and the new icons were available.

So I decided to use them and here the problems began. :slightly_frowning_face:

Fortunately I have conky running all the time, otherwise I wouldn´t have noticed that the system was suddenly using too much RAM, much too much. :astonished:

With every programme closed it showed 50 % of RAM usage. It should´ve been 28 %.

BTW: I have 4 GB of RAM available.

I should´ve taken a thorough look what process was using so much of the RAM, but unfortunately I panicked in this situation so the thought hadn´t occurred to me. :worried:

But I think it was a process preficed by xfce4[…]. That´s all I can remember.
It could´ve been xfwm4 as well.

So I opted for a reboot, to see if the problem remained. Unfortunately it did. Nothing had changed.

O.K., I thought. It´s a cold start then. That should take care of what´s amiss. But no: even after a cold start: 50 % of RAM usage with no process started (aside from conky).

The next step was to revert the system to my latest timeshift snapshot. It was taken on July 1. I was pretty sure that would solve the problem.
I was stunned to see that nothing had changed, again :exclamation: :hushed:

What? Can this be possible? The only explanation I can come up with is - if I´m not completely mistaken - timeshift excludes some paths by default. I´d have
to look up which paths these are…

I grew more and more desperate. So I thought: employing clonezilla to sort things out should be the only thing that I could do now.

My latest backup was dated June 25. Oh well…
I could restore the root partition and luckily it woked this time. :relieved:

clonezilla restored the whole of the root partition of course, so even the paths obviously not covered by timeshift were taken care of by clonezilla.

What a relief. So I´m back to 28 % RAM usage after a cold start. :smiling_face:

Of course I had to take care of the updates I had lost and a few things more…

But some questions still remain:

  • Can installing a new theme and new icons indeed have such an effect as described above?
  • Wouldn´t there be a simpler way of fixing the problem?
  • Am I correct in my assumption that timeshift omits certain paths by default and that one of these paths wre affected by the problem?

To be clear:

I don´t want to add new themes and icons anymore. I think I´ve learnt my lesson. I´m glad that everything´s back to normal again. My questions are rather of a theoretical nature.

Thanks a lot in advance.

Many greetings from Rosika :slightly_smiling_face:

Hi Rosika,
I think it is likely that Timeshift omits those directories that are populated every time you boot - ie /dev, /proc, /run, /tmp, …
I cant see how omitting those would cause what you have experienced.

Does Timeshift restore your home directory?
If it does not, then there may have been dot files in your home directory that were causing the problem.
I assume clonezilla would have restored everything, including your home directory?

Just ideas… I cant answer your question.


1 Like

Hi Neville, :wave:

thanks a lot for your reply.

Ah, that´s it. Thanks for the clarification.

Well, then my theory must be false. Like you said:

It´s a mystery to me then. Timeshift should definitively have reverted the root partition to its last working state. :thinking:

No, actually not. It´s configured in a way that it just handles the root partition. The home partition remains unaffected.

YesterdayI was thinking along those lines as well. But it cannot be.
Like I said: nothing was changed on my home partition and clonezilla still sorted out the problem in spite of the fact that it dealt with the home partition only.

It´s a huge mystery to me … :thinking:
Thanks a lot, Neville.

Cheers from Rosika :slightly_smiling_face:

By default, Timeshift excludes /root and the home directories. At least that’s the default on Mint.

1 Like

Hi again Rosika,

How do you know that?
Did you check the hidden dot files ( files whose name begins with ‘.’)

clonezilla still sorted out the problem in spite of the fact that it dealt with the home partition only.

You only restored the home partition… not the root partition?

More questions


1 Like

@easyt50 :

Thanks Howard. My home partition is excluded as well.

@nevj :

No, no, Neville. I didn´t restore the home partition. I just restored the root partiton with clonezilla. I did a partition restore and chose just to restore the root partition.

timeshift with me is configured to use its default settings, this way it doesn´t cover the home partition, if I´m not completely mistaken… :thinking:.

The thing is: timeshift and clonezilla should´ve done the same thing: only restore the root partition.

Cheers from Rosika :slightly_smiling_face:

Oh, then we have a real mystery to solve… love that

Did timeshift really restore a copy of the root partition from before you made the
fatal modifications?

Well, I should think so.
The problem I ran into was created by me only yesterday and the timeshift snaphot was from July 1.

Therefore I was very surprised that employing timeshift didn´t have the desired effect.

It does not add up.
Can we assume timeshift is reliable?.. Does it wipe the partition before it restores files?
I know clonezilla does. I know that if you install on an existing partition without wiping it first, you get a mix of old and new files. I wonder if Timeshift is like an install?

I should think so. In the past I employed timeshift a few times (even with some other people) and it seemed to have worked reliably.

Hmm, I don´t know.

All I know is that timeshift can be configured to use either rsync or btrfs as snapshot type.
I opted for rsync. So I think it´s just a matter of syncing… :question:

It would depend how it calls rsync
I mostly use rsync in archive mode… ie dont remove any files in the target that are not in the source.
but you can make rsync delete files from the target, it deoends on its options

You see what I am getting at… if timeshift just copied stuff back without deleting anything, then there is your explanation of the mystery.

1 Like

Yes, I see what you mean, Neville. Thanks a lot. I guess that´s the explanation. :+1:

Yes, I will try to investigate.

So if the themes installation caused any additional file(s) to be created these wouldn´t have necessarily been deleted by timeshift when using rsync in archive mode…

…whereas it´s a different case with clonezilla. It just exchanges the installed partition with the backupped partition as it is.

Thanks, Neville. That must be it. :+1:

Many greetings from Rosika :slightly_smiling_face:

If that is what happened, you have just uncovered a major flaw in timeshift

Thanks Neville,

yes, you´re right: the sane defaults should´ve been to delete files that are not present in the timeshift snapshot.

It would take some research to find out what the timeshift settings (regarding rsync) are, if it can be done in the first place.

But at least we have a possible (even: probable) explanation now. That´s worth a lot. :wink: .

Thank you very much for your help, Neville. :heart:

Many greetings from Rosika :slightly_smiling_face:

Does Timeshift have a settings menu?
It might have something like “Erase filesystem before recovery”

There is a big difference between clonezilla and timeshift

  • clonezilla recovers partitions
  • timeshift recovers filesystems
1 Like

Hi Neville, :wave:

Well, it does have a settings menu but I couldn´t find an option like “Erase filesystem before recovery”.
There doesn´t seem to be a way for the user to tweak the setting of how exactly the “rsync”-version works.

This is all the man pages have to say regarding rsync:

timeshift is a system restore utility which takes snapshots of the sys‐
tem at regular intervals. These snapshots can be restored at a later
date to undo system changes. Creates incremental snapshots using rsync
or BTRFS snapshots using BTRFS tools.

–snapshot-device Specify backup device (default: con‐
–yes Answer YES to all confirmation prompts.
–btrfs Switch to BTRFS mode (default: config).
rsync Switch to RSYNC mode (default: config).
–debug Show additional debug messages.
–verbose Show rsync output (default).
–quiet Hide rsync output.
–scripted Run in non-interactive mode.
–help Show all options.

Thanks for putting it so clearly.

So if in doubt, clonezilla seems to be the better option.

Thanks a lot, Neville.

Cheers from Rosika :slightly_smiling_face:

All the howto writeups say that timeshift when restoring puts back an exact copy of the former state of the OS. ie it erases everything then restores?
We think it did not put back a clean restore in your case?
So is it always wrong, or was your case some unique gliche?
We dont know.

It seems that way, otherwise the initial problem with higher RAM usage should´ve been solved.

Yes, quite so. I don´t think there´s a simple way of finding out.

Well, it was a good thing then I had a recent clonezilla backup available.
It certainly pays to stick to a certain backup routine, even if it takes some discipline to do it, I guess. :wink:

Thanks and cheers from Rosika :slightly_smiling_face:

1 Like