Problems mounting exfat SD card on linux

Greetings!

I recently ordered two 64GB exfat-formatted SD cards (SanDisk Extreme PRO) to use with my DSLR camera. Neither would read, and I found this lovely post that explained that I needed to install exfat libraries (https://itsfoss.com/mount-exfat/).

Unfortunately, I’m still having no luck. The cards are not recognised. The Device Notifier does not activate, fdisk -l does not list them. The only indication I have that the OS has noticed them at all is when I run dmesg, and see the following:
[16413.597058] mmc0: error -110 whilst initialising SD card

I can’t find anything on “error -110” in my google searches.
The card works well on my camera, It works just fine on both W10 systems that I’ve tried.

It just doesn’t work on my Lenovo P50’s built-in SD card reader. I’m running Kubunty 18.10, up-to-date.

I’d be most grateful for any recommendations/advice!

1 Like

Try a dedicated one on each USB port.

Please, also give detailed information about the Linux OS you are using.

You may also check out the results for similar errors. If you don’t find the exact error code you experience, it may help if you look for similar ones and what people did/said about those.

1 Like

I have seen that this is your first post here. Firstly welcome to our community. Please will you kindly take a moment to introduce yourself to our community. On the Please introduce your thread :grinning:

As our friend @Akito, has said it would help members of the community to help you if you provide detailed information as he has said, thank you.

In Ubuntu, there is a tool called Disks. Please run it and see if it recognizes your SD Card.

If yes, then (after taking backup of your data) format the SD Card to FAT file system. You may have to create a partition using Disks.

Take a hint from this article about using Disks and formatting it:

Let me know if this works for you.

1 Like

Aloha, abhishek. I found the gnome disk utility you refer to, but it does not show anything on the 64 GB card. I tried a 32 GB card, and it shows up as an SD card. I’d previously tried using the gparted tool as well - and gparted did not even see this card.

For comparison, here is dmesg showing the insertion and removal of the 32 GB card followed by the insertion of the 64 GB card:

[  606.753953] mmc0: cannot verify signal voltage switch
[  606.876283] mmc0: new ultra high speed SDR50 SDHC card at address e624
[  606.882035] mmcblk0: mmc0:e624 SU32G 29.7 GiB  
[  606.889094]  mmcblk0: p1
[  642.834554] mmc0: card e624 removed
[  659.544644] mmc0: error -110 whilst initialising SD card
[  660.884849] mmc0: error -110 whilst initialising SD card
[  662.229042] mmc0: error -110 whilst initialising SD card

I’ve been wondering if its possible that the sd card reader on the P50 is incapable of reading an exfat card. I know that akito recommended an external SD card reader - I will try that as soon as I can get one.

Mahalo, thank you!

That’s so weird. At least it should be recognized but it seems that Linux kernel is rejecting the SD card outright. There is little you can do or I could suggest. Either the card is damaged (but it works in other operating system) or the SD card slot is not working properly (you may try with some other card) or your Linux kernel is the culprit (a distant probability).

I am not 100% sure but the error 110 seems to be ‘connection time out’ which could mean that your Linux system couldn’t read the card properly and timed out.

Quick update! Our college library had a USB3.0 reader that they can loan out, and I tested this as per akito’s recommendation. IT WORKED. So the short term fix, of course, is “get my own SD card reader”. I’m still a bit perplexed why my built-in won’t work, this isn’t an old laptop.

I use 32GB cards in the built-in laptop all the time, so there’s something funny about the combination of the built-in and the 64GB/exfat cards.

If possible, try formatting the SD card (on device where it is recognized) into FAT format. And then see if your system recognizes it or not.

I just tried using the external reader on my linux box to format to FAT32. That format successfully completed, but I get the same error on the built-in card reader.

Re-insertion with the external reader shows the FAT32 formatting, it just won’t work on the built-in.
I’ve never had a problem with the built-in before, it works just fine with 32GB cards (and smaller). It seems that there is something about the hardware of this brand/make of card that is making it unreadable.

I agree.

.
.
.
.
.

Seems that the problem was simple :slight_smile:
usb port no have energy enough for your SD card.
replace for other usb 3.0 and solved trouble.

SD cards are a pain and you will find that Gparted does not recognise them, especially 64bit. I solved this problem by buying for a few pence a SD card formatter, USB type, that the SD card slots in one end. Micro SD USB 2.0 is it’s official name Link below

After putting in my 64bit SD card into this and firing GParted up it formatted correctly, recognizing it as 64bit and reading the whole card . That’s one, headache out of the way. I take it it is Micro SD cards you’re having problems with?

1 Like

First time I tried to install Ubuntu 20.4 from CD, I had an SDHC card in the SD reader slot of my HP Envy laptop and the installation would hang. That’s when I notice that the error messages were pointing an an SD card. When I popped it off, Ubuntu installed OK.

After a successful install, Ubuntu would not read my SD Card from the laptop slot but interestingly, it would get mounted to my Windows partition after a while. Ubuntu correctly mounts and read regular SD cards (4 G) in the same slot.

Thanks to you, I tried a USB card reader and I can now read the 32G SDHC. It’s interesting that Linux Mint can read this same card directly from the built-in SD reader slot.

2 Likes

Jolting this thread back to life…

On the subject of exfat… It seemed about an hour ago, like the best compromise to share data across Apple and Linux…

So - I formatted an external Samsung T series 500 GB USB 3 / USBC SSD with EXFAT…

Copied all my Virtual Box VM’s there…

Went to copy my main Music folder there (using Drag n Drop in nautilus) and it kept barfing on what at first I thought were folders or filenames with accented characters (e.g. Motörhead must ALWAYS be spelt that way), but no - it turns out it’s symlinks! SYMLINKS?

Do you mean I can’t drag n drop symbolic links onto an exfat drive??? It’s starting to look that way… I shitcanned that drag n drop job, and tried rsync - and there ya go - NO SYMBOLIC LINKS!!! And then a bit of google-fu - soft links not supported on exfat - I can’t believe it myself!

WTF?

WELL EXFAT :
image

Probably easier to get read/write of Apple HFS or whatever it’s called, on Linux… and NTFS can go to the same place as EXFAT…

But the time could well be nigh, for me to read this :
https://openzfsonosx.org/

1 Like