Pseudo Terminal Session number / Mouse Wheel Madness / Tumbleweed updates

Pseudo Terminal Session number

Something looked odd on an instance at work. When you run ‘w’ it shows who is connected via ssh something like below.

john pts/0 login time idle time yada yada
mary pts/1 login time idel time yada yada

All of a sudden yesterday when I connected it showed me with pts/13 even though there were only three or four connections. It’s never done this before. Some of the users were in the pts/0 and pts/1 range. Today I was in the office rather than home but still running over the same VPN and today I was back to the pts/0 and pts/1 range. But there were still some of the pts/15 type connections too.

It just looks odd. Any ideas on some reason for this?

Mouse Wheel Madness

My mouse sometimes does something odd when I close the lid on my laptop and walk away for a bit. Maybe it goes to sleep or something. I can’t reproduce this on demand, but sometimes when I come back and surf the net the mouse wheel is super slow when I try to scroll down the page. Up until a couple days ago I would logoff and logon or reboot. Then I discovered I’d just turn the mouse off (wireless) and turn it back on again to fix it.

Has anyone else seen something similar? It’s just odd but easy to fix.

Tumbleweed updates

I just updated openSUSE Tumbleweed tonight. It’s running as a VM on a pretty speedy laptop, but there were over 1,800 updates to apply. In round figures it took 15 minutes to download the updates (500Mbps download speed) and 15 minutes to apply them.

Jeepers that’s a lot of updates. This is after updating a few times over the past couple weeks. I haven’t been using it long enough to know if that’s normal for Tumbleweed or not. That could be a reason to avoid Tumbleweed if that happens each week.

Does anyone else have some Tumbleweed experience?

1 Like

Tumbleweed yes and other rollers also yes and that is the norm as with rolling releases are heavy on updates size.

Typo :rofl:


sudo lsof -i ,shows bound network ports and the daemon that owns them.

While their running


I wonder if it is a terminology issue… does ‘updates’ mean packages or individual files within packages?
15 mins is not long… A typical fortnightly Void Linux update could take that long and it might be 500Mb of downloads and about twice that in file space.

1 Like

All of these sessions are my username… the x.5.68.12 IP addresses are my VPN connections via NAT (from both of my MacBooks) - the x.22.1.8 are MobaXterm sessions from a Windows RDP jumphost (in the customer’s network)

and - I also noticed an interesting anomaly…

I often type “who am i” (gives a different result to “whoami”)…

But I made a typo and accidentally typed “who ma i” and it worked EXACTLY the same as “who am i”…


On one of my MacBooks :

╭─datripp@loge.local ~
╰─➤  who ma i
datripp  ttys011  Mar 23 19:22
╭─datripp@loge.local ~
╰─➤  whoami

I was surprised that lsof was not installed. After installing I ran it but not sure it tells me anything about the pseudo terminal session numbers. I do see open files and PID among other details.

The updates just kept scrolling past. What I was seeing was aaa.rpm, bbb.rpm, etc.rpm. So not really individual files, but the packages it seemed like.

I didn’t take note of the size. It sure took long enough. I was in a corner of the basement so WiFi would have been a bit slower and I was streaming TV at the same time and my wife was probably on YouTube.

Even after downloading it took 15 minutes to install. Sheesh.

I was on my home laptop composing my original post and didn’t have easy access to the work machine.

Here is what I’m seeing.

Note those IP addresses are all on the same subnet. We have to use VPN to connect and everyone gets the same IP range. Some are single digit, then a big gap, then into the teens.

It really doesn’t matter. Just curious and different than what I’ve seen.

Probably best when the connections (pseudos) are showing up,
or it’s that new cable going in up in your area,
Good Luck tracking the sneaks on your connection_
mm what are they doing mm?

pros and cons
you are refreshing a complete install completely,
you are getting the latest versions of the apps.

It’s not the update size that was a problem,
Manjaro would every two or three updates later would poop itself,
EndeavourOS didn’t have anywhere as much maybe once or twice per year,
EndeavourOS that has a great community.

Tumbleweed are you using snapper on Btrfs it’s a good tool.

1 Like

The pseudoes were showing up but didn’t see anything I could translate to a cause. Oh well.

I’m not really sure what the installation details were for Tumbleweed. I just created a VM and took the defaults at install. It looks and runs nicely. It does keep up with each new kernel and everything else, obviously.

The diggers didn’t cut our cable. I was kind of surprised they didn’t. There has been a lot of that type of fiber pulling for the last several years. It’s just getting close to our house now. It would be nice to get some competition for the one cable company. One of the workers was wearing a vest with a second cable company’s logo on it. So I am hopeful. It’ll still be a good year or more before it gets to my house even though it’s at the end of the block now.

Check your App menu if it there (Snapper) it will be in there.
Rollers are :cool:

And we think they are slow in Oz

No it’s one of the rogues infiltrating online you and other unwary citizens . . .