Question about xscreensaver behaviour

Hi all, :wave:

As I´m using Lubuntu 20.04.3 LTS xscreensaver is installed by default.

I´ve encountered some strange behaviour as far as xscreensaver is concerned and thought I´d post it here to see if anyone may tell me more about it. :blush:

BTW: I´ve already posted the topic in the Lubuntu forum (Question about xscreensaver behaviour - Lubuntu Support - Lubuntu Discourse ) but haven´t received an answer so far.
Perhaps the topic is a bit too strange… :no_mouth:

The screensaver is set to 10 mins; that´s a good value for my purposes.

Sometimes I have text read out to me with a text-to-speech-script I once wrote.
If the reading takes longer than 10 minutes xscreensaver kicks in.

But: I think it shouldn´t, because every now and then I use the space-key of my keyboard.

The background of my action is: I read along the text (e.g. pdf-file) and have to “turn over” a page.
That I do by applying the space-key of my keyboard.

The bottom line is: there is definitively input (by my keyboard) within the 10 minute time frame. :thinking:

However: when I use my mouse within the 10 minute time frame xscreensaver doesn´t kick in.
So it´s just the keyboard which seems to be ignored. :worried:

Curious though:

when xscreensaver is active and I want to get my desktop back it really doesn´t matter whether I use my mouse or the keyboard. Any action is recognized and my desktop is displayed. Even the space-key of my keyboard… :hushed:

Does anyone have any idea why that behaviour is :question:

Thanks a lot in advance.

Many greetings.
Rosika :slightly_smiling_face:

According to the man page, it should respond to keyboard entries as well:

DESCRIPTION
       The  xscreensaver program waits until the keyboard 
       and mouse have been idle for a period, and then runs 
       a graphics demo chosen at random.  It turns off as 
       soon as there is any mouse or keyboard activity.

However, the program is ancient, and I wonder whether it’s not kind of obsolete now.
Modern screens don’t require screensavers, though it makes sense to turn the screen off for the purpose of energy saving.

Perhaps, it would be better to configure the energy settings in your desktop environment instead of trying to teach an old dog new tricks.

Just my 2¢

2 Likes

Dear @Mina, :wave:

thanks so much for replying. :hearts:

Yes, that´s what I was thinking as well.

As I said, the weirdest thing is the space-key action seems to be ignored only when the desktop is in “normal” mode, the effect of which is that xscreensaver kicks in.
When xscreensaver is active the space-key action is perfectly recognized and hittig it immediately ends xscreensaver actions. :thinking:

Well, all that isn´t overwhelmigly important. I just wanted to ask around a bit. :blush:

Anyway, next time i use my tts-script I´ll try hitting another key in order to see if it´s just the space-key…

Thanks, Mina, that seems to be good advice.

Many greetings from Rosika :slightly_smiling_face:

UPDATE:

Hi @Mina, :wave:

just wanted to let you know that in the meantime I´ve used my tts-script once more and could establish one fact.
I had text read out to me (taking well over 10 mins) and flipped the page of the accompanying pdf by using the “Page Down” button instead of the space-key.

The result was just the same. :slightly_frowning_face:

So at least I know now as a fact that any keyboard input (not just the space key) is ignored by xscreesaver.
But only in one direction.
If the screensaver is active any keyboard action triggers the end of the xscreensaver process.

That´s weird behaviour indeed. :astonished:
But as you said:

and I think I´ll best leave it at that.

Thanks so much for your help, Mina.

All the best and many greetings.
Rosika :slightly_smiling_face: