Quite OK image format (qoi / QOI)

Was just reading about this on Phoronix :

KDE Apps Now Support QOI Images, Plasma 6 Development Continues - Phoronix, https://qoiformat.org/, QOI (image format) - Wikipedia


Just tried it out on a jpg from my phone… “convert” program from the ImageMagick suite - natively supports QOI in the version I have on Pop!_OS…

Convert jpg to PNG took a matter of seconds (probably less than 10).

Convert that same jpg to QOI? INSTANT! It was so quick, I almost didn’t believe it. Just tried to paste that into this forum (discourse) but it doesn’t yet support that format :

Unfortunately - while it sounds like KDE users (recent versions) can have native support of that image format, I’m using Gnome and my default (I set it to default) image viewer, Shotwell, is stumped when it comes to displaying a QOI file - note: Nautilus (on Pop!_OS 22) shows thumbnails for QOI images… Note also - MacOS “finder” can’t even show a thumbnail! :smiley: (there’s an installer to fix that on the project’s github)…

Note : also - I changed the default open for qoi files from Shotwell, to Gnome’s “Image Viewer” and I can open it…

I guess I should try the same on Ubuntu 23.04…

Update : Shotwell on Ubuntu 23.04 doesn’t support QOI yet either… So I changed Nautilus (it shows a thumbnail) to use Image Viewer as well - and that worked… But I prefer to use Shotwell (mostly for “crop” feature)…


@daniel.m.tripp ,
Speed of QOI probably depends on the type of image.
It uses run length encoding, so a very grainy image would be
difficult for it, I think.

Hi all, :wave:

such a shame.
I don´t seem to be able to convert e.g. a .png file into a .qoi file.

  • didn´t work with imagemagick:
rosika@rosika-Lenovo-H520e /m/r/f/D/k/kgw> convert Bild233.png test.qoi
rosika@rosika-Lenovo-H520e /m/r/f/D/k/kgw> file *
Bild233.png: PNG image data, 565 x 655, 8-bit/color RGB, non-interlaced
test.qoi:    PNG image data, 565 x 655, 8-bit/color RGB, non-interlaced

Well, it “worked”, but the result was still a PNG image.

  • no success with ffmpeg either:

ffmpeg -i Bild233.png test.qoi
ffmpeg version 4.4.2-0ubuntu0.22.04.1 Copyright (c) 2000-2021 the FFmpeg developers
[NULL @ 0x5571a69b9380] Unable to find a suitable output format for 'test.qoi'
test.qoi: Invalid argument

Perhaps my versions of imagemagick and ffmpeg are too old and don´t support the .qoi format yet.

Many greetings from Rosika :slightly_smiling_face:

1 Like