Raspberry Pi: Blank Screen

I’m struggling to access my Raspberry Pi GUI, which I inadvertently disabled on start up to improve performance; so I’m wondering how to get it back? The media-server running off the Pi still works fine when plugged in, and I can access the files in Filezilla (but not as root), I just can’t add any new features, update software, or fix bugs as there’s no GUI, or even command line, to access.

I’ve tried:

  • Accessing via VNC: I now just get a black screen with an X cursor
  • Accessing via my projector’s HDMI cable: this brings up a blank screen. I’ve tried CTL+ALT+F7, nothing happens.
    – From the projector, I can get to the NOOBS screen, where I can edit config.txt and cmdline.txt, but can’t find an option to re-enable ‘boot to GUI’
    – From the NOOBS screen, I can install the OS again; but boy do I want to avoid having to do that!
  • Accessing via HDMI to laptop monitor - nope, HDMI is an output here, so won’t bring up my Pi

Any easy way back in people know?

First things first: you don’t need any GUI on your Raspberry Pi. Additionally, if you truly had no access to your Raspberry Pi the way you describe you wouldn’t be able to modify anything, anyway.

First thing you need is your credentials to the device, you set up on first installation. Then you need the IP you connect to from Filezilla. Then you just create an SSH connection and have access to the command line interface, which offers virtually infinite possibilities, more than any GUI can currently offer.

If you want to connect from Linux:

If you want to connect from Windows:

Explanation on SSH:

The way your connection through Filezilla is established resembles SSH in many aspects:

2 Likes

Thank you so much @Akito, life-saver. ssh pi@[ip-address] from my laptop was all I needed and bingo, I can update my Pi. So pleased! Thank you for taking the time to post those links, simple solution has saved me days of work reinstalling my media-server…

2 Likes