RasPi4 arm64 -- install .deb don't work: AppImage-file installer?


So I have finally been able to set up a Raspberry Pi 4 with the Ubuntu Mate 20.04.

Now I was about to install LBRY, and ran into a problem because the available download from their page was another architecture than the arm64 that the Pi/Ubuntu Mate runs.

They had an alternative file to download which was an .AppImage file (as opposed to .deb). But I don’t have any default program to run this app once its downloaded: From my research I came across snapcraft: But having switched to Linux for principles of FOSS I found the concept a bit odd, and made a quick research and found some concerns.

Any tips how to proceed here?

Thank you!

It’s just a type of binary. You usually would run it like this:

cd path/to/file

However, if it’s for x86, then it still won’t work.
Best thing you can do is to compile the program on your platform.

Desktop App


If there’s no arm64 deb, then it’s VERY unlikely there’s an arm64 snap, app image or flatpak… not just VERY but probably EXTREMELY unlikely.

I run into this all the time… well not all the time, but often enough for it to be a PITA.

I mostly run Ubuntu 21.04 on my Pi4 systems (I do have a headless Pi4 with 4 GB RAM running Raspbian Buster arm64/aarch64) - because I loathe the foundation’s Pixel desktop it’s butt-ugly, and retrofitting XFCE4 onto arm64 Raspbian is also a PITA, and it’s always an ancient version of XFCE, so I’ve gone with Ubuntu 21.04 running Gnome, and I find it more usable than Buster running XFCE, and I get kernel 5.11…

Just getting armhf binaries working on arm64 can be hairpullingly frustrating… e.g. on armhf raspbian, I can install steamplay (to stream steam games from a remote computer) simple as “sudo apt install steamplay”… If I want to do that on Buster arm64? It’s like a 1-2 hour process, installing multiple libraries and armhf libraries on top of arm64 (and one time - doing this, not sure what happened, but it decided to REMOVE all the arm64 versions of libraries and make my Pi unbootable).

If you can’t find binaries - then I’d suggest your only option, if its OSS, grab the source code and compile it. That’s what I did to make Sayonara play on Raspbian Buster (but it turns out, Canonical include Sayonara in 21.04 arm64!).

There’s one thing I kinda / sorta need - I bought a PiJuice Hat (it’s a “hat” that sits ontop of the pi, and it has a battery - it’s essentialy a UPS) - but - the vendor software does NOT play nice on anything but armhf… So’s I’m planning on running Kali on this (tried once, but when I tried to sync it to my cloud solution - it zeroed half my shit). I’ll probably try Kali (arm64) on this Pi4 again, from scratch, and then try and get PiJuice running on arm64 - because that’s the whole point of Kali really, that it be quite small, and portable… I still can’t believe the Pi Foundation are too stingy to include a LiPo battery charging circuit on the board - there’s plenty of room, and Banana Pi can do it, and Orange Pi, and NTC CHIP, why not Raspberry?

TL;DR - sorry for hijacking your thread…

What @Akito said - read their github page, and try running it from source, that’s your only option really… I’ve no use for this software, but I see the Mac binaries are probably for Intel, which may, or may not, work (using Rosetta) on my ARM64 Macbook M1…

On that github page, there’s link to a “Builde Guid” for arm/arm64 :

Then link to here :

With a big DOWNLOAD button to get some kinda zip file…

1 Like

Sorry for my late answer and thank you for your reply.
I did some searching online about compiling and came out of it a little confused. Could you please quickly explain me how to compile a program, and would it work for this program for example: signal4linux/install.sh at main · br-ut/signal4linux · GitHub
It is x64, but I didn’t find any info on whether it is arm64 (like my Pi) or amd64. Would it work in any case if I compile it?

Explaining how to compile a program may be in the “README” file in te same folder…

There may be a build guide on the github page…

In many / most cases it’s usually something like

make install

or it might be

make config
- or -
make insall

you see there are a lot of variations…

Some stuff uses “cmake” so it might be


and there may be other arguments to give cmake

some source code WILL NOT have a make file and you have to know gcc (or whatever your compiler is - e.g. “gcc thing.c”)

Teaching you how to compile software is way beyond the purpose of any forum like this - you will need to do A LOT OF GOOGLING AND READING…

Also x64 usually means Intel / AMD - and not any ARM architecture :

CISC / Intel AMD :

  • 8086
  • i386 (32 bit)
  • i686 (32 bit with PAE)
  • amd64 (64 bit AMD [and intel, who were late])
  • x86_64 (i.e. almost exactly the same as amd64)


  • arm6l (32 bit arm)
  • arm7l (32 bit arm)
  • arm8/l (??? probably 64 bit ???)
  • arm64 (64 bit ARM)
  • aarch64 (64 bit ARM - essentially IDENTICAL to arm64 - just another name for the same thing)

In many cases above, the 64 bit versions can be made to run binaries from their 32 bit ancestors, with some tweaking… Also note : proviso : ARM is not the only RISC game in town, there’s also Sparc, PowerPC (now only used by IBM), and RISCV, and some implementations of MIPS (e.g. Chinese LongSoon)…

x64 implies Intel / AMD and it cannot run without some emulation layer on ARM (32 or 64 bit). Maybe the best known implementation of emulating Intel x86_64 on ARM(64) is Apples “new” Rosetta 2 (the “old” rosetta “1” enabled PowerPC binaries to run in intel Macs). I believe there is a commercial product to emulate I think it’s called “ExaGear” (I haven’t tried it, so don’t ask me about it, I only read about it somewhere as one way to get Dropbox’s Linux client to run Raspbian) - I don’t even know whether its 32 bit or 64 bit.l

Note - it’s VERY easy to confuse :

  • synergy_1.14.0-stable.67d824b8_raspios_arm64.deb
  • synergy_1.14.0-stable.67d824b8_ubuntu18_amd64.deb

I’ve done it before, not paying attention, using bash / zsh command line completion, and then gotten pissed off when it wouldn’t let me install an amd64 package on my arm64 machine, until the penny dropped and I kicked myself.

Did you even read the page at the 2nd link I sent you, which seems to imply there maybe arm64 binaries you can grab to run it? This would negate ANY need to compile anything.